summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/nonworking
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-multimedia/nonworking
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/nonworking')
-rw-r--r--meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/fix-makefile.patch41
-rw-r--r--meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/search-for-headers-in-staging-dir.patch48
-rw-r--r--meta-oe/recipes-multimedia/nonworking/minidlna/minidlna_1.0.25.bb19
3 files changed, 108 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/fix-makefile.patch b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/fix-makefile.patch
new file mode 100644
index 000000000..96429fd6c
--- /dev/null
+++ b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/fix-makefile.patch
@@ -0,0 +1,41 @@
1Fix Makefile:
2* don't overwrite CFLAGS but append to it
3* use gcc as CC only if CC is not already defined
4* use -I= to include paths
5* fix compile of minidlna binary by removing ${LIBS} dependency
6
7Upstream-status: Pending
8Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
9
10Index: minidlna-1.0.25/Makefile
11===================================================================
12--- minidlna-1.0.25.orig/Makefile 2012-01-18 00:49:01.000000000 +0200
13+++ minidlna-1.0.25/Makefile 2013-02-10 17:46:49.000000000 +0200
14@@ -12,13 +12,13 @@
15 #
16 #CFLAGS = -Wall -O -D_GNU_SOURCE -g -DDEBUG
17 #CFLAGS = -Wall -g -Os -D_GNU_SOURCE
18-CFLAGS = -Wall -g -O3 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
19- -I/usr/include/ffmpeg \
20- -I/usr/include/libavutil -I/usr/include/libavcodec -I/usr/include/libavformat \
21- -I/usr/include/ffmpeg/libavutil -I/usr/include/ffmpeg/libavcodec -I/usr/include/ffmpeg/libavformat
22+CFLAGS += -Wall -g -O3 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
23+ -I=/usr/include/ffmpeg \
24+ -I=/usr/include/libavutil -I=/usr/include/libavcodec -I=/usr/include/libavformat \
25+ -I=/usr/include/ffmpeg/libavutil -I=/usr/include/ffmpeg/libavcodec -I=/usr/include/ffmpeg/libavformat
26 #STATIC_LINKING: CFLAGS += -DSTATIC
27 #STATIC_LINKING: LDFLAGS = -static
28-CC = gcc
29+CC ?= gcc
30 RM = rm -f
31 INSTALL = install
32
33@@ -64,7 +64,7 @@
34 $(INSTALL) -d $(ETCINSTALLDIR)
35 $(INSTALL) --mode=0644 minidlna.conf $(ETCINSTALLDIR)
36
37-minidlna: $(BASEOBJS) $(LNXOBJS) $(LIBS)
38+minidlna: $(BASEOBJS) $(LNXOBJS)
39 @echo Linking $@
40 @$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BASEOBJS) $(LNXOBJS) $(LIBS)
41
diff --git a/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/search-for-headers-in-staging-dir.patch b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/search-for-headers-in-staging-dir.patch
new file mode 100644
index 000000000..573d88c81
--- /dev/null
+++ b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna/search-for-headers-in-staging-dir.patch
@@ -0,0 +1,48 @@
1Search for headers in STAGING_DIR_GOST.
2
3Upstream-status: Pending
4Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
5
6Index: minidlna-1.0.25/genconfig.sh
7===================================================================
8--- minidlna-1.0.25.orig/genconfig.sh 2012-01-21 02:34:13.000000000 +0200
9+++ minidlna-1.0.25/genconfig.sh 2013-02-10 17:12:06.000000000 +0200
10@@ -40,22 +40,22 @@
11
12 # Detect if there are missing headers
13 # NOTE: This check only works with a normal distro
14-[ ! -e "/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
15-[ ! -e "/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
16-[ ! -e "/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
17-[ ! -e "/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
18-[ ! -e "/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
19-[ ! -e "/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
20-[ ! -e "/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
21-[ ! -e "/usr/include/ffmpeg/avutil.h" -a \
22- ! -e "/usr/include/libavutil/avutil.h" -a \
23- ! -e "/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
24-[ ! -e "/usr/include/ffmpeg/avformat.h" -a \
25- ! -e "/usr/include/libavformat/avformat.h" -a \
26- ! -e "/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
27-[ ! -e "/usr/include/ffmpeg/avcodec.h" -a \
28- ! -e "/usr/include/libavcodec/avcodec.h" -a \
29- ! -e "/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
30+[ ! -e "$STAGING_DIR_HOST/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
31+[ ! -e "$STAGING_DIR_HOST/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
32+[ ! -e "$STAGING_DIR_HOST/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
33+[ ! -e "$STAGING_DIR_HOST/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
34+[ ! -e "$STAGING_DIR_HOST/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
35+[ ! -e "$STAGING_DIR_HOST/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
36+[ ! -e "$STAGING_DIR_HOST/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
37+[ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/avutil.h" -a \
38+ ! -e "$STAGING_DIR_HOST/usr/include/libavutil/avutil.h" -a \
39+ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
40+[ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/avformat.h" -a \
41+ ! -e "$STAGING_DIR_HOST/usr/include/libavformat/avformat.h" -a \
42+ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
43+[ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/avcodec.h" -a \
44+ ! -e "$STAGING_DIR_HOST/usr/include/libavcodec/avcodec.h" -a \
45+ ! -e "$STAGING_DIR_HOST/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
46 if [ -n "$MISSING" ]; then
47 echo -e "\nERROR! Cannot continue."
48 echo -e "The following required libraries are either missing, or are missing development headers:\n"
diff --git a/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna_1.0.25.bb b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna_1.0.25.bb
new file mode 100644
index 000000000..9264bc224
--- /dev/null
+++ b/meta-oe/recipes-multimedia/nonworking/minidlna/minidlna_1.0.25.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "MiniDLNA (aka ReadyDLNA) is server software with the aim of \
2being fully compliant with DLNA/UPnP-AV clients."
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=b1a795ac1a06805cf8fd74920bc46b5c"
5
6DEPENDS = "flac libav jpeg sqlite3 libexif libogg libid3tag"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}_${PV}_src.tar.gz \
9 file://search-for-headers-in-staging-dir.patch \
10 file://fix-makefile.patch \
11"
12
13SRC_URI[md5sum] = "d966256baf2f9b068b9de871ab5dade5"
14SRC_URI[sha256sum] = "170560fbe042c2bbcba78c5f15b54f4fac321ff770490b23b55789be463f2851"
15
16export STAGING_DIR_HOST
17
18inherit autotools
19