diff options
author | Abdur Rehman <abdur_rehman@mentor.com> | 2016-05-25 00:07:51 +0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-08 14:55:30 +0200 |
commit | 52213998eb4ead7d24cba012c937bcc25e89c2ca (patch) | |
tree | f5b29e83d80eb229f8321bbf7337dc61ed9181aa /meta-oe/recipes-multimedia/mplayer | |
parent | 1847d0be0b820c720ddf4405d7cca000eef06e23 (diff) | |
download | meta-openembedded-52213998eb4ead7d24cba012c937bcc25e89c2ca.tar.gz |
mpv: Media Player
mpv is a fork of mplayer2 and MPlayer. It shares some features with
the former projects while introducing many more.
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Abdur Rehman <abdur_rehman@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer')
-rw-r--r-- | meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb | 69 |
1 files changed, 69 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb b/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb new file mode 100644 index 000000000..6a258b541 --- /dev/null +++ b/meta-oe/recipes-multimedia/mplayer/mpv_0.15.0.bb | |||
@@ -0,0 +1,69 @@ | |||
1 | SUMMARY = "Open Source multimedia player" | ||
2 | SECTION = "multimedia" | ||
3 | HOMEPAGE = "http://www.mpv.io/" | ||
4 | DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \ | ||
5 | libxscrnsaver libv4l libxinerama \ | ||
6 | " | ||
7 | |||
8 | REQUIRED_DISTRO_FEATURES = "x11" | ||
9 | |||
10 | LICENSE = "GPLv2+" | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb" | ||
12 | |||
13 | SRC_URI = "https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz;name=mpv \ | ||
14 | http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf \ | ||
15 | " | ||
16 | SRC_URI[mpv.md5sum] = "9042bd3fbff2bc8ba0b7fadaa4a22101" | ||
17 | SRC_URI[mpv.sha256sum] = "7d31217ba8572f364fcea2955733f821374ae6d8c6d8f22f8bc63c44c0400bdc" | ||
18 | SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71" | ||
19 | SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b" | ||
20 | |||
21 | inherit pkgconfig pythonnative distro_features_check | ||
22 | |||
23 | # Note: both lua and libass are required to get on-screen-display (controls) | ||
24 | PACKAGECONFIG ??= "lua libass" | ||
25 | PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit" | ||
26 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" | ||
27 | PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive" | ||
28 | PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack" | ||
29 | |||
30 | EXTRA_OECONF = " \ | ||
31 | --prefix=${prefix} \ | ||
32 | --target=${SIMPLE_TARGET_SYS} \ | ||
33 | --confdir=${sysconfdir} \ | ||
34 | --datadir=${datadir} \ | ||
35 | --disable-manpage-build \ | ||
36 | --disable-gl \ | ||
37 | --disable-libsmbclient \ | ||
38 | --disable-encoding \ | ||
39 | --disable-libbluray \ | ||
40 | --disable-dvdread \ | ||
41 | --disable-dvdnav \ | ||
42 | --disable-cdda \ | ||
43 | --disable-enca \ | ||
44 | --disable-libguess \ | ||
45 | --disable-uchardet \ | ||
46 | --disable-rubberband \ | ||
47 | --disable-lcms2 \ | ||
48 | --disable-vapoursynth \ | ||
49 | --disable-vapoursynth-lazy \ | ||
50 | " | ||
51 | |||
52 | do_configure() { | ||
53 | if [ ! -L ../waf ]; then | ||
54 | chmod a+x ../waf-1.8.12 | ||
55 | ln -s waf-1.8.12 ../waf | ||
56 | fi | ||
57 | export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)" | ||
58 | ../waf configure ${EXTRA_OECONF} | ||
59 | } | ||
60 | |||
61 | do_compile () { | ||
62 | ../waf build | ||
63 | } | ||
64 | |||
65 | do_install() { | ||
66 | ../waf install --destdir=${D} | ||
67 | } | ||
68 | |||
69 | FILES_${PN} += "${datadir}/icons" | ||