summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
diff options
context:
space:
mode:
authorBelal, Awais <Awais_Belal@mentor.com>2016-03-17 13:48:01 +0500
committerArmin Kuster <akuster808@gmail.com>2016-04-17 07:41:40 -0700
commit108016f9e7f2659e195abd11083ba733a5b505da (patch)
tree2ca7b73d80bd90dc6dd0ce2470cb02635a7415a2 /meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
parentee18901e78e85a1b42de1380c1dad99390c0bc54 (diff)
downloadmeta-openembedded-108016f9e7f2659e195abd11083ba733a5b505da.tar.gz
mplayer2: fix building with gcc 5.x
This patch works around a potential problem in the theora glue code where it assumes that the compiler will somehow find a function which is not exported explicitly through the libtheora library. Due to this problem the build fails with gcc-5.x compiler. The included patch essentially backports a commit which updates the glue code to use the Theora 1.0 API to eliminate this problem and PNBLACKLIST is cleared for mplayer2. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb')
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
index 2f0369a19..9df4e745a 100644
--- a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
@@ -21,6 +21,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
21 21
22SRC_URI = "git://repo.or.cz/mplayer.git \ 22SRC_URI = "git://repo.or.cz/mplayer.git \
23 file://0001-configure-don-t-disable-ASS-support-when-explicitly-.patch \ 23 file://0001-configure-don-t-disable-ASS-support-when-explicitly-.patch \
24 file://0001-demux_ogg-partially-port-libtheora-glue-code-to-Theo.patch \
24" 25"
25 26
26SRCREV = "2c378c71a4d9b1df382db9aa787b646628b4e3f9" 27SRCREV = "2c378c71a4d9b1df382db9aa787b646628b4e3f9"
@@ -153,6 +154,3 @@ do_install() {
153 install ${S}/etc/codecs.conf ${D}/usr/etc/mplayer/ 154 install ${S}/etc/codecs.conf ${D}/usr/etc/mplayer/
154 [ -e ${D}/usr/lib ] && rmdir ${D}/usr/lib 155 [ -e ${D}/usr/lib ] && rmdir ${D}/usr/lib
155} 156}
156
157# | libmpdemux/demux_ogg.o:demux_ogg.c:function demux_ogg_read_packet: error: undefined reference to '_ilog'
158PNBLACKLIST[mplayer2] ?= "BROKEN, fails to build with gcc-5"