summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/live555
diff options
context:
space:
mode:
authorJoel A Fernandes <joelagnel@ti.com>2011-09-07 05:54:07 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-07 08:07:05 +0200
commitce464aff2f3f5d851e876ce831be78c191587b51 (patch)
tree443618ef24bf8c65559769419d8abd6f8f58f2d8 /meta-oe/recipes-multimedia/live555
parent6e0fb5ec91f5d397b519908e45664f8ce5c64190 (diff)
downloadmeta-openembedded-ce464aff2f3f5d851e876ce831be78c191587b51.tar.gz
live555: Imported from OE classic
Dropped PR=r* and changed LICENSE to LGPLv3 Signed-off-by: Joel A Fernandes <joelagnel@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/live555')
-rw-r--r--meta-oe/recipes-multimedia/live555/files/config.linux-cross17
-rw-r--r--meta-oe/recipes-multimedia/live555/live555.inc54
-rw-r--r--meta-oe/recipes-multimedia/live555/live555_20110314.bb10
3 files changed, 81 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/live555/files/config.linux-cross b/meta-oe/recipes-multimedia/live555/files/config.linux-cross
new file mode 100644
index 000000000..d1277da8d
--- /dev/null
+++ b/meta-oe/recipes-multimedia/live555/files/config.linux-cross
@@ -0,0 +1,17 @@
1COMPILE_OPTS = $(INCLUDES) -I. -O2 -DSOCKLEN_T=socklen_t -DNO_STRSTREAM=1 -D_LARGEFILE_SOURCE=1
2C = c
3C_COMPILER = $(CC)
4C_FLAGS = $(COMPILE_OPTS)
5CPP = cpp
6CPLUSPLUS_COMPILER = $(CXX)
7CPLUSPLUS_FLAGS = $(COMPILE_OPTS) -Wall -DBSD=1
8OBJ = o
9LINK = $(CXX) -o
10LINK_OPTS = -L.
11CONSOLE_LINK_OPTS = $(LINK_OPTS)
12LIBRARY_LINK = $(LD) -o
13LIBRARY_LINK_OPTS = $(LINK_OPTS) -r -Bstatic
14LIB_SUFFIX = a
15LIBS_FOR_CONSOLE_APPLICATION =
16LIBS_FOR_GUI_APPLICATION =
17EXE =
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc
new file mode 100644
index 000000000..8d026a195
--- /dev/null
+++ b/meta-oe/recipes-multimedia/live555/live555.inc
@@ -0,0 +1,54 @@
1# live555 OE build file
2# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
3# Released under the MIT license (see packages/COPYING)
4
5DESCRIPTION = "LIVE555 Streaming Media libraries"
6HOMEPAGE = "http://live.com/"
7LICENSE = "LGPLv3"
8SECTION = "devel"
9
10URLV = "${@bb.data.getVar('PV',d,1)[0:4]}.${@bb.data.getVar('PV',d,1)[4:6]}.${@bb.data.getVar('PV',d,1)[6:8]}"
11SRC_URI = "http://www.live555.com/liveMedia/public/live.${URLV}.tar.gz \
12 file://config.linux-cross"
13
14S = "${WORKDIR}/live"
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17do_configure() {
18 cp ${WORKDIR}/config.linux-cross .
19 echo "COMPILE_OPTS+=" -fPIC "" >> config.linux-cross
20 ./genMakefiles linux-cross
21}
22
23do_compile() {
24 make
25}
26
27do_install() {
28 install -d ${D}${includedir}/BasicUsageEnvironment
29 install -d ${D}${includedir}/groupsock
30 install -d ${D}${includedir}/liveMedia
31 install -d ${D}${includedir}/UsageEnvironment
32 install -d ${D}${libdir}
33 cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/
34 cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/
35 cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/
36 cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/
37 cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/
38 # Find all the headers
39 for i in $(find . -name "*.hh") $(find . -name "*.h") ; do
40 install ${i} ${D}${includedir}
41 done
42 cp ${S}/*/*.a ${D}${libdir}
43 install -d ${D}${bindir}
44 for i in MPEG2TransportStreamIndexer openRTSP playSIP sapWatch testMPEG1or2AudioVideoToDarwin testMPEG1or2ProgramToTransportStream testMPEG1or2Splitter testMPEG1or2VideoReceiver testMPEG2TransportStreamTrickPlay testMPEG4VideoToDarwin testOnDemandRTSPServer testRelay testAMRAudioStreamer testDVVideoStreamer testMP3Receiver testMP3Streamer testMPEG1or2AudioVideoStreamer testMPEG1or2VideoStreamer testMPEG2TransportStreamer testMPEG4VideoStreamer testWAVAudioStreamer vobStreamer; do
45 install -m 0755 ${S}/testProgs/${i} ${D}${bindir}/
46 done
47 install -m 0755 ${S}/mediaServer/live555MediaServer ${D}${bindir}/
48}
49
50PACKAGES =+ " live555-openrtsp live555-playsip live555-mediaserver"
51FILES_${PN} = "${bindir}/sapWatch ${bindir}/testMPEG1or2AudioVideoToDarwin ${bindir}/testMPEG1or2ProgramToTransportStream ${bindir}/testMPEG1or2Splitter ${bindir}/testMPEG1or2VideoReceiver ${bindir}/testMPEG2TransportStreamTrickPlay ${bindir}/testMPEG4VideoToDarwin ${bindir}/testOnDemandRTSPServer ${bindir}/testRelay ${bindir}/testAMRAudioStreamer ${bindir}/testDVVideoStreamer ${bindir}/testMP3Receiver ${bindir}/testMP3Streamer ${bindir}/testMPEG1or2AudioVideoStreamer ${bindir}/testMPEG1or2VideoStreamer ${bindir}/testMPEG2TransportStreamer ${bindir}/testMPEG4VideoStreamer ${bindir}/testWAVAudioStreamer ${bindir}/vobStreamer ${bindir}/MPEG2TransportStreamIndexer"
52FILES_live555-openrtsp = "${bindir}/openRTSP"
53FILES_live555-playsip = "${bindir}/playSIP"
54FILES_live555-mediaserver = "${bindir}/live555MediaServer"
diff --git a/meta-oe/recipes-multimedia/live555/live555_20110314.bb b/meta-oe/recipes-multimedia/live555/live555_20110314.bb
new file mode 100644
index 000000000..b1dbad2f4
--- /dev/null
+++ b/meta-oe/recipes-multimedia/live555/live555_20110314.bb
@@ -0,0 +1,10 @@
1require live555.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=68ad62c64cc6c620126241fd429e68fe"
4
5PR = "${INC_PR}.0"
6
7SRC_URI[md5sum] = "ff65b2c598e970b4b6c8219a1811de00"
8SRC_URI[sha256sum] = "c6ce050a7f9f69901e6f7f81a6745c82d9419e3904a753b2d5db1139caaf6738"
9
10