summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/live555
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-multimedia/live555
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/live555')
-rw-r--r--meta-oe/recipes-multimedia/live555/live555.inc48
1 files changed, 24 insertions, 24 deletions
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc
index 443f81818..966224d7f 100644
--- a/meta-oe/recipes-multimedia/live555/live555.inc
+++ b/meta-oe/recipes-multimedia/live555/live555.inc
@@ -19,36 +19,36 @@ S = "${WORKDIR}/live"
19TARGET_CC_ARCH += "${LDFLAGS}" 19TARGET_CC_ARCH += "${LDFLAGS}"
20 20
21do_configure() { 21do_configure() {
22 cp ${WORKDIR}/config.linux-cross . 22 cp ${WORKDIR}/config.linux-cross .
23 echo "COMPILE_OPTS+=" -fPIC "" >> config.linux-cross 23 echo "COMPILE_OPTS+=" -fPIC "" >> config.linux-cross
24 ./genMakefiles linux-cross 24 ./genMakefiles linux-cross
25} 25}
26 26
27do_compile() { 27do_compile() {
28 make 28 make
29} 29}
30 30
31do_install() { 31do_install() {
32 install -d ${D}${includedir}/BasicUsageEnvironment 32 install -d ${D}${includedir}/BasicUsageEnvironment
33 install -d ${D}${includedir}/groupsock 33 install -d ${D}${includedir}/groupsock
34 install -d ${D}${includedir}/liveMedia 34 install -d ${D}${includedir}/liveMedia
35 install -d ${D}${includedir}/UsageEnvironment 35 install -d ${D}${includedir}/UsageEnvironment
36 install -d ${D}${libdir} 36 install -d ${D}${libdir}
37 cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/ 37 cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/
38 cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/ 38 cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/
39 cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/ 39 cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/
40 cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/ 40 cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/
41 cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/ 41 cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/
42 # Find all the headers 42 # Find all the headers
43 for i in $(find . -name "*.hh") $(find . -name "*.h") ; do 43 for i in $(find . -name "*.hh") $(find . -name "*.h") ; do
44 install ${i} ${D}${includedir} 44 install ${i} ${D}${includedir}
45 done 45 done
46 cp ${S}/*/*.a ${D}${libdir} 46 cp ${S}/*/*.a ${D}${libdir}
47 install -d ${D}${bindir} 47 install -d ${D}${bindir}
48 for i in MPEG2TransportStreamIndexer openRTSP playSIP sapWatch testMPEG1or2AudioVideoToDarwin testMPEG1or2ProgramToTransportStream testMPEG1or2Splitter testMPEG1or2VideoReceiver testMPEG2TransportStreamTrickPlay testMPEG4VideoToDarwin testOnDemandRTSPServer testRelay testAMRAudioStreamer testDVVideoStreamer testMP3Receiver testMP3Streamer testMPEG1or2AudioVideoStreamer testMPEG1or2VideoStreamer testMPEG2TransportStreamer testMPEG4VideoStreamer testWAVAudioStreamer vobStreamer; do 48 for i in MPEG2TransportStreamIndexer openRTSP playSIP sapWatch testMPEG1or2AudioVideoToDarwin testMPEG1or2ProgramToTransportStream testMPEG1or2Splitter testMPEG1or2VideoReceiver testMPEG2TransportStreamTrickPlay testMPEG4VideoToDarwin testOnDemandRTSPServer testRelay testAMRAudioStreamer testDVVideoStreamer testMP3Receiver testMP3Streamer testMPEG1or2AudioVideoStreamer testMPEG1or2VideoStreamer testMPEG2TransportStreamer testMPEG4VideoStreamer testWAVAudioStreamer vobStreamer; do
49 install -m 0755 ${S}/testProgs/${i} ${D}${bindir}/ 49 install -m 0755 ${S}/testProgs/${i} ${D}${bindir}/
50 done 50 done
51 install -m 0755 ${S}/mediaServer/live555MediaServer ${D}${bindir}/ 51 install -m 0755 ${S}/mediaServer/live555MediaServer ${D}${bindir}/
52} 52}
53 53
54PACKAGES =+ " live555-openrtsp live555-playsip live555-mediaserver" 54PACKAGES =+ " live555-openrtsp live555-playsip live555-mediaserver"