summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb')
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb
index c8fa6ca46..00c7ec8c0 100644
--- a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.12.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a37a47a0e579e461474cd03b9e05199d"
6 6
7SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \ 7SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
8 file://configure.patch \ 8 file://configure.patch \
9 " 9"
10 10
11SRC_URI[md5sum] = "e03ff73d77a55e3572ad0217131dc4a1" 11SRC_URI[md5sum] = "e03ff73d77a55e3572ad0217131dc4a1"
12SRC_URI[sha256sum] = "1644308279a975799049e4826af2cfc787cad2abb11aa14562e402521f86992a" 12SRC_URI[sha256sum] = "1644308279a975799049e4826af2cfc787cad2abb11aa14562e402521f86992a"
@@ -19,20 +19,20 @@ EXTRA_AUTORECONF += "--include=acinclude"
19EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}" 19EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
20 20
21do_configure () { 21do_configure () {
22 # Remove old libtool macros. 22 # Remove old libtool macros.
23 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" 23 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
24 for i in ${MACROS}; do 24 for i in ${MACROS}; do
25 rm -f acinclude/$i 25 rm -f acinclude/$i
26 done 26 done
27 cp build-scripts/* . || true 27 cp build-scripts/* . || true
28 rm -rf build-scripts/ 28 rm -rf build-scripts/
29 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR 29 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
30 30
31 autotools_do_configure 31 autotools_do_configure
32 32
33 rm config.log 33 rm config.log
34 for i in $(find -name "Makefile") ; do 34 for i in $(find -name "Makefile") ; do
35 sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i 35 sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i
36 done 36 done
37} 37}
38 38