diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-10-06 20:18:28 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-10 12:33:42 +0200 |
commit | 2935a21d38de8b7130cbd80edfb097f2dac4a1d1 (patch) | |
tree | f934497db18044a68ae4f176bded482a8196dd98 /meta-oe/recipes-multimedia/libpostproc | |
parent | c5af19d6c27c507583bccb55136191d3fb8618a0 (diff) | |
download | meta-openembedded-2935a21d38de8b7130cbd80edfb097f2dac4a1d1.tar.gz |
libpostproc: Add git version
This has been split from libav code during development of 0.9 series.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/libpostproc')
-rw-r--r-- | meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb b/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb new file mode 100644 index 000000000..3620ff064 --- /dev/null +++ b/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "FFmpeg derived postprocessing library" | ||
2 | HOMEPAGE = "http://git.videolan.org/?p=libpostproc.git;a=summary" | ||
3 | SECTION = "libs" | ||
4 | DEPENDS = "libav" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
7 | |||
8 | PV = "0.0.0+git${SRCPV}" | ||
9 | |||
10 | DEFAULT_PREFERENCE = "-1" | ||
11 | |||
12 | SRCREV = "3b7053f46dbfe4662063345245cb00b6acbbe969" | ||
13 | SRC_URI = "git://git.videolan.org/libpostproc.git" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit autotools lib_package pkgconfig | ||
18 | |||
19 | FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math" | ||
20 | BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}" | ||
21 | |||
22 | EXTRA_FFCONF_armv7a = "--cpu=cortex-a8" | ||
23 | EXTRA_FFCONF ?= "" | ||
24 | |||
25 | EXTRA_OECONF = " \ | ||
26 | --enable-shared \ | ||
27 | --enable-pthreads \ | ||
28 | --enable-gpl \ | ||
29 | --enable-postproc \ | ||
30 | \ | ||
31 | --cross-prefix=${TARGET_PREFIX} \ | ||
32 | --prefix=${prefix} \ | ||
33 | \ | ||
34 | --arch=${TARGET_ARCH} \ | ||
35 | --target-os="linux" \ | ||
36 | --enable-cross-compile \ | ||
37 | --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ | ||
38 | --extra-ldflags="${TARGET_LDFLAGS}" \ | ||
39 | --sysroot="${STAGING_DIR_TARGET}" \ | ||
40 | ${EXTRA_FFCONF} \ | ||
41 | " | ||
42 | |||
43 | #| yasm not found, use --disable-yasm for a crippled build | ||
44 | EXTRA_OECONF_append_x86-64 = " --disable-yasm" | ||
45 | EXTRA_OECONF_append_x86 = " --disable-yasm" | ||
46 | |||
47 | do_configure() { | ||
48 | ./configure ${EXTRA_OECONF} | ||
49 | } | ||