summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libav
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-30 16:20:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-05-04 10:05:32 +0200
commitdff45fb21c52b615908e9b48e8ffb29207544c83 (patch)
tree0d17b72fbfcbe53ccd5c367782e4934b9ffac886 /meta-oe/recipes-multimedia/libav
parent8457644a4164d8dd335af9d81e6c558f5da46182 (diff)
downloadmeta-openembedded-dff45fb21c52b615908e9b48e8ffb29207544c83.tar.gz
libav-0.7.4: fix build with gcc-4.7
A cmp instruction with two constants is invalid, therefore 'g' constraint is not correct but must be "rm" instead. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/libav')
-rw-r--r--meta-oe/recipes-multimedia/libav/libav-0.7.4/h264_qpel_mmx.patch57
-rw-r--r--meta-oe/recipes-multimedia/libav/libav_0.7.4.bb6
2 files changed, 61 insertions, 2 deletions
diff --git a/meta-oe/recipes-multimedia/libav/libav-0.7.4/h264_qpel_mmx.patch b/meta-oe/recipes-multimedia/libav/libav-0.7.4/h264_qpel_mmx.patch
new file mode 100644
index 000000000..5656c47f4
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libav/libav-0.7.4/h264_qpel_mmx.patch
@@ -0,0 +1,57 @@
1Backport http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=5f654897e325349dacf2546674e0510bb72ecb50;hp=250cebeb3b348c3da71f9972eb500d6005dc01f1
2
3Fixes these errors on x86
4
5libavcodec/x86/h264_qpel_mmx.c: Assembler messages:
6libavcodec/x86/h264_qpel_mmx.c:1294: Error: operand type mismatch for `cmp'
7libavcodec/x86/h264_qpel_mmx.c:1294: Error: operand type mismatch for `cmp'
8libavcodec/x86/h264_qpel_mmx.c:1298: Error: operand type mismatch for `cmp'
9libavcodec/x86/h264_qpel_mmx.c:1298: Error: operand type mismatch for `cmp'
10libavcodec/x86/h264_qpel_mmx.c:964: Error: operand type mismatch for `cmp'
11libavcodec/x86/h264_qpel_mmx.c:964: Error: operand type mismatch for `cmp'
12libavcodec/x86/h264_qpel_mmx.c:964: Error: operand type mismatch for `cmp'
13make[5]: *** [libavcodec/x86/dsputil_mmx.o] Error 1
14
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17Upstream-status: Backport
18Index: b/libavcodec/x86/h264_qpel_mmx.c
19===================================================================
20--- a/libavcodec/x86/h264_qpel_mmx.c 2012-03-30 11:39:41.324522051 -0700
21+++ b/libavcodec/x86/h264_qpel_mmx.c 2012-03-30 11:54:08.152564075 -0700
22@@ -398,7 +398,7 @@
23 "2: \n\t"\
24 \
25 : "+a"(src), "+c"(dst)\
26- : "S"((x86_reg)srcStride), "D"((x86_reg)dstStride), "g"(h)\
27+ : "S"((x86_reg)srcStride), "D"((x86_reg)dstStride), "rm"(h)\
28 : "memory"\
29 );\
30 src += 4-(h+5)*srcStride;\
31@@ -446,7 +446,7 @@
32 QPEL_H264HV(%%mm3, %%mm4, %%mm5, %%mm0, %%mm1, %%mm2, 15*48)\
33 "2: \n\t"\
34 : "+a"(src)\
35- : "c"(tmp), "S"((x86_reg)srcStride), "g"(size)\
36+ : "c"(tmp), "S"((x86_reg)srcStride), "rm"(size)\
37 : "memory"\
38 );\
39 tmp += 4;\
40@@ -823,7 +823,7 @@
41 "2: \n\t"\
42 \
43 : "+a"(src), "+c"(dst)\
44- : "S"((x86_reg)srcStride), "D"((x86_reg)dstStride), "g"(h)\
45+ : "S"((x86_reg)srcStride), "D"((x86_reg)dstStride), "rm"(h)\
46 : XMM_CLOBBERS("%xmm0", "%xmm1", "%xmm2", "%xmm3", \
47 "%xmm4", "%xmm5", "%xmm6", "%xmm7",)\
48 "memory"\
49@@ -878,7 +878,7 @@
50 QPEL_H264HV_XMM(%%xmm3, %%xmm4, %%xmm5, %%xmm0, %%xmm1, %%xmm2, 15*48)
51 "2: \n\t"
52 : "+a"(src)
53- : "c"(tmp), "S"((x86_reg)srcStride), "g"(size)
54+ : "c"(tmp), "S"((x86_reg)srcStride), "rm"(size)
55 : XMM_CLOBBERS("%xmm0", "%xmm1", "%xmm2", "%xmm3",
56 "%xmm4", "%xmm5", "%xmm6", "%xmm7",)
57 "memory"
diff --git a/meta-oe/recipes-multimedia/libav/libav_0.7.4.bb b/meta-oe/recipes-multimedia/libav/libav_0.7.4.bb
index c4c01db37..bf077c6b4 100644
--- a/meta-oe/recipes-multimedia/libav/libav_0.7.4.bb
+++ b/meta-oe/recipes-multimedia/libav/libav_0.7.4.bb
@@ -10,9 +10,11 @@ LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10SRCREV = "d4653e882fee5a2876c3878bc23d26799e3380ad" 10SRCREV = "d4653e882fee5a2876c3878bc23d26799e3380ad"
11 11
12PV = "0.7.4" 12PV = "0.7.4"
13PR = "${INC_PR}.0" 13PR = "${INC_PR}.1"
14 14
15SRC_URI = "git://git.libav.org/libav.git;protocol=git;branch=release/0.7" 15SRC_URI = "git://git.libav.org/libav.git;protocol=git;branch=release/0.7 \
16 file://h264_qpel_mmx.patch \
17"
16 18
17S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
18 20