summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libav
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-multimedia/libav
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/libav')
-rw-r--r--meta-oe/recipes-multimedia/libav/libav.inc66
-rw-r--r--meta-oe/recipes-multimedia/libav/libav_0.8.4.bb4
2 files changed, 35 insertions, 35 deletions
diff --git a/meta-oe/recipes-multimedia/libav/libav.inc b/meta-oe/recipes-multimedia/libav/libav.inc
index 54307afda..6e91061d0 100644
--- a/meta-oe/recipes-multimedia/libav/libav.inc
+++ b/meta-oe/recipes-multimedia/libav/libav.inc
@@ -15,10 +15,10 @@ INC_PR = "r8"
15 15
16inherit autotools pkgconfig 16inherit autotools pkgconfig
17 17
18# --enable-libgsm 18# --enable-libgsm
19# --enable-libmp3lame 19# --enable-libmp3lame
20# --enable-libschroedinger 20# --enable-libschroedinger
21# --enable-libvpx 21# --enable-libvpx
22 22
23B = "${S}/build.${HOST_SYS}.${TARGET_SYS}" 23B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
24 24
@@ -29,28 +29,28 @@ EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
29EXTRA_FFCONF ?= "" 29EXTRA_FFCONF ?= ""
30 30
31EXTRA_OECONF = " \ 31EXTRA_OECONF = " \
32 --enable-shared \ 32 --enable-shared \
33 --enable-pthreads \ 33 --enable-pthreads \
34 --enable-gpl \ 34 --enable-gpl \
35 --enable-avfilter \ 35 --enable-avfilter \
36 \ 36 \
37 --cross-prefix=${TARGET_PREFIX} \ 37 --cross-prefix=${TARGET_PREFIX} \
38 --prefix=${prefix} \ 38 --prefix=${prefix} \
39 \ 39 \
40 --enable-avserver \ 40 --enable-avserver \
41 --enable-avplay \ 41 --enable-avplay \
42 --enable-x11grab \ 42 --enable-x11grab \
43 --enable-libtheora \ 43 --enable-libtheora \
44 --enable-libvorbis \ 44 --enable-libvorbis \
45 --enable-libx264 \ 45 --enable-libx264 \
46 --arch=${TARGET_ARCH} \ 46 --arch=${TARGET_ARCH} \
47 --target-os="linux" \ 47 --target-os="linux" \
48 --enable-cross-compile \ 48 --enable-cross-compile \
49 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ 49 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
50 --extra-ldflags="${TARGET_LDFLAGS}" \ 50 --extra-ldflags="${TARGET_LDFLAGS}" \
51 --sysroot="${STAGING_DIR_TARGET}" \ 51 --sysroot="${STAGING_DIR_TARGET}" \
52 --enable-hardcoded-tables \ 52 --enable-hardcoded-tables \
53 ${EXTRA_FFCONF} \ 53 ${EXTRA_FFCONF} \
54" 54"
55 55
56#| yasm not found, use --disable-yasm for a crippled build 56#| yasm not found, use --disable-yasm for a crippled build
@@ -58,16 +58,16 @@ EXTRA_OECONF_append_x86-64 = " --disable-yasm"
58EXTRA_OECONF_append_x86 = " --disable-yasm" 58EXTRA_OECONF_append_x86 = " --disable-yasm"
59 59
60do_configure() { 60do_configure() {
61 # We don't have TARGET_PREFIX-pkgconfig 61 # We don't have TARGET_PREFIX-pkgconfig
62 sed -i '/pkg_config_default="${cross_prefix}${pkg_config_default}"/d' ${S}/configure 62 sed -i '/pkg_config_default="${cross_prefix}${pkg_config_default}"/d' ${S}/configure
63 mkdir -p ${B} 63 mkdir -p ${B}
64 cd ${B} 64 cd ${B}
65 ${S}/configure ${EXTRA_OECONF} 65 ${S}/configure ${EXTRA_OECONF}
66 sed -i -e s:Os:O4:g ${B}/config.h 66 sed -i -e s:Os:O4:g ${B}/config.h
67} 67}
68 68
69do_install_append() { 69do_install_append() {
70 install -m 0644 ${S}/libavfilter/*.h ${D}${includedir}/libavfilter/ 70 install -m 0644 ${S}/libavfilter/*.h ${D}${includedir}/libavfilter/
71} 71}
72 72
73FFMPEG_LIBS = "libavcodec libavdevice libavformat \ 73FFMPEG_LIBS = "libavcodec libavdevice libavformat \
diff --git a/meta-oe/recipes-multimedia/libav/libav_0.8.4.bb b/meta-oe/recipes-multimedia/libav/libav_0.8.4.bb
index ebab2c10f..b48ae96ad 100644
--- a/meta-oe/recipes-multimedia/libav/libav_0.8.4.bb
+++ b/meta-oe/recipes-multimedia/libav/libav_0.8.4.bb
@@ -1,13 +1,13 @@
1require libav.inc 1require libav.inc
2 2
3EXTRA_OECONF += " \ 3EXTRA_OECONF += " \
4 --enable-postproc \ 4 --enable-postproc \
5" 5"
6 6
7FILESEXTRAPATHS_prepend := "${THISDIR}/libav-0.8.4:" 7FILESEXTRAPATHS_prepend := "${THISDIR}/libav-0.8.4:"
8 8
9SRC_URI_append = " \ 9SRC_URI_append = " \
10 file://0001-configure-enable-pic-for-AArch64.patch \ 10 file://0001-configure-enable-pic-for-AArch64.patch \
11" 11"
12LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 12LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ 13 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \