summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorHaiqing Bai <Haiqing.Bai@windriver.com>2019-03-07 09:10:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-07 09:33:45 -0800
commit8c345d604f80420e841f769f64aae2b02544c44f (patch)
treeeaa3c74a7fc2ae98a83efeb042dfcd3b0fe73a3e /meta-oe/recipes-kernel
parent781f6cfb1c07fc3e76f18dff820befab73de9d78 (diff)
downloadmeta-openembedded-8c345d604f80420e841f769f64aae2b02544c44f.tar.gz
makedumpfile: Upgrade to 1.6.5 to support kernel 4.18 and 4.19
This upgrade fixed the below issue: When run '$makedumpfile -E -d 1 /proc/vmcore /root/vmcore_dumpfile' shows 'The kernel version is not supported.' Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch25
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.5.bb (renamed from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.4.bb)4
2 files changed, 19 insertions, 10 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
index 766f4fc76..156b4d57d 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
@@ -1,4 +1,4 @@
1From ba123fa6b2aa0ac62d1b78f327339635ae87201a Mon Sep 17 00:00:00 2001 1From 0d1cdb59da3603e0a80913617ece0164b05380d2 Mon Sep 17 00:00:00 2001
2From: Alexandru Moise <alexandru.moise@windriver.com> 2From: Alexandru Moise <alexandru.moise@windriver.com>
3Date: Fri, 29 Apr 2016 07:40:46 +0000 3Date: Fri, 29 Apr 2016 07:40:46 +0000
4Subject: [PATCH] mem_section: Support only 46 bit for MAX_PHYSMEM_BITS on 4Subject: [PATCH] mem_section: Support only 46 bit for MAX_PHYSMEM_BITS on
@@ -21,19 +21,20 @@ Upstream-Status: Pending
21Signed-off-by: Alexandru Moise <alexandru.moise@windriver.com> 21Signed-off-by: Alexandru Moise <alexandru.moise@windriver.com>
22Signed-off-by: Yi Zhao <yi.zhao@windriver.com> 22Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
23 23
24[hqBai: adjusted patch for context, no logical change]
25Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com>
24--- 26---
25 arch/ppc64.c | 28 ++-------------------------- 27 arch/ppc64.c | 33 ++-------------------------------
26 1 file changed, 2 insertions(+), 26 deletions(-) 28 1 file changed, 2 insertions(+), 31 deletions(-)
27 29
28diff --git a/arch/ppc64.c b/arch/ppc64.c 30diff --git a/arch/ppc64.c b/arch/ppc64.c
29index 8b6f7d5..458f06b 100644 31index 947a125..458f06b 100644
30--- a/arch/ppc64.c 32--- a/arch/ppc64.c
31+++ b/arch/ppc64.c 33+++ b/arch/ppc64.c
32@@ -462,38 +462,14 @@ ppc64_vtop_level4(unsigned long vaddr) 34@@ -463,42 +463,13 @@ ppc64_vtop_level4(unsigned long vaddr)
33 return paddr;
34 } 35 }
35 36
36-int 37 int
37-set_ppc64_max_physmem_bits(void) 38-set_ppc64_max_physmem_bits(void)
38-{ 39-{
39- long array_len = ARRAY_LENGTH(mem_section); 40- long array_len = ARRAY_LENGTH(mem_section);
@@ -52,10 +53,15 @@ index 8b6f7d5..458f06b 100644
52- || (array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT()))) 53- || (array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT())))
53- return TRUE; 54- return TRUE;
54- 55-
56- info->max_physmem_bits = _MAX_PHYSMEM_BITS_4_19;
57- if ((array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT_EXTREME()))
58- || (array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT())))
59- return TRUE;
60-
55- return FALSE; 61- return FALSE;
56-} 62-}
57- 63-
58 int 64-int
59 get_machdep_info_ppc64(void) 65 get_machdep_info_ppc64(void)
60 { 66 {
61 unsigned long vmlist, vmap_area_list, vmalloc_start; 67 unsigned long vmlist, vmap_area_list, vmalloc_start;
@@ -70,3 +76,6 @@ index 8b6f7d5..458f06b 100644
70 info->page_offset = __PAGE_OFFSET; 76 info->page_offset = __PAGE_OFFSET;
71 77
72 if (SYMBOL(_stext) == NOT_FOUND_SYMBOL) { 78 if (SYMBOL(_stext) == NOT_FOUND_SYMBOL) {
79--
802.7.4
81
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.4.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.5.bb
index 33194b850..413b413a9 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.4.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.5.bb
@@ -25,8 +25,8 @@ SRC_URI = "\
25 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ 25 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
26 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \ 26 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
27" 27"
28SRC_URI[md5sum] = "7dfbca19f487604c271e2892ba07f4bd" 28SRC_URI[md5sum] = "1737f8e8904d565629f0c9e702f92d02"
29SRC_URI[sha256sum] = "7e06f72d5f291fcab9e92975f405a76e37d4f7fc8fa4172f199636398ae812b1" 29SRC_URI[sha256sum] = "5d4f1d6ded8dca6951eeabcf4bb1ebf6575288fee947529397103c040eb5c760"
30 30
31UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/makedumpfile/files/makedumpfile/" 31UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/makedumpfile/files/makedumpfile/"
32UPSTREAM_CHECK_REGEX = "makedumpfile/(?P<pver>\d+(\.\d+)+)/" 32UPSTREAM_CHECK_REGEX = "makedumpfile/(?P<pver>\d+(\.\d+)+)/"