summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-08-01 23:39:43 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-02 18:04:41 -0700
commit68f1fdf237087f7fb644ae02922e56408c24e5cf (patch)
tree3bfedfe7149fc74ff4b639b1770564d8e8089c15 /meta-oe/recipes-kernel
parentc9fbe982f57092b95c33b2a64e51e61b77f0e8e4 (diff)
downloadmeta-openembedded-68f1fdf237087f7fb644ae02922e56408c24e5cf.tar.gz
pm-graph: fix time format parse error
Time format in dmesg has been changed from "%Y-%m-%d %H:%M:%S" to "%Y-%m-%dT%H:%M:%S", backport an upstream patch to fix this error. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch32
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
new file mode 100644
index 000000000..d49ce0138
--- /dev/null
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
@@ -0,0 +1,32 @@
1From 0c94e32b218c31f31a7988577fb9bec595034e7b Mon Sep 17 00:00:00 2001
2From: Todd Brandt <todd.e.brandt@linux.intel.com>
3Date: Fri, 10 May 2019 15:10:35 -0700
4Subject: [PATCH] bootgraph.py: - handle boot time start grep better, the regex
5 needs more complexity
6
7Upstream-Status: Backport [https://github.com/intel/pm-graph/commit/0c94e32b218c31f31a7988577fb9bec595034e7b]
8
9Signed-off-by: Liwei Song <liwei.song@windriver.com>
10---
11 bootgraph.py | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/bootgraph.py b/bootgraph.py
15index a2b1b1897307..d7f4bd152bf1 100755
16--- a/bootgraph.py
17+++ b/bootgraph.py
18@@ -333,9 +333,9 @@ def parseKernelLog():
19 if(not sysvals.stamp['kernel']):
20 sysvals.stamp['kernel'] = sysvals.kernelVersion(msg)
21 continue
22- m = re.match('.* setting system clock to (?P<t>.*) UTC.*', msg)
23+ m = re.match('.* setting system clock to (?P<d>[0-9\-]*)[ A-Z](?P<t>[0-9:]*) UTC.*', msg)
24 if(m):
25- bt = datetime.strptime(m.group('t'), '%Y-%m-%d %H:%M:%S')
26+ bt = datetime.strptime(m.group('d')+' '+m.group('t'), '%Y-%m-%d %H:%M:%S')
27 bt = bt - timedelta(seconds=int(ktime))
28 data.boottime = bt.strftime('%Y-%m-%d_%H:%M:%S')
29 sysvals.stamp['time'] = bt.strftime('%B %d %Y, %I:%M:%S %p')
30--
312.22.0
32
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
index ea12e054d..a9f540ab8 100644
--- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7 7
8SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7" 8SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7"
9SRC_URI = "git://github.com/intel/pm-graph.git \ 9SRC_URI = "git://github.com/intel/pm-graph.git \
10 file://0001-Makefile-fix-multilib-build-failure.patch" 10 file://0001-Makefile-fix-multilib-build-failure.patch \
11 file://0001-bootgraph.py.patch \
12"
11S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
12 14
13COMPATIBLE_HOST='(i.86|x86_64).*' 15COMPATIBLE_HOST='(i.86|x86_64).*'