summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-18 15:31:24 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commit5d6d1bb305c197497adee1d7367b19b9681d746b (patch)
tree0b57523afd46be8b2a23d887fde1e7a164bd45b6 /meta-oe/recipes-kernel
parent1c2c30c1439c64fe8c8c68e5ceeadf4148befaa4 (diff)
downloadmeta-openembedded-5d6d1bb305c197497adee1d7367b19b9681d746b.tar.gz
oprofile: 1.1.0 -> 1.1.2
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile.inc5
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile/0001-Fix-FTBFS-problem-with-GCC-6.patch51
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile/0001-fix-musl-libc-compile-error.patch30
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile_1.1.0.bb10
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile_1.2.0.bb10
5 files changed, 43 insertions, 63 deletions
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile.inc b/meta-oe/recipes-kernel/oprofile/oprofile.inc
index 4b01654fa..dabc30b36 100644
--- a/meta-oe/recipes-kernel/oprofile/oprofile.inc
+++ b/meta-oe/recipes-kernel/oprofile/oprofile.inc
@@ -25,12 +25,13 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
25 file://run-ptest \ 25 file://run-ptest \
26 file://root-home-dir.patch \ 26 file://root-home-dir.patch \
27 file://0001-Add-rmb-definition-for-NIOS2-architecture.patch \ 27 file://0001-Add-rmb-definition-for-NIOS2-architecture.patch \
28 file://0001-Fix-FTBFS-problem-with-GCC-6.patch \
29" 28"
30UPSTREAM_CHECK_REGEX = "oprofile-(?P<pver>\d+(\.\d+)+)/" 29UPSTREAM_CHECK_REGEX = "oprofile-(?P<pver>\d+(\.\d+)+)/"
31UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/oprofile/files/oprofile/" 30UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/oprofile/files/oprofile/"
32 31
33SRC_URI_append_libc-musl = " file://musl.patch" 32SRC_URI_append_libc-musl = " file://musl.patch \
33 file://0001-fix-musl-libc-compile-error.patch \
34"
34 35
35inherit autotools pkgconfig ptest 36inherit autotools pkgconfig ptest
36 37
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile/0001-Fix-FTBFS-problem-with-GCC-6.patch b/meta-oe/recipes-kernel/oprofile/oprofile/0001-Fix-FTBFS-problem-with-GCC-6.patch
deleted file mode 100644
index d372fd527..000000000
--- a/meta-oe/recipes-kernel/oprofile/oprofile/0001-Fix-FTBFS-problem-with-GCC-6.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 39d4d46a0bd504ac708ffe72df87bf74cd12ad30 Mon Sep 17 00:00:00 2001
2From: William Cohen <wcohen@redhat.com>
3Date: Fri, 5 Feb 2016 17:30:19 -0500
4Subject: [PATCH] Fix FTBFS problem with GCC-6
5
6GCC-6 is pickier about some of the type conversions causing the Fedora
724 mass rebuild the build of oprofile failed with:
8
9make[3]: Entering directory '/builddir/build/BUILD/oprofile-1.1.0/libutil++'
10g++ -DHAVE_CONFIG_H -I. -I.. -I ../libutil -I ../libop -I ../libpp -W -Wall -fno-common -ftemplate-depth-50 -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c -o op_bfd.o op_bfd.cpp
11op_bfd.cpp: In member function 'void op_bfd::get_symbol_range(symbol_index_t, long long unsigned int&, long long unsigned int&) const':
12op_bfd.cpp:538:47: error: cannot convert 'std::ostream {aka std::basic_ostream<char>}' to 'const bool' in initialization
13 bool const verbose = cverb << (vbfd & vlevel1);
14 ^
15op_bfd.cpp:546:7: error: in argument to unary !
16 if (!verbose)
17 ^~~~~~~
18
19Avoid the intermediate bool type to make GCC-6 happy.
20
21Signed-off-by: William Cohen <wcohen@redhat.com>
22---
23Upstream-Status: Backport
24
25 libutil++/op_bfd.cpp | 4 +---
26 1 file changed, 1 insertion(+), 3 deletions(-)
27
28diff --git a/libutil++/op_bfd.cpp b/libutil++/op_bfd.cpp
29index 389c920..f2eb42b 100644
30--- a/libutil++/op_bfd.cpp
31+++ b/libutil++/op_bfd.cpp
32@@ -535,15 +535,13 @@ void op_bfd::get_symbol_range(symbol_index_t sym_idx,
33 {
34 op_bfd_symbol const & sym = syms[sym_idx];
35
36- bool const verbose = cverb << (vbfd & vlevel1);
37-
38 if (anon_obj)
39 start = sym.vma();
40 else
41 start = sym.filepos();
42 end = start + sym.size();
43
44- if (!verbose)
45+ if (!(cverb << (vbfd & vlevel1)))
46 return;
47
48 io_state state(cverb << (vbfd & vlevel1));
49--
501.9.1
51
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile/0001-fix-musl-libc-compile-error.patch b/meta-oe/recipes-kernel/oprofile/oprofile/0001-fix-musl-libc-compile-error.patch
new file mode 100644
index 000000000..c21a10575
--- /dev/null
+++ b/meta-oe/recipes-kernel/oprofile/oprofile/0001-fix-musl-libc-compile-error.patch
@@ -0,0 +1,30 @@
1From 512f1b3a4727a3a18f8fa55f196eedcacdd4a872 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 18 Jul 2018 13:01:03 +0800
4Subject: [PATCH] fix musl libc compile error
5
6use op_basename instead of basename to fix below error:
7../../oprofile-1.2.0/pp/oparchive.cpp:264:20: error: 'basename'
8was not declared in this scope
9
10Signed-off-by: Changqing Li <changqing.li@windriver.com>
11---
12 pp/oparchive.cpp | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/pp/oparchive.cpp b/pp/oparchive.cpp
16index 6221e14..274152b 100644
17--- a/pp/oparchive.cpp
18+++ b/pp/oparchive.cpp
19@@ -261,7 +261,7 @@ int oparchive(options::spec const & spec)
20 /* determine the session name of sample file */
21 int offset = sample_name.find('{');
22 string base_samples_dir = sample_name.substr(0, offset-1);
23- string session = basename(base_samples_dir.c_str());
24+ string session = op_basename(base_samples_dir.c_str());
25 /* Get rid of the the archive_path from the name */
26 string sample_base = sample_name.substr(offset);
27 string sample_archive_file = dest_samples_dir + "/" + session + "/" + sample_base;
28--
292.7.4
30
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile_1.1.0.bb b/meta-oe/recipes-kernel/oprofile/oprofile_1.1.0.bb
deleted file mode 100644
index 92a94ad0d..000000000
--- a/meta-oe/recipes-kernel/oprofile/oprofile_1.1.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require oprofile.inc
2
3DEPENDS += "virtual/kernel"
4DEPENDS_append_powerpc64 = " libpfm4"
5
6SRC_URI[md5sum] = "248c4c069f9476f427fa7195563f9867"
7SRC_URI[sha256sum] = "cf759a6de1a6033d5dfc93bda129a9f2e128aecc4238cc657feb0801d1b0366c"
8
9S = "${WORKDIR}/oprofile-${PV}"
10
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile_1.2.0.bb b/meta-oe/recipes-kernel/oprofile/oprofile_1.2.0.bb
new file mode 100644
index 000000000..e85e805c3
--- /dev/null
+++ b/meta-oe/recipes-kernel/oprofile/oprofile_1.2.0.bb
@@ -0,0 +1,10 @@
1require oprofile.inc
2
3DEPENDS += "virtual/kernel"
4DEPENDS_append_powerpc64 = " libpfm4"
5
6SRC_URI[md5sum] = "4fcd3920984dcb607314b2e225086c3a"
7SRC_URI[sha256sum] = "eb95f98c40b7d0ee29b45fba3565d9f8381747528aa6b6159e37d4fa0c8ca57d"
8
9S = "${WORKDIR}/oprofile-${PV}"
10