summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-13 14:16:55 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-23 08:44:44 -0700
commitffc64e9c6fee0af7eea3466135416d011172a5e6 (patch)
treeb9effa069d9af3c63d6f3a41caff6b887450522c /meta-oe/recipes-kernel
parenta90f89dbc7eff2ae83bab6a6676f4737c0b48a8d (diff)
downloadmeta-openembedded-ffc64e9c6fee0af7eea3466135416d011172a5e6.tar.gz
recipes: Start WORKDIR -> UNPACKDIR transition
Replace references of WORKDIR with UNPACKDIR where it makes sense to do so in preparation for changing the default value of UNPACKDIR. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb4
-rw-r--r--meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb4
-rw-r--r--meta-oe/recipes-kernel/linux/linux.inc4
-rw-r--r--meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.7.bb4
-rw-r--r--meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb2
-rw-r--r--meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb4
6 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index 0f1c8846b..7a15d16bc 100644
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -37,8 +37,8 @@ S = "${WORKDIR}/git"
37inherit autotools pkgconfig 37inherit autotools pkgconfig
38 38
39do_install:append() { 39do_install:append() {
40 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then 40 if [ -e ${UNPACKDIR}/iana-enterprise-numbers ]; then
41 install -Dm 0755 ${WORKDIR}/iana-enterprise-numbers ${D}${datadir}/misc/enterprise-numbers 41 install -Dm 0755 ${UNPACKDIR}/iana-enterprise-numbers ${D}${datadir}/misc/enterprise-numbers
42 fi 42 fi
43} 43}
44 44
diff --git a/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb b/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb
index 01f185adb..3f57ef3bf 100644
--- a/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb
+++ b/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb
@@ -2,7 +2,7 @@ SUMMARY = "Kernel selftest for Linux"
2DESCRIPTION = "Kernel selftest for Linux" 2DESCRIPTION = "Kernel selftest for Linux"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4 4
5LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 5LIC_FILES_CHKSUM = "file://${UNPACKDIR}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
6 6
7DEPENDS = "rsync-native llvm-native" 7DEPENDS = "rsync-native llvm-native"
8 8
@@ -120,7 +120,7 @@ do_install() {
120} 120}
121 121
122do_configure() { 122do_configure() {
123 install -D -m 0644 ${WORKDIR}/COPYING ${S}/COPYING 123 install -D -m 0644 ${UNPACKDIR}/COPYING ${S}/COPYING
124} 124}
125 125
126do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated" 126do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated"
diff --git a/meta-oe/recipes-kernel/linux/linux.inc b/meta-oe/recipes-kernel/linux/linux.inc
index b4b066122..79a916d46 100644
--- a/meta-oe/recipes-kernel/linux/linux.inc
+++ b/meta-oe/recipes-kernel/linux/linux.inc
@@ -41,8 +41,8 @@ do_configure:prepend() {
41 # 41 #
42 # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used 42 # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used
43 # 43 #
44 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then 44 if [ -e ${UNPACKDIR}/logo_linux_clut224.ppm ]; then
45 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm 45 install -m 0644 ${UNPACKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
46 kernel_conf_variable LOGO y 46 kernel_conf_variable LOGO y
47 kernel_conf_variable LOGO_LINUX_CLUT224 y 47 kernel_conf_variable LOGO_LINUX_CLUT224 y
48 fi 48 fi
diff --git a/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.7.bb b/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.7.bb
index 726aa60ce..90e847c13 100644
--- a/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.7.bb
+++ b/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.7.bb
@@ -36,9 +36,9 @@ do_install:append() {
36 cp -rf ${S}/etc/* ${D}/${sysconfdir}/ 36 cp -rf ${S}/etc/* ${D}/${sysconfdir}/
37 37
38 install -d ${D}${systemd_system_unitdir} 38 install -d ${D}${systemd_system_unitdir}
39 install -m 0644 ${WORKDIR}/minicoredumper.service ${D}${systemd_system_unitdir} 39 install -m 0644 ${UNPACKDIR}/minicoredumper.service ${D}${systemd_system_unitdir}
40 install -d ${D}${sysconfdir}/init.d 40 install -d ${D}${sysconfdir}/init.d
41 install -m 0755 ${WORKDIR}/minicoredumper.init ${D}${sysconfdir}/init.d/minicoredumper 41 install -m 0755 ${UNPACKDIR}/minicoredumper.init ${D}${sysconfdir}/init.d/minicoredumper
42 42
43 # correct path of minicoredumper 43 # correct path of minicoredumper
44 sed -i -e s:/usr/bin/minicoredumper:${sbindir}/minicoredumper:g ${D}${sysconfdir}/init.d/minicoredumper 44 sed -i -e s:/usr/bin/minicoredumper:${sbindir}/minicoredumper:g ${D}${sysconfdir}/init.d/minicoredumper
diff --git a/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb b/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
index c4c89e575..45f70aa38 100644
--- a/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
+++ b/meta-oe/recipes-kernel/oprofile/oprofile_1.4.0.bb
@@ -43,7 +43,7 @@ inherit autotools pkgconfig ptest
43 43
44EXTRA_OECONF = "--with-kernel=${STAGING_DIR_HOST}${prefix} --without-x ac_cv_prog_XSLTPROC=" 44EXTRA_OECONF = "--with-kernel=${STAGING_DIR_HOST}${prefix} --without-x ac_cv_prog_XSLTPROC="
45do_configure () { 45do_configure () {
46 cp ${WORKDIR}/acinclude.m4 ${S}/ 46 cp ${UNPACKDIR}/acinclude.m4 ${S}/
47 autotools_do_configure 47 autotools_do_configure
48} 48}
49 49
diff --git a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
index bdc37c038..02a695218 100644
--- a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
+++ b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
@@ -12,7 +12,7 @@ processor frequency and idle power saving state residency on supported \
12processors." 12processors."
13 13
14LICENSE = "GPL-2.0-only" 14LICENSE = "GPL-2.0-only"
15LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 15LIC_FILES_CHKSUM = "file://${UNPACKDIR}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
16COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' 16COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
17COMPATIBLE_HOST:libc-musl = "null" 17COMPATIBLE_HOST:libc-musl = "null"
18 18
@@ -50,7 +50,7 @@ do_configure:prepend() {
50 cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S} 50 cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
51 fi 51 fi
52 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S} 52 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
53 cp -r ${WORKDIR}/COPYING ${S} 53 cp -r ${UNPACKDIR}/COPYING ${S}
54} 54}
55 55
56 56