diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:35:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:36:45 +0200 |
commit | cdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch) | |
tree | 42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-oe/recipes-kernel | |
parent | 2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff) | |
download | meta-openembedded-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz |
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread:
https://patchwork.openembedded.org/patch/137573/
update the messages to warn possible users that the
recipe will be removed before the end of the next development
cycle (before Yocto 2.4 is released).
* updated with:
sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs`
* then noticed couple recipes being blacklisted only based on
DISTRO_FEATURES, so removed those:
meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb
meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb
meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb
meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
meta-oe/recipes-navigation/gypsy/gypsy.inc
meta-oe/recipes-navigation/navit/navit.inc
meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
* if it isn't fixed by this date, it's fair game to be removed
whenever someone gets around to i
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.1.5.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ktap/ktap-module_git.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ktap/ktap_git.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb index 3ea5820be..fbd89c316 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb | |||
@@ -112,4 +112,4 @@ RDEPENDS_${PN}_class-cross = "" | |||
112 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - | 112 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - |
113 | ARM_INSTRUCTION_SET = "arm" | 113 | ARM_INSTRUCTION_SET = "arm" |
114 | 114 | ||
115 | PNBLACKLIST[crash] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130678/" | 115 | PNBLACKLIST[crash] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130678/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb index cb913271f..1119d4c90 100644 --- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb +++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb | |||
@@ -7,7 +7,7 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" | |||
7 | inherit module | 7 | inherit module |
8 | 8 | ||
9 | # See https://github.com/ktap/ktap/issues/80 | 9 | # See https://github.com/ktap/ktap/issues/80 |
10 | PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel" | 10 | PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
11 | 11 | ||
12 | # Only build the module | 12 | # Only build the module |
13 | MAKE_TARGETS = "mod" | 13 | MAKE_TARGETS = "mod" |
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb index 248e7bdd6..a947b7fcc 100644 --- a/meta-oe/recipes-kernel/ktap/ktap_git.bb +++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb | |||
@@ -5,7 +5,7 @@ require ktap.inc | |||
5 | SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" | 5 | SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" |
6 | DEPENDS = "ktap-module" | 6 | DEPENDS = "ktap-module" |
7 | 7 | ||
8 | PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm" | 8 | PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
9 | 9 | ||
10 | # Only build the userspace app | 10 | # Only build the userspace app |
11 | EXTRA_OEMAKE += "ktap" | 11 | EXTRA_OEMAKE += "ktap" |