summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-06-18 17:30:23 +0800
committerKhem Raj <raj.khem@gmail.com>2019-06-18 06:32:38 -0700
commit86407337b940fa54f473cdc586ee763c57413677 (patch)
tree7ca813096cc13c71ad1f668c4dc7bb5cb272e662 /meta-oe/recipes-kernel
parentd29f84835bbd39a05be310126d37f5d2c00ed2ba (diff)
downloadmeta-openembedded-86407337b940fa54f473cdc586ee763c57413677.tar.gz
pm-graph: fix multilib build failure
Added the generic library path used by multilib code Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Tested-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph/0001-Makefile-fix-multilib-build-failure.patch89
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb5
2 files changed, 92 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-Makefile-fix-multilib-build-failure.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-Makefile-fix-multilib-build-failure.patch
new file mode 100644
index 000000000..56981d96f
--- /dev/null
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-Makefile-fix-multilib-build-failure.patch
@@ -0,0 +1,89 @@
1From 50cea8fd3c07ab27da6edce865a49339f16f3b57 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 18 Jun 2019 17:10:15 +0800
4Subject: [PATCH] Makefile: fix multilib build failure
5
6Upstream-Status: Inappropriate [oe specific]
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 Makefile | 50 +++++++++++++++++++++++++++-----------------------
11 1 file changed, 27 insertions(+), 23 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index 8455415..4aa0786 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -1,30 +1,34 @@
18 # SPDX-License-Identifier: GPL-2.0
19 PREFIX ?= /usr
20 DESTDIR ?=
21+BASELIB ?=
22
23 all:
24 @echo "Nothing to build"
25
26+clean:
27+ @echo "Nothing to clean"
28+
29 install : uninstall
30- install -d $(DESTDIR)$(PREFIX)/lib/pm-graph
31- install sleepgraph.py $(DESTDIR)$(PREFIX)/lib/pm-graph
32- install bootgraph.py $(DESTDIR)$(PREFIX)/lib/pm-graph
33- install -d $(DESTDIR)$(PREFIX)/lib/pm-graph/config
34- install -m 644 config/cgskip.txt $(DESTDIR)$(PREFIX)/lib/pm-graph/config
35- install -m 644 config/freeze-callgraph.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
36- install -m 644 config/freeze.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
37- install -m 644 config/freeze-dev.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
38- install -m 644 config/standby-callgraph.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
39- install -m 644 config/standby.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
40- install -m 644 config/standby-dev.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
41- install -m 644 config/suspend-callgraph.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
42- install -m 644 config/suspend.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
43- install -m 644 config/suspend-dev.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
44- install -m 644 config/suspend-x2-proc.cfg $(DESTDIR)$(PREFIX)/lib/pm-graph/config
45+ install -d $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph
46+ install sleepgraph.py $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph
47+ install bootgraph.py $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph
48+ install -d $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
49+ install -m 644 config/cgskip.txt $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
50+ install -m 644 config/freeze-callgraph.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
51+ install -m 644 config/freeze.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
52+ install -m 644 config/freeze-dev.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
53+ install -m 644 config/standby-callgraph.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
54+ install -m 644 config/standby.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
55+ install -m 644 config/standby-dev.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
56+ install -m 644 config/suspend-callgraph.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
57+ install -m 644 config/suspend.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
58+ install -m 644 config/suspend-dev.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
59+ install -m 644 config/suspend-x2-proc.cfg $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config
60
61 install -d $(DESTDIR)$(PREFIX)/bin
62- ln -s ../lib/pm-graph/bootgraph.py $(DESTDIR)$(PREFIX)/bin/bootgraph
63- ln -s ../lib/pm-graph/sleepgraph.py $(DESTDIR)$(PREFIX)/bin/sleepgraph
64+ ln -s ../$(BASELIB)/pm-graph/bootgraph.py $(DESTDIR)$(PREFIX)/bin/bootgraph
65+ ln -s ../$(BASELIB)/pm-graph/sleepgraph.py $(DESTDIR)$(PREFIX)/bin/sleepgraph
66
67 install -d $(DESTDIR)$(PREFIX)/share/man/man8
68 install bootgraph.8 $(DESTDIR)$(PREFIX)/share/man/man8
69@@ -37,11 +41,11 @@ uninstall :
70 rm -f $(DESTDIR)$(PREFIX)/bin/bootgraph
71 rm -f $(DESTDIR)$(PREFIX)/bin/sleepgraph
72
73- rm -f $(DESTDIR)$(PREFIX)/lib/pm-graph/config/*
74- if [ -d $(DESTDIR)$(PREFIX)/lib/pm-graph/config ] ; then \
75- rmdir $(DESTDIR)$(PREFIX)/lib/pm-graph/config; \
76+ rm -f $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config/*
77+ if [ -d $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config ] ; then \
78+ rmdir $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/config; \
79 fi;
80- rm -f $(DESTDIR)$(PREFIX)/lib/pm-graph/*
81- if [ -d $(DESTDIR)$(PREFIX)/lib/pm-graph ] ; then \
82- rmdir $(DESTDIR)$(PREFIX)/lib/pm-graph; \
83+ rm -f $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph/*
84+ if [ -d $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph ] ; then \
85+ rmdir $(DESTDIR)$(PREFIX)/$(BASELIB)/pm-graph; \
86 fi;
87--
882.17.1
89
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
index de2d46dca..ea12e054d 100644
--- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
@@ -6,11 +6,12 @@ LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7 7
8SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7" 8SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7"
9SRC_URI = "git://github.com/intel/pm-graph.git" 9SRC_URI = "git://github.com/intel/pm-graph.git \
10 file://0001-Makefile-fix-multilib-build-failure.patch"
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
11 12
12COMPATIBLE_HOST='(i.86|x86_64).*' 13COMPATIBLE_HOST='(i.86|x86_64).*'
13EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}" 14EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
14 15
15do_install() { 16do_install() {
16 oe_runmake install 17 oe_runmake install