summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorDenis Carikli <GNUtoo@no-log.org>2012-07-18 22:00:16 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-19 11:09:46 +0200
commite8402b1583c0c1e1c85aacf54349b58e32142c7c (patch)
treec36d105efa2c086eeb18237b4d0493e77c944701 /meta-oe/recipes-kernel
parentb3a8b70fdd98178ed06d3f7f8573f061c732746c (diff)
downloadmeta-openembedded-e8402b1583c0c1e1c85aacf54349b58e32142c7c.tar.gz
Add compat-wireless recipe.
This recipe was based on the compat-wireless.inc recipe from openembedded-classic at commit 53784a5e2622582ce5e2ffb91bbdb573503ed75e The .inc is there in order to make it possible to have such recipes: $ cat compat-wireless-ath_0.bb include compat-wireless.inc do_configure() { cd ${S} ./scripts/driver-select ath } 0001-ath5k-fix-compilation-without-CONFIG_PCI.patch will have to be submitted upstream Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb1
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc33
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch33
3 files changed, 67 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb
new file mode 100644
index 000000000..1d3395f9e
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_0.bb
@@ -0,0 +1 @@
include compat-wireless.inc
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
new file mode 100644
index 000000000..faf1aabe6
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
@@ -0,0 +1,33 @@
1DESCRIPTION = "Latest wireless drivers"
2HOMEPAGE = "http://wireless.kernel.org/en/users/Download"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d7810fab7487fb0aad327b76f1be7cd7"
6RDEPENDS = "wireless-tools"
7PR = "r0"
8
9COMPAT_WIRELESS_VERSION = "3.5-rc5-1"
10
11SRC_URI = " \
12 http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.5/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
13 file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
14"
15
16PV = "${COMPAT_WIRELESS_VERSION}"
17
18S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}"
19
20inherit module
21
22EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
23
24do_configure_append() {
25 sed -i "s#@./scripts/update-initramfs## " Makefile
26}
27
28do_install() {
29 oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
30}
31
32SRC_URI[md5sum] = "5d26bb5fd830ba67e920e0e4b2cff284"
33SRC_URI[sha256sum] = "f77ec3afd7c8fb1d9583cb5c82cdc683816c7fc43cebebc1f0f029d172fcce9a"
diff --git a/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch b/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
new file mode 100644
index 000000000..3a51266d0
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/files/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
@@ -0,0 +1,33 @@
1From fb323acc0b01bcf1ecafb9330c4fbb41cf942139 Mon Sep 17 00:00:00 2001
2From: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
3Date: Wed, 18 Jul 2012 01:01:52 +0200
4Subject: [PATCH] ath5k: fix compilation without CONFIG_PCI
5
6Without that fix we have:
7 [...]/drivers/net/wireless/ath/ath5k/led.c: In function 'ath5k_init_leds':
8 [...]/drivers/net/wireless/ath/ath5k/led.c:179:2: error: implicit declaration of function 'pci_match_id' [-Werror=implicit-function-declaration]
9When CONFIG_PCI is not set.
10
11Upstream-Status: Pending: Not submitted yet.
12
13Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
14---
15 drivers/net/wireless/ath/ath5k/led.c | 2 +-
16 1 files changed, 1 insertions(+), 1 deletions(-)
17
18diff --git a/drivers/net/wireless/ath/ath5k/led.c b/drivers/net/wireless/ath/ath5k/led.c
19index c044476..a4de133 100644
20--- a/drivers/net/wireless/ath/ath5k/led.c
21+++ b/drivers/net/wireless/ath/ath5k/led.c
22@@ -173,7 +173,7 @@ int __devinit ath5k_init_leds(struct ath5k_hw *ah)
23 if (!ah->pdev)
24 return 0;
25
26-#ifdef CONFIG_ATHEROS_AR231X
27+#if defined(CONFIG_ATHEROS_AR231X) || !defined(CONFIG_PCI)
28 match = NULL;
29 #else
30 match = pci_match_id(&ath5k_led_devices[0], pdev);
31--
321.7.4.1
33