summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-kernel
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc8
-rw-r--r--meta-oe/recipes-kernel/linux/linux.inc182
2 files changed, 95 insertions, 95 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
index 30d52cc19..41f673ac8 100644
--- a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
@@ -10,8 +10,8 @@ COMPAT_WIRELESS_VERSION = "${PV}-1"
10SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" 10SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
11 11
12SRC_URI = " \ 12SRC_URI = " \
13 http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \ 13 http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
14 file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \ 14 file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
15" 15"
16 16
17S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}" 17S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}"
@@ -21,9 +21,9 @@ inherit module
21EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}" 21EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
22 22
23do_configure_append() { 23do_configure_append() {
24 sed -i "s#@./scripts/update-initramfs## " Makefile 24 sed -i "s#@./scripts/update-initramfs## " Makefile
25} 25}
26 26
27do_install() { 27do_install() {
28 oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules 28 oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
29} 29}
diff --git a/meta-oe/recipes-kernel/linux/linux.inc b/meta-oe/recipes-kernel/linux/linux.inc
index 2b2fbf352..7b301ae21 100644
--- a/meta-oe/recipes-kernel/linux/linux.inc
+++ b/meta-oe/recipes-kernel/linux/linux.inc
@@ -25,106 +25,106 @@ LOCALVERSION ?= ""
25 25
26#kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\"" 26#kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
27kernel_conf_variable() { 27kernel_conf_variable() {
28 CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;" 28 CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;"
29 if test "$2" = "n" 29 if test "$2" = "n"
30 then 30 then
31 echo "# CONFIG_$1 is not set" >> ${S}/.config 31 echo "# CONFIG_$1 is not set" >> ${S}/.config
32 else 32 else
33 echo "CONFIG_$1=$2" >> ${S}/.config 33 echo "CONFIG_$1=$2" >> ${S}/.config
34 fi 34 fi
35} 35}
36 36
37do_configure_prepend() { 37do_configure_prepend() {
38 echo "" > ${S}/.config 38 echo "" > ${S}/.config
39 CONF_SED_SCRIPT="" 39 CONF_SED_SCRIPT=""
40 40
41 # 41 #
42 # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used 42 # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used
43 # 43 #
44 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then 44 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
45 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm 45 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
46 kernel_conf_variable LOGO y 46 kernel_conf_variable LOGO y
47 kernel_conf_variable LOGO_LINUX_CLUT224 y 47 kernel_conf_variable LOGO_LINUX_CLUT224 y
48 fi 48 fi
49 49
50 # 50 #
51 # oabi / eabi support 51 # oabi / eabi support
52 # 52 #
53 kernel_conf_variable AEABI y 53 kernel_conf_variable AEABI y
54 if [ "${ARM_KEEP_OABI}" = "1" ] ; then 54 if [ "${ARM_KEEP_OABI}" = "1" ] ; then
55 kernel_conf_variable OABI_COMPAT y 55 kernel_conf_variable OABI_COMPAT y
56 else 56 else
57 kernel_conf_variable OABI_COMPAT n 57 kernel_conf_variable OABI_COMPAT n
58 fi 58 fi
59 59
60 # When enabling thumb for userspace we also need thumb support in the kernel 60 # When enabling thumb for userspace we also need thumb support in the kernel
61 if [ "${ARM_INSTRUCTION_SET}" = "thumb" ] ; then 61 if [ "${ARM_INSTRUCTION_SET}" = "thumb" ] ; then
62 kernel_conf_variable ARM_THUMB y 62 kernel_conf_variable ARM_THUMB y
63 fi 63 fi
64 64
65 kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\"" 65 kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
66 66
67 kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\"" 67 kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
68 kernel_conf_variable LOCALVERSION_AUTO n 68 kernel_conf_variable LOCALVERSION_AUTO n
69 69
70 kernel_conf_variable SYSFS_DEPRECATED n 70 kernel_conf_variable SYSFS_DEPRECATED n
71 kernel_conf_variable SYSFS_DEPRECATED_V2 n 71 kernel_conf_variable SYSFS_DEPRECATED_V2 n
72 kernel_conf_variable HOTPLUG y 72 kernel_conf_variable HOTPLUG y
73 kernel_conf_variable UEVENT_HELPER_PATH \"\" 73 kernel_conf_variable UEVENT_HELPER_PATH \"\"
74 kernel_conf_variable UNIX y 74 kernel_conf_variable UNIX y
75 kernel_conf_variable SYSFS y 75 kernel_conf_variable SYSFS y
76 kernel_conf_variable PROC_FS y 76 kernel_conf_variable PROC_FS y
77 kernel_conf_variable TMPFS y 77 kernel_conf_variable TMPFS y
78 kernel_conf_variable INOTIFY_USER y 78 kernel_conf_variable INOTIFY_USER y
79 kernel_conf_variable SIGNALFD y 79 kernel_conf_variable SIGNALFD y
80 kernel_conf_variable TMPFS_POSIX_ACL y 80 kernel_conf_variable TMPFS_POSIX_ACL y
81 kernel_conf_variable BLK_DEV_BSG y 81 kernel_conf_variable BLK_DEV_BSG y
82 kernel_conf_variable DEVTMPFS y 82 kernel_conf_variable DEVTMPFS y
83 kernel_conf_variable DEVTMPFS_MOUNT y 83 kernel_conf_variable DEVTMPFS_MOUNT y
84 84
85 # Newer inits like systemd need cgroup support 85 # Newer inits like systemd need cgroup support
86 if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then 86 if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then
87 kernel_conf_variable CGROUP_SCHED y 87 kernel_conf_variable CGROUP_SCHED y
88 kernel_conf_variable CGROUPS y 88 kernel_conf_variable CGROUPS y
89 kernel_conf_variable CGROUP_NS y 89 kernel_conf_variable CGROUP_NS y
90 kernel_conf_variable CGROUP_FREEZER y 90 kernel_conf_variable CGROUP_FREEZER y
91 kernel_conf_variable CGROUP_DEVICE y 91 kernel_conf_variable CGROUP_DEVICE y
92 kernel_conf_variable CPUSETS y 92 kernel_conf_variable CPUSETS y
93 kernel_conf_variable PROC_PID_CPUSET y 93 kernel_conf_variable PROC_PID_CPUSET y
94 kernel_conf_variable CGROUP_CPUACCT y 94 kernel_conf_variable CGROUP_CPUACCT y
95 kernel_conf_variable RESOURCE_COUNTERS y 95 kernel_conf_variable RESOURCE_COUNTERS y
96 fi 96 fi
97 97
98 # 98 #
99 # root-over-nfs-over-usb-eth support. Limited, but should cover some cases. 99 # root-over-nfs-over-usb-eth support. Limited, but should cover some cases.
100 # Enable this by setting a proper CMDLINE_NFSROOT_USB. 100 # Enable this by setting a proper CMDLINE_NFSROOT_USB.
101 # 101 #
102 if [ ! -z "${CMDLINE_NFSROOT_USB}" ]; then 102 if [ ! -z "${CMDLINE_NFSROOT_USB}" ]; then
103 bbnote "Configuring the kernel for root-over-nfs-over-usb-eth with CMDLINE ${CMDLINE_NFSROOT_USB}" 103 bbnote "Configuring the kernel for root-over-nfs-over-usb-eth with CMDLINE ${CMDLINE_NFSROOT_USB}"
104 kernel_conf_variable INET y 104 kernel_conf_variable INET y
105 kernel_conf_variable IP_PNP y 105 kernel_conf_variable IP_PNP y
106 kernel_conf_variable USB_GADGET y 106 kernel_conf_variable USB_GADGET y
107 kernel_conf_variable USB_GADGET_SELECTED y 107 kernel_conf_variable USB_GADGET_SELECTED y
108 kernel_conf_variable USB_ETH y 108 kernel_conf_variable USB_ETH y
109 kernel_conf_variable NFS_FS y 109 kernel_conf_variable NFS_FS y
110 kernel_conf_variable ROOT_NFS y 110 kernel_conf_variable ROOT_NFS y
111 kernel_conf_variable CMDLINE \"${CMDLINE_NFSROOT_USB} ${CMDLINE_DEBUG}\" 111 kernel_conf_variable CMDLINE \"${CMDLINE_NFSROOT_USB} ${CMDLINE_DEBUG}\"
112 fi 112 fi
113 113
114 sed -e "${CONF_SED_SCRIPT}" \ 114 sed -e "${CONF_SED_SCRIPT}" \
115 < '${WORKDIR}/defconfig' >>'${S}/.config' 115 < '${WORKDIR}/defconfig' >>'${S}/.config'
116 116
117 yes '' | oe_runmake oldconfig 117 yes '' | oe_runmake oldconfig
118} 118}
119 119
120do_configure_append() { 120do_configure_append() {
121 if test -e scripts/Makefile.fwinst ; then 121 if test -e scripts/Makefile.fwinst ; then
122 sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst 122 sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
123 fi 123 fi
124} 124}
125 125
126do_install_append() { 126do_install_append() {
127 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH 127 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
128} 128}
129 129
130PACKAGES =+ "kernel-headers" 130PACKAGES =+ "kernel-headers"