summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-12-01 10:16:48 +0800
committerKhem Raj <raj.khem@gmail.com>2020-11-30 22:42:20 -0800
commit89eb9a1ddeb278c79fef8258e500bc02306a361f (patch)
tree8b1a338821ad1814742a780fc4a08cec49d80524 /meta-oe/recipes-kernel
parent6c65d53796164e3410314964cec778ba28d96153 (diff)
downloadmeta-openembedded-89eb9a1ddeb278c79fef8258e500bc02306a361f.tar.gz
crash: upgrade 7.2.8 -> 7.2.9
crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch Removed since this is included in 7.2.9 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch54
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.2.9.bb (renamed from meta-oe/recipes-kernel/crash/crash_7.2.8.bb)3
2 files changed, 1 insertions, 56 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch
deleted file mode 100644
index c94644438..000000000
--- a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From 0dddb4e1158705345b7f4f71635d42c89e1b0c8f Mon Sep 17 00:00:00 2001
2From: Dave Anderson <anderson@redhat.com>
3Date: Fri, 31 Jan 2020 17:11:46 -0500
4Subject: [PATCH] Fix for an ARM64 gcc-10 compilation error. Without the
5 patch, the build of the embedded gdb module fails with an error message that
6 indicates "multiple definition of 'tdesc_aarch64'". (anderson@redhat.com)
7
8Upstream-Status: Backport [https://github.com/crash-utility/crash/commit/e770735200c02ac2414c394ea6ec5f7f033efe64]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 gdb-7.6.patch | 30 ++++++++++++++++++++++++++++++
12 1 file changed, 30 insertions(+)
13
14diff --git a/gdb-7.6.patch b/gdb-7.6.patch
15index f6c311d..f64b55f 100644
16--- a/gdb-7.6.patch
17+++ b/gdb-7.6.patch
18@@ -2471,3 +2471,33 @@ diff -up gdb-7.6/opcodes/configure.orig gdb-7.6/opcodes/configure
19 #else
20 # error "!__i386__ && !__x86_64__"
21 #endif
22+--- gdb-7.6/gdb/features/aarch64.c.orig
23++++ gdb-7.6/gdb/features/aarch64.c
24+@@ -5,7 +5,6 @@
25+ #include "osabi.h"
26+ #include "target-descriptions.h"
27+
28+-struct target_desc *tdesc_aarch64;
29+ static void
30+ initialize_tdesc_aarch64 (void)
31+ {
32+--- gdb-7.6/gdb/aarch64-linux-nat.c.orig
33++++ gdb-7.6/gdb/aarch64-linux-nat.c
34+@@ -37,6 +37,7 @@
35+
36+ #include "gregset.h"
37+
38++extern struct target_desc *tdesc_aarch64;
39+ #include "features/aarch64.c"
40+
41+ /* Defines ps_err_e, struct ps_prochandle. */
42+--- gdb-7.6/gdb/aarch64-tdep.c.orig
43++++ gdb-7.6/gdb/aarch64-tdep.c
44+@@ -52,6 +52,7 @@
45+ #include "gdb_assert.h"
46+ #include "vec.h"
47+
48++struct target_desc *tdesc_aarch64;
49+ #include "features/aarch64.c"
50+ #include "features/aarch64-without-fpu.c"
51+
52--
532.28.0
54
diff --git a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb b/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
index 6e2533635..4394b6fc6 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
@@ -25,9 +25,8 @@ SRC_URI = "git://github.com/crash-utility/${BPN}.git \
25 file://remove-unrecognized-gcc-option-m32-for-mips.patch \ 25 file://remove-unrecognized-gcc-option-m32-for-mips.patch \
26 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ 26 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \
27 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ 27 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \
28 file://0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch \
29 " 28 "
30SRCREV = "24f4801f8c8871a2e3e660fe9fa8fdd86bb29876" 29SRCREV = "a25aa4b649d339dd25c20d5413d81b851a77e0b2"
31 30
32SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" 31SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470"
33SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" 32SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36"