diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-15 15:55:50 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-15 21:08:54 -0800 |
commit | 773bd4cec54b0f936618365c05b494384055e5c3 (patch) | |
tree | 63b0bd927556ec5a7efa0e1c7460684fcd9e47b7 /meta-oe/recipes-kernel | |
parent | d51f6000bf849ecf2721a20a5398f6ad406de61c (diff) | |
download | meta-openembedded-773bd4cec54b0f936618365c05b494384055e5c3.tar.gz |
libpfm4: Moved here from oe-core
Upgrade to 4.10.1 while here
oprofile/ppc64 still depends on it
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r-- | meta-oe/recipes-kernel/libpfm/libpfm4/0001-Include-poll.h-instead-of-sys-poll.h.patch | 86 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/libpfm/libpfm4_4.10.1.bb | 31 |
2 files changed, 117 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/libpfm/libpfm4/0001-Include-poll.h-instead-of-sys-poll.h.patch b/meta-oe/recipes-kernel/libpfm/libpfm4/0001-Include-poll.h-instead-of-sys-poll.h.patch new file mode 100644 index 000000000..fe13df2b5 --- /dev/null +++ b/meta-oe/recipes-kernel/libpfm/libpfm4/0001-Include-poll.h-instead-of-sys-poll.h.patch | |||
@@ -0,0 +1,86 @@ | |||
1 | From f62b629c1e1e968f90aafbc0cf9116b49eea9d8e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 15 Dec 2019 16:24:37 -0800 | ||
4 | Subject: [PATCH] Include poll.h instead of sys/poll.h | ||
5 | |||
6 | Fixes | ||
7 | error: redirecting incorrect #include <sys/poll.h> to <poll.h> [-Werror,-W#warnings] | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | perf_examples/branch_smpl.c | 2 +- | ||
13 | perf_examples/syst_smpl.c | 2 +- | ||
14 | perf_examples/task_attach_timeout.c | 2 +- | ||
15 | perf_examples/task_smpl.c | 2 +- | ||
16 | perf_examples/x86/bts_smpl.c | 2 +- | ||
17 | 5 files changed, 5 insertions(+), 5 deletions(-) | ||
18 | |||
19 | diff --git a/perf_examples/branch_smpl.c b/perf_examples/branch_smpl.c | ||
20 | index 87cd303..4d16b04 100644 | ||
21 | --- a/perf_examples/branch_smpl.c | ||
22 | +++ b/perf_examples/branch_smpl.c | ||
23 | @@ -32,7 +32,7 @@ | ||
24 | #include <getopt.h> | ||
25 | #include <setjmp.h> | ||
26 | #include <sys/wait.h> | ||
27 | -#include <sys/poll.h> | ||
28 | +#include <poll.h> | ||
29 | #include <sys/mman.h> | ||
30 | #include <locale.h> | ||
31 | #include <sys/ioctl.h> | ||
32 | diff --git a/perf_examples/syst_smpl.c b/perf_examples/syst_smpl.c | ||
33 | index 04580fd..d059c08 100755 | ||
34 | --- a/perf_examples/syst_smpl.c | ||
35 | +++ b/perf_examples/syst_smpl.c | ||
36 | @@ -33,7 +33,7 @@ | ||
37 | #include <setjmp.h> | ||
38 | #include <sys/ptrace.h> | ||
39 | #include <sys/wait.h> | ||
40 | -#include <sys/poll.h> | ||
41 | +#include <poll.h> | ||
42 | #include <sys/ioctl.h> | ||
43 | #include <sys/mman.h> | ||
44 | #include <fcntl.h> | ||
45 | diff --git a/perf_examples/task_attach_timeout.c b/perf_examples/task_attach_timeout.c | ||
46 | index 7fc5524..a0367c8 100644 | ||
47 | --- a/perf_examples/task_attach_timeout.c | ||
48 | +++ b/perf_examples/task_attach_timeout.c | ||
49 | @@ -36,7 +36,7 @@ | ||
50 | #include <stdarg.h> | ||
51 | #include <sys/wait.h> | ||
52 | #include <err.h> | ||
53 | -#include <sys/poll.h> | ||
54 | +#include <poll.h> | ||
55 | |||
56 | #include "perf_util.h" | ||
57 | |||
58 | diff --git a/perf_examples/task_smpl.c b/perf_examples/task_smpl.c | ||
59 | index dcb7481..95c432c 100644 | ||
60 | --- a/perf_examples/task_smpl.c | ||
61 | +++ b/perf_examples/task_smpl.c | ||
62 | @@ -37,7 +37,7 @@ | ||
63 | #include <getopt.h> | ||
64 | #include <setjmp.h> | ||
65 | #include <sys/wait.h> | ||
66 | -#include <sys/poll.h> | ||
67 | +#include <poll.h> | ||
68 | #include <sys/mman.h> | ||
69 | #include <locale.h> | ||
70 | #include <sys/ioctl.h> | ||
71 | diff --git a/perf_examples/x86/bts_smpl.c b/perf_examples/x86/bts_smpl.c | ||
72 | index 6498776..d66d5e6 100644 | ||
73 | --- a/perf_examples/x86/bts_smpl.c | ||
74 | +++ b/perf_examples/x86/bts_smpl.c | ||
75 | @@ -41,7 +41,7 @@ | ||
76 | #include <sys/time.h> | ||
77 | #include <sys/ptrace.h> | ||
78 | #include <sys/wait.h> | ||
79 | -#include <sys/poll.h> | ||
80 | +#include <poll.h> | ||
81 | #include <sys/mman.h> | ||
82 | #include <sys/resource.h> | ||
83 | #include <err.h> | ||
84 | -- | ||
85 | 2.24.1 | ||
86 | |||
diff --git a/meta-oe/recipes-kernel/libpfm/libpfm4_4.10.1.bb b/meta-oe/recipes-kernel/libpfm/libpfm4_4.10.1.bb new file mode 100644 index 000000000..9b43b4a97 --- /dev/null +++ b/meta-oe/recipes-kernel/libpfm/libpfm4_4.10.1.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "Monitoring tools exploiting the performance monitoring events" | ||
2 | DESCRIPTION = "This package provides a library, called libpfm4 which is used to develop \ | ||
3 | monitoring tools exploiting the performance monitoring events such as those \ | ||
4 | provided by the Performance Monitoring Unit (PMU) of modern processors." | ||
5 | HOMEPAGE = "http://perfmon2.sourceforge.net/" | ||
6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=144822&atid=759953&source=navbar" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0de488f3bd4424e308e2e399cb99c788" | ||
10 | |||
11 | SECTION = "devel" | ||
12 | |||
13 | COMPATIBLE_HOST = "powerpc64" | ||
14 | |||
15 | SRC_URI = "${SOURCEFORGE_MIRROR}/perfmon2/${BPN}/libpfm-${PV}.tar.gz \ | ||
16 | file://0001-Include-poll.h-instead-of-sys-poll.h.patch \ | ||
17 | " | ||
18 | SRC_URI[md5sum] = "d8f66cb9bfa7e1434434e0de6409db5b" | ||
19 | SRC_URI[sha256sum] = "c61c575378b5c17ccfc5806761e4038828610de76e2e34fac9f7fa73ba844b49" | ||
20 | |||
21 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/perfmon2/files/libpfm4/" | ||
22 | |||
23 | EXTRA_OEMAKE = "DESTDIR=\"${D}\" PREFIX=\"${prefix}\" LIBDIR=\"${libdir}\" LDCONFIG=\"true\"" | ||
24 | EXTRA_OEMAKE_append_powerpc = " ARCH=\"powerpc\"" | ||
25 | EXTRA_OEMAKE_append_powerpc64 = " ARCH=\"powerpc\" BITMODE=\"64\"" | ||
26 | |||
27 | S = "${WORKDIR}/libpfm-${PV}" | ||
28 | |||
29 | do_install () { | ||
30 | oe_runmake install | ||
31 | } | ||