diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-09 12:26:29 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-11 10:46:55 +0100 |
commit | 4a680e64f4570d38ffdfca51b67e6347ac91a361 (patch) | |
tree | c0f0a64349700c54490948815e3969e2e20d86c7 /meta-oe/recipes-kernel | |
parent | fc591a156abdd880b348bc9433c1d4db602a59f7 (diff) | |
download | meta-openembedded-4a680e64f4570d38ffdfca51b67e6347ac91a361.tar.gz |
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with:
ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r-- | meta-oe/recipes-kernel/ktap/ktap-module_git.bb | 5 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ktap/ktap.inc | 12 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ktap/ktap_git.bb | 10 |
3 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb index e3c94e3dc..cb913271f 100644 --- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb +++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb | |||
@@ -9,11 +9,8 @@ inherit module | |||
9 | # See https://github.com/ktap/ktap/issues/80 | 9 | # See https://github.com/ktap/ktap/issues/80 |
10 | PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel" | 10 | PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel" |
11 | 11 | ||
12 | # Available package configs: ffi (only supported on x86_64) | ||
13 | PACKAGECONFIG ?= "" | ||
14 | |||
15 | # Only build the module | 12 | # Only build the module |
16 | MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod" | 13 | MAKE_TARGETS = "mod" |
17 | 14 | ||
18 | # Kernel module packages MUST begin with 'kernel-module-', otherwise | 15 | # Kernel module packages MUST begin with 'kernel-module-', otherwise |
19 | # multilib image generation can fail. | 16 | # multilib image generation can fail. |
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc index 2c94a08d6..e2e498f9f 100644 --- a/meta-oe/recipes-kernel/ktap/ktap.inc +++ b/meta-oe/recipes-kernel/ktap/ktap.inc | |||
@@ -11,4 +11,16 @@ SRC_URI = "git://github.com/ktap/ktap.git" | |||
11 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
12 | 12 | ||
13 | # Package config is abused as a general compile time configuration tool. | 13 | # Package config is abused as a general compile time configuration tool. |
14 | |||
15 | # Only supports x86_64 for now!. Needs to be enabled for ktap-module too. | ||
14 | PACKAGECONFIG[ffi] = "" | 16 | PACKAGECONFIG[ffi] = "" |
17 | |||
18 | # Needed to resolve symbols in DSO and for sdt | ||
19 | PACKAGECONFIG[libelf] = ",,elfutils" | ||
20 | |||
21 | PACKAGECONFIG ?= "libelf" | ||
22 | |||
23 | EXTRA_OEMAKE = " \ | ||
24 | ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \ | ||
25 | ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \ | ||
26 | " | ||
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb index 1379c4833..248e7bdd6 100644 --- a/meta-oe/recipes-kernel/ktap/ktap_git.bb +++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb | |||
@@ -6,17 +6,9 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" | |||
6 | DEPENDS = "ktap-module" | 6 | DEPENDS = "ktap-module" |
7 | 7 | ||
8 | PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm" | 8 | PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm" |
9 | #Available package configs: | ||
10 | # libelf - needed to resolve symbols in DSO and for sdt | ||
11 | # ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too. | ||
12 | PACKAGECONFIG ?= "libelf" | ||
13 | |||
14 | PACKAGECONFIG[libelf] = ",,elfutils" | ||
15 | 9 | ||
16 | # Only build the userspace app | 10 | # Only build the userspace app |
17 | EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \ | 11 | EXTRA_OEMAKE += "ktap" |
18 | ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \ | ||
19 | ktap" | ||
20 | 12 | ||
21 | do_install() { | 13 | do_install() { |
22 | install -d ${D}${bindir} | 14 | install -d ${D}${bindir} |