summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/pm-graph
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-09-11 13:31:03 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-11 00:04:29 -0700
commit255b755381e4876f1fad0b1a8b6e4be1a3b37935 (patch)
tree8b576f83d038a508d4eed5ae8de7934d1faee48c /meta-oe/recipes-kernel/pm-graph
parentc93f66d65a333dee1bd7b8dbb776ceedc715cf86 (diff)
downloadmeta-openembedded-255b755381e4876f1fad0b1a8b6e4be1a3b37935.tar.gz
pm-graph: upgrade 5.3 -> 5.5
This release has python3 support so updating python3 to RDEPENDS. python subprocess comes with python3-core, so removing from RDEPENDS. Removed patch, which is already merged in this release. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/pm-graph')
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch32
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch39
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb (renamed from meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb)6
3 files changed, 42 insertions, 35 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
deleted file mode 100644
index d49ce0138..000000000
--- a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 0c94e32b218c31f31a7988577fb9bec595034e7b Mon Sep 17 00:00:00 2001
2From: Todd Brandt <todd.e.brandt@linux.intel.com>
3Date: Fri, 10 May 2019 15:10:35 -0700
4Subject: [PATCH] bootgraph.py: - handle boot time start grep better, the regex
5 needs more complexity
6
7Upstream-Status: Backport [https://github.com/intel/pm-graph/commit/0c94e32b218c31f31a7988577fb9bec595034e7b]
8
9Signed-off-by: Liwei Song <liwei.song@windriver.com>
10---
11 bootgraph.py | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/bootgraph.py b/bootgraph.py
15index a2b1b1897307..d7f4bd152bf1 100755
16--- a/bootgraph.py
17+++ b/bootgraph.py
18@@ -333,9 +333,9 @@ def parseKernelLog():
19 if(not sysvals.stamp['kernel']):
20 sysvals.stamp['kernel'] = sysvals.kernelVersion(msg)
21 continue
22- m = re.match('.* setting system clock to (?P<t>.*) UTC.*', msg)
23+ m = re.match('.* setting system clock to (?P<d>[0-9\-]*)[ A-Z](?P<t>[0-9:]*) UTC.*', msg)
24 if(m):
25- bt = datetime.strptime(m.group('t'), '%Y-%m-%d %H:%M:%S')
26+ bt = datetime.strptime(m.group('d')+' '+m.group('t'), '%Y-%m-%d %H:%M:%S')
27 bt = bt - timedelta(seconds=int(ktime))
28 data.boottime = bt.strftime('%Y-%m-%d_%H:%M:%S')
29 sysvals.stamp['time'] = bt.strftime('%B %d %Y, %I:%M:%S %p')
30--
312.22.0
32
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch
new file mode 100644
index 000000000..25c87093f
--- /dev/null
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch
@@ -0,0 +1,39 @@
1From 22ce65d997f99606a3bb9d2a660ead42eecc234a Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 11 Sep 2019 11:31:07 +0800
4Subject: [PATCH] sleepgraph.py: use python3
5
6Already compatible with Python 3.
7Same goes for bootgraph.py
8
9Upstream-Status: Inappropriate [oe specific]
10
11Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
12---
13 bootgraph.py | 2 +-
14 sleepgraph.py | 2 +-
15 2 files changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/bootgraph.py b/bootgraph.py
18index d3b99a1..efb5714 100755
19--- a/bootgraph.py
20+++ b/bootgraph.py
21@@ -1,4 +1,4 @@
22-#!/usr/bin/python
23+#!/usr/bin/python3
24 # SPDX-License-Identifier: GPL-2.0-only
25 #
26 # Tool for analyzing boot timing
27diff --git a/sleepgraph.py b/sleepgraph.py
28index 1794c79..cfed8e0 100755
29--- a/sleepgraph.py
30+++ b/sleepgraph.py
31@@ -1,4 +1,4 @@
32-#!/usr/bin/python
33+#!/usr/bin/python3
34 # SPDX-License-Identifier: GPL-2.0-only
35 #
36 # Tool for analyzing suspend/resume timing
37--
382.17.1
39
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
index a9f540ab8..63a9fa88e 100644
--- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
@@ -5,10 +5,10 @@ HOMEPAGE = "https://01.org/pm-graph"
5LICENSE = "GPL-2" 5LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7 7
8SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7" 8SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
9SRC_URI = "git://github.com/intel/pm-graph.git \ 9SRC_URI = "git://github.com/intel/pm-graph.git \
10 file://0001-Makefile-fix-multilib-build-failure.patch \ 10 file://0001-Makefile-fix-multilib-build-failure.patch \
11 file://0001-bootgraph.py.patch \ 11 file://0001-sleepgraph.py-use-python3.patch \
12" 12"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
@@ -19,4 +19,4 @@ do_install() {
19 oe_runmake install 19 oe_runmake install
20} 20}
21 21
22RDEPENDS_${PN} += "python-core python-threading python-datetime python-subprocess python-compression" 22RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"