diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2019-09-11 13:31:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-11 00:04:29 -0700 |
commit | 255b755381e4876f1fad0b1a8b6e4be1a3b37935 (patch) | |
tree | 8b576f83d038a508d4eed5ae8de7934d1faee48c /meta-oe/recipes-kernel/pm-graph | |
parent | c93f66d65a333dee1bd7b8dbb776ceedc715cf86 (diff) | |
download | meta-openembedded-255b755381e4876f1fad0b1a8b6e4be1a3b37935.tar.gz |
pm-graph: upgrade 5.3 -> 5.5
This release has python3 support so updating python3 to RDEPENDS.
python subprocess comes with python3-core, so removing from RDEPENDS.
Removed patch, which is already merged in this release.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/pm-graph')
-rw-r--r-- | meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch | 39 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb (renamed from meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb) | 6 |
3 files changed, 42 insertions, 35 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch deleted file mode 100644 index d49ce0138..000000000 --- a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-bootgraph.py.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 0c94e32b218c31f31a7988577fb9bec595034e7b Mon Sep 17 00:00:00 2001 | ||
2 | From: Todd Brandt <todd.e.brandt@linux.intel.com> | ||
3 | Date: Fri, 10 May 2019 15:10:35 -0700 | ||
4 | Subject: [PATCH] bootgraph.py: - handle boot time start grep better, the regex | ||
5 | needs more complexity | ||
6 | |||
7 | Upstream-Status: Backport [https://github.com/intel/pm-graph/commit/0c94e32b218c31f31a7988577fb9bec595034e7b] | ||
8 | |||
9 | Signed-off-by: Liwei Song <liwei.song@windriver.com> | ||
10 | --- | ||
11 | bootgraph.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/bootgraph.py b/bootgraph.py | ||
15 | index a2b1b1897307..d7f4bd152bf1 100755 | ||
16 | --- a/bootgraph.py | ||
17 | +++ b/bootgraph.py | ||
18 | @@ -333,9 +333,9 @@ def parseKernelLog(): | ||
19 | if(not sysvals.stamp['kernel']): | ||
20 | sysvals.stamp['kernel'] = sysvals.kernelVersion(msg) | ||
21 | continue | ||
22 | - m = re.match('.* setting system clock to (?P<t>.*) UTC.*', msg) | ||
23 | + m = re.match('.* setting system clock to (?P<d>[0-9\-]*)[ A-Z](?P<t>[0-9:]*) UTC.*', msg) | ||
24 | if(m): | ||
25 | - bt = datetime.strptime(m.group('t'), '%Y-%m-%d %H:%M:%S') | ||
26 | + bt = datetime.strptime(m.group('d')+' '+m.group('t'), '%Y-%m-%d %H:%M:%S') | ||
27 | bt = bt - timedelta(seconds=int(ktime)) | ||
28 | data.boottime = bt.strftime('%Y-%m-%d_%H:%M:%S') | ||
29 | sysvals.stamp['time'] = bt.strftime('%B %d %Y, %I:%M:%S %p') | ||
30 | -- | ||
31 | 2.22.0 | ||
32 | |||
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch new file mode 100644 index 000000000..25c87093f --- /dev/null +++ b/meta-oe/recipes-kernel/pm-graph/pm-graph/0001-sleepgraph.py-use-python3.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From 22ce65d997f99606a3bb9d2a660ead42eecc234a Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 11 Sep 2019 11:31:07 +0800 | ||
4 | Subject: [PATCH] sleepgraph.py: use python3 | ||
5 | |||
6 | Already compatible with Python 3. | ||
7 | Same goes for bootgraph.py | ||
8 | |||
9 | Upstream-Status: Inappropriate [oe specific] | ||
10 | |||
11 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
12 | --- | ||
13 | bootgraph.py | 2 +- | ||
14 | sleepgraph.py | 2 +- | ||
15 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/bootgraph.py b/bootgraph.py | ||
18 | index d3b99a1..efb5714 100755 | ||
19 | --- a/bootgraph.py | ||
20 | +++ b/bootgraph.py | ||
21 | @@ -1,4 +1,4 @@ | ||
22 | -#!/usr/bin/python | ||
23 | +#!/usr/bin/python3 | ||
24 | # SPDX-License-Identifier: GPL-2.0-only | ||
25 | # | ||
26 | # Tool for analyzing boot timing | ||
27 | diff --git a/sleepgraph.py b/sleepgraph.py | ||
28 | index 1794c79..cfed8e0 100755 | ||
29 | --- a/sleepgraph.py | ||
30 | +++ b/sleepgraph.py | ||
31 | @@ -1,4 +1,4 @@ | ||
32 | -#!/usr/bin/python | ||
33 | +#!/usr/bin/python3 | ||
34 | # SPDX-License-Identifier: GPL-2.0-only | ||
35 | # | ||
36 | # Tool for analyzing suspend/resume timing | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb index a9f540ab8..63a9fa88e 100644 --- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb +++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb | |||
@@ -5,10 +5,10 @@ HOMEPAGE = "https://01.org/pm-graph" | |||
5 | LICENSE = "GPL-2" | 5 | LICENSE = "GPL-2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
7 | 7 | ||
8 | SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7" | 8 | SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6" |
9 | SRC_URI = "git://github.com/intel/pm-graph.git \ | 9 | SRC_URI = "git://github.com/intel/pm-graph.git \ |
10 | file://0001-Makefile-fix-multilib-build-failure.patch \ | 10 | file://0001-Makefile-fix-multilib-build-failure.patch \ |
11 | file://0001-bootgraph.py.patch \ | 11 | file://0001-sleepgraph.py-use-python3.patch \ |
12 | " | 12 | " |
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
@@ -19,4 +19,4 @@ do_install() { | |||
19 | oe_runmake install | 19 | oe_runmake install |
20 | } | 20 | } |
21 | 21 | ||
22 | RDEPENDS_${PN} += "python-core python-threading python-datetime python-subprocess python-compression" | 22 | RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression" |