diff options
author | Fathi Boudra <fathi.boudra@linaro.org> | 2021-11-18 14:07:19 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-18 11:07:10 -0800 |
commit | 2fdb6eb87e7a94ec4794d50059b69e945daaa707 (patch) | |
tree | b0237c7f172a7ff367c71d9e0fb5716499dd8cc9 /meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb | |
parent | 2755ba786a1d8e54b065320b7a35bfe8f31ef847 (diff) | |
download | meta-openembedded-2fdb6eb87e7a94ec4794d50059b69e945daaa707.tar.gz |
makedumpfile: upgrade from 1.6.9 to 1.7.0
* Drop 0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
This patch has been introduced in January 2017 for makedumpfile 1.6.1.
It has never reached upstream, hence the pending status is
inappropriate. Since that time, the upstream code to retrieve
MAX_PHYSMEM_BITS has been updated to use vmcoreinfo, with a backward
compatibility for older kernels.
* Remove the deprecated comment about arm/aarch64 would compile but has never
been tested upstream, introduced in July 2016. Nowadays, it works just fine
on those architectures.
* Add PACKAGECONFIG option for zstd compression
Since 1.7.0 release, Zstandard (zstd) compression support has been added.
With zstd, the vmcore size and time consumption can have a better balance
than zlib/lzo/snappy.
http://lists.infradead.org/pipermail/kexec/2021-September/023011.html
Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb')
-rw-r--r-- | meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb new file mode 100644 index 000000000..e703ee71b --- /dev/null +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "VMcore extraction tool" | ||
2 | DESCRIPTION = "\ | ||
3 | This program is used to extract a subset of the memory available either \ | ||
4 | via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \ | ||
5 | images without extra uneeded information (zero pages, userspace programs, \ | ||
6 | etc). \ | ||
7 | " | ||
8 | HOMEPAGE = "https://github.com/makedumpfile/makedumpfile" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
11 | LICENSE = "GPLv2.0" | ||
12 | |||
13 | SRCBRANCH ?= "master" | ||
14 | SRCREV = "06ef8e2b814feb08a668b7a3783c86674e49a7b1" | ||
15 | |||
16 | DEPENDS = "bzip2 zlib elfutils xz" | ||
17 | RDEPENDS:${PN}-tools = "perl ${PN}" | ||
18 | |||
19 | # mips would not compile. | ||
20 | COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm|aarch64).*-linux" | ||
21 | |||
22 | PACKAGES =+ "${PN}-tools" | ||
23 | FILES:${PN}-tools = "${bindir}/*.pl" | ||
24 | |||
25 | SRC_URI = "\ | ||
26 | git://github.com/makedumpfile/makedumpfile;branch=${SRCBRANCH};protocol=https \ | ||
27 | file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ | ||
28 | " | ||
29 | |||
30 | S = "${WORKDIR}/git" | ||
31 | |||
32 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||
33 | |||
34 | SECTION = "base" | ||
35 | |||
36 | # If we do not specify TARGET, makedumpfile will build for the host but use the | ||
37 | # target gcc. | ||
38 | # | ||
39 | EXTRA_OEMAKE = "\ | ||
40 | LINKTYPE=static \ | ||
41 | TARGET=${TARGET_ARCH} \ | ||
42 | ${PACKAGECONFIG_CONFARGS} \ | ||
43 | " | ||
44 | |||
45 | PACKAGECONFIG ??= "" | ||
46 | PACKAGECONFIG[lzo] = "USELZO=on,USELZO=off,lzo" | ||
47 | PACKAGECONFIG[snappy] = "USESNAPPY=on,USESNAPPY=off,snappy" | ||
48 | PACKAGECONFIG[zstd] = "USEZSTD=on,USEZSTD=off,zstd" | ||
49 | |||
50 | do_install () { | ||
51 | mkdir -p ${D}/usr/bin | ||
52 | install -m 755 ${S}/makedumpfile ${D}/usr/bin | ||
53 | install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin | ||
54 | |||
55 | mkdir -p ${D}/usr/share/man/man8 | ||
56 | install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8 | ||
57 | |||
58 | mkdir -p ${D}/usr/share/man/man5 | ||
59 | install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5 | ||
60 | |||
61 | mkdir -p ${D}/etc/ | ||
62 | install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample | ||
63 | } | ||