summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-kernel/ktap
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb22
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc13
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb26
3 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
new file mode 100644
index 000000000..62f2a99a2
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -0,0 +1,22 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6
7inherit module
8
9# Available package configs: ffi (only supported on x86_64)
10PACKAGECONFIG ?= ""
11
12# Only build the module
13MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
14
15# Kernel module packages MUST begin with 'kernel-module-', otherwise
16# multilib image generation can fail.
17#
18# The following line is only necessary if the recipe name does not begin
19# with kernel-module-.
20#
21PKG_${PN} = "kernel-module-${PN}"
22
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
new file mode 100644
index 000000000..93a4e2ca3
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -0,0 +1,13 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3HOMEPAGE = "http://www.ktap.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE-GPL;md5=eb723b61539feef013de476e68b5c50a"
6
7SRCREV = "c8401e07c89cdec9a5f673da4ddb12b7982b522b"
8SRC_URI = "git://github.com/ktap/ktap.git"
9
10S = "${WORKDIR}/git"
11
12# Package config is abused as a general compile time configuration tool.
13PACKAGECONFIG[ffi] = ""
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
new file mode 100644
index 000000000..cbdabf82d
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -0,0 +1,26 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module"
7
8#Available package configs:
9# libelf - needed to resolve symbols in DSO and for sdt
10# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
11PACKAGECONFIG ?= "libelf"
12
13PACKAGECONFIG[libelf] = ",,elfutils"
14
15# Only build the userspace app
16EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
17 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
18 ktap"
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 ${S}/ktap ${D}${bindir}/
23}
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26RDEPENDS_${PN} = "kernel-module-ktapvm"