summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2014-01-10 07:47:51 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-15 18:02:32 +0100
commit3e79b4c4e1653fc5471c1a2ef815d143644dba14 (patch)
treebb49c6b9fff4bac464d1129d3d0d30e2f9ea2475 /meta-oe/recipes-kernel/ktap/ktap_0.4.bb
parentd4b25acb2db4e11f65b588b748ff12f47ba502ca (diff)
downloadmeta-openembedded-3e79b4c4e1653fc5471c1a2ef815d143644dba14.tar.gz
ktap: add configs for elfutils and ffi
libelf (elfutils) is required for resolving symbols in DSO and for sdt (taken from ktap docs). The earlier v0.4 recipe built ktap against libelf if it was found, thus enable it per default. FFI needs to be enabled for both userspace and kernel module. Currently, it is only supported for x86_64 (enforced when building ktap-module). Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
index f5dd62f84..20f94d598 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -5,8 +5,17 @@ require ktap.inc
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" 5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module" 6DEPENDS = "ktap-module"
7 7
8#Available package configs:
9# libelf - needed to resolve symbols in DSO and for sdt
10# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
11PACKAGECONFIG ?= "libelf"
12
13PACKAGECONFIG[libelf] = ",,elfutils"
14
8# Only build the userspace app 15# Only build the userspace app
9EXTRA_OEMAKE = "ktap" 16EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
17 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
18 ktap"
10 19
11do_install() { 20do_install() {
12 install -d ${D}${bindir} 21 install -d ${D}${bindir}