diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2024-01-10 14:42:37 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-01-09 22:48:25 -0800 |
commit | df2e4cff8e908226b0b0c61f4b5ea5c5f73be1bd (patch) | |
tree | e7e4bf7c81f885708717a7cdc7fbfc21e31c6f24 /meta-oe/recipes-kernel/ipmitool | |
parent | 11056735e8c2ced778ec308f9a9f52964ceefa12 (diff) | |
download | meta-openembedded-df2e4cff8e908226b0b0c61f4b5ea5c5f73be1bd.tar.gz |
ipmitool: Make the version consistent
The git revison info is added [1] to make the version more descriptive
to produce an incremental revision number like 1.8.18.13 or 1.8.18.14
and etc and more clear in terms of "what codebase was used" like
`1.8.18.13.gee01aa5`. But it also introduces the version inconsistence.
Note as stated in [1]
For cases when .git directory is missing (Release compilation?) the suffix
part will be omitted completely yielding a version like `1.8.18`.
Considering the version we acutally used in oe is a release version,
the git revision info as [1] is meaningness. So drop the git revsion
info to make the version consistent.
Before the patch:
root@qemux86-64:~# ipmitool -V
ipmitool version 1.8.19.19.gab5ce5b
root@qemux86-64:~# rpm -qa | grep ipmitool
ipmitool-1.8.19-r0.core2_64
After the patch:
root@qemux86-64:~# ipmitool -V
ipmitool version 1.8.19
root@qemux86-64:~# rpm -qa | grep ipmitool
ipmitool-1.8.19-r0.core2_64
[1] https://github.com/ipmitool/ipmitool/commit/ba01dc84b4e225c86eac3f562e629662d752040f
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ipmitool')
-rw-r--r-- | meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb | 1 |
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch b/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch new file mode 100644 index 0000000000..98a820bd9e --- /dev/null +++ b/meta-oe/recipes-kernel/ipmitool/files/0001-csv-revision-Drop-the-git-revision-info.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 0a1af74ed3fae9a9a08b8b1ab89e88c02427ae06 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Wed, 10 Jan 2024 05:57:00 +0000 | ||
4 | Subject: [PATCH] csv-revision: Drop the git revision info | ||
5 | |||
6 | The git revison info is added [1] to make the version more descriptive | ||
7 | to produce an incremental revision number like 1.8.18.13 or 1.8.18.14 | ||
8 | and etc and more clear in terms of "what codebase was used" like | ||
9 | `1.8.18.13.gee01aa5`. But it also introduces the below version | ||
10 | inconsistence. | ||
11 | root@qemux86-64:~# ipmitool -V | ||
12 | ipmitool version 1.8.19.19.gab5ce5b | ||
13 | root@qemux86-64:~# rpm -qa | grep ipmitool | ||
14 | ipmitool-1.8.19-r0.core2_64 | ||
15 | |||
16 | Considering the version we acutally used in oe is a release version, | ||
17 | the git revision info as [1] is meaningness. So drop the git revsion | ||
18 | info to remove the above version inconsitence. | ||
19 | |||
20 | [1] https://github.com/ipmitool/ipmitool/commit/ba01dc84b4e225c86eac3f562e629662d752040f | ||
21 | |||
22 | Upstream-Status: Inappropriate [OE-Specific as we use a release version in oe] | ||
23 | |||
24 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
25 | --- | ||
26 | csv-revision | 1 + | ||
27 | 1 file changed, 1 insertion(+) | ||
28 | |||
29 | diff --git a/csv-revision b/csv-revision | ||
30 | index 289c133..3fa9f1c 100755 | ||
31 | --- a/csv-revision | ||
32 | +++ b/csv-revision | ||
33 | @@ -1,5 +1,6 @@ | ||
34 | #!/bin/sh | ||
35 | |||
36 | +exit 0 | ||
37 | git describe --first-parent --tags 2>/dev/null | ( | ||
38 | IFS=- read tag rev hash | ||
39 | if [ $? ] && [ -n "$rev" ]; then | ||
40 | -- | ||
41 | 2.35.5 | ||
42 | |||
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb index a8279f5755..0f1c8846b4 100644 --- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb +++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb | |||
@@ -24,6 +24,7 @@ DEPENDS = "openssl readline ncurses" | |||
24 | SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3" | 24 | SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3" |
25 | SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \ | 25 | SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \ |
26 | ${IANA_ENTERPRISE_NUMBERS} \ | 26 | ${IANA_ENTERPRISE_NUMBERS} \ |
27 | file://0001-csv-revision-Drop-the-git-revision-info.patch \ | ||
27 | " | 28 | " |
28 | IANA_ENTERPRISE_NUMBERS ?= "" | 29 | IANA_ENTERPRISE_NUMBERS ?= "" |
29 | 30 | ||