summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
diff options
context:
space:
mode:
authorJohnathan Mantey <johnathanx.mantey@intel.com>2023-11-02 10:27:36 -0700
committerKhem Raj <raj.khem@gmail.com>2023-11-02 10:45:57 -0700
commit762a6880f3e56832441ecacdddeddc3566de1f54 (patch)
tree37c05480f9e18583e5f2f3f38efbe56a166f0a84 /meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
parent3b1abede06befcef54ffacf086d985f7283dd8c2 (diff)
downloadmeta-openembedded-762a6880f3e56832441ecacdddeddc3566de1f54.tar.gz
ipmitool: Update and eliminate unneeded patch
The upstream ipmitool code has implemented an autoconfig control to enable and disable dynamic fetching of the IANA numbers file. As a result the patch removing the code that blocks fetching the IANA numbers is no longer relevant. The patch being removed explicitlly blocks downloading the IANA numbers file. Maintain this behavior at this level by using the --disable-registry-download feature. In order for that autoconfig switch to work, the recipe must inherit the pkgconfig feature. Without the pkgconfig dependency the code in the configure.ac file causes a compile time error. Tested: IANA numbers file isn't downloaded. Manually downloaded IANA file is installed in /usr/share/misc Enabling registry download enables dynamic download of IANA numbers Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb')
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index ab9074bba5..a8279f5755 100644
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184" 21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22 22
23DEPENDS = "openssl readline ncurses" 23DEPENDS = "openssl readline ncurses"
24SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62" 24SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
25SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \ 25SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
26 ${IANA_ENTERPRISE_NUMBERS} \ 26 ${IANA_ENTERPRISE_NUMBERS} \
27 file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
28 " 27 "
29IANA_ENTERPRISE_NUMBERS ?= "" 28IANA_ENTERPRISE_NUMBERS ?= ""
30 29
@@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
34 33
35S = "${WORKDIR}/git" 34S = "${WORKDIR}/git"
36 35
37inherit autotools 36inherit autotools pkgconfig
38 37
39do_install:append() { 38do_install:append() {
40 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then 39 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
@@ -50,5 +49,10 @@ FILES:${PN} += "${datadir}/misc"
50# --enable-file-security adds some security checks 49# --enable-file-security adds some security checks
51# --disable-intf-free disables FreeIPMI support - we don't want to depend on 50# --disable-intf-free disables FreeIPMI support - we don't want to depend on
52# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility. 51# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
52# --disable-registry-download prevents the IANA numbers from being fetched
53# at build time, as it is not repeatable.
53# 54#
54EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free" 55EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free \
56 --disable-registry-download \
57 "
58