diff options
author | Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | 2018-01-15 10:15:09 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-01-22 19:37:21 -0800 |
commit | 5b9288eb24f29ab9c60b165173aa42a51539419c (patch) | |
tree | 46ad054b8f2c8ca20261e8a952345f68e3fa27bf /meta-oe/recipes-kernel/crash | |
parent | 7f486077421aa5e6c7da3525192bcdd0dab71247 (diff) | |
download | meta-openembedded-5b9288eb24f29ab9c60b165173aa42a51539419c.tar.gz |
crash: 7.1.9 -> 7.2.0
1)Upgrade crash from 7.1.9 to 7.2.0.
2)Delete 0004-crash-fix-build-failure-with-mips.patch, since it is integrated upstream.
Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/crash')
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch | 87 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.2.0.bb (renamed from meta-oe/recipes-kernel/crash/crash_7.1.9.bb) | 5 |
2 files changed, 2 insertions, 90 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch b/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch deleted file mode 100644 index 1e7ce6b38..000000000 --- a/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | From 423ebdce07aa9f398f32c0adf659353069d023c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dengke Du <dengke.du@windriver.com> | ||
3 | Date: Thu, 4 May 2017 07:14:13 +0000 | ||
4 | Subject: [PATCH] crash: fix build failure with mips | ||
5 | |||
6 | When build crash with mips: | ||
7 | |||
8 | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
9 | mips-linux-nat.c:157:1: error: conflicting types for 'ps_get_thread_area' | ||
10 | ps_get_thread_area (const struct ps_prochandle *ph, | ||
11 | ^~~~~~~~~~~~~~~~~~ | ||
12 | In file included from gdb_proc_service.h:26:0, | ||
13 | from mips-linux-nat.c:32: | ||
14 | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
15 | |||
16 | This problem have been fixed on intel and arm plantform, we can use the | ||
17 | similar approch to fix it on mips. | ||
18 | |||
19 | Upstream-status: Submitted [https://github.com/crash-utility/crash/pull/11] | ||
20 | |||
21 | Signed-off-by: Dengke Du <dengke.du@windriver.com> | ||
22 | --- | ||
23 | Makefile | 1 + | ||
24 | crash-fix-build-failure-with-mips.patch | 39 +++++++++++++++++++++++++++++++++ | ||
25 | 2 files changed, 40 insertions(+) | ||
26 | create mode 100644 crash-fix-build-failure-with-mips.patch | ||
27 | |||
28 | diff --git a/Makefile b/Makefile | ||
29 | index 5496523..2ec3325 100644 | ||
30 | --- a/Makefile | ||
31 | +++ b/Makefile | ||
32 | @@ -268,6 +268,7 @@ gdb_patch: | ||
33 | grep 'extern ps_err_e ps_get_thread_area (struct' ${RECIPE_SYSROOT}/usr/include/proc_service.h; \ | ||
34 | if [ $$? -eq 0 ]; then \ | ||
35 | patch -p0 < ${GDB}-proc_service.h.patch; \ | ||
36 | + patch -p1 < crash-fix-build-failure-with-mips.patch; \ | ||
37 | fi; \ | ||
38 | fi | ||
39 | |||
40 | diff --git a/crash-fix-build-failure-with-mips.patch b/crash-fix-build-failure-with-mips.patch | ||
41 | new file mode 100644 | ||
42 | index 0000000..0c70c5f | ||
43 | --- /dev/null | ||
44 | +++ b/crash-fix-build-failure-with-mips.patch | ||
45 | @@ -0,0 +1,39 @@ | ||
46 | +From 615c802d9c73fad48723b6567042cd54f6795849 Mon Sep 17 00:00:00 2001 | ||
47 | +From: Dengke Du <dengke.du@windriver.com> | ||
48 | +Date: Thu, 4 May 2017 06:14:47 +0000 | ||
49 | +Subject: [PATCH] crash: fix build failure with mips | ||
50 | + | ||
51 | +When build crash with mips: | ||
52 | + | ||
53 | +~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
54 | +mips-linux-nat.c:157:1: error: conflicting types for 'ps_get_thread_area' | ||
55 | + ps_get_thread_area (const struct ps_prochandle *ph, | ||
56 | + ^~~~~~~~~~~~~~~~~~ | ||
57 | +In file included from gdb_proc_service.h:26:0, | ||
58 | + from mips-linux-nat.c:32: | ||
59 | +~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
60 | + | ||
61 | +This problem have been fixed on intel and arm plantform, we can use the | ||
62 | +similar approch to fix it on mips. | ||
63 | + | ||
64 | +Signed-off-by: Dengke Du <dengke.du@windriver.com> | ||
65 | +--- | ||
66 | + gdb-7.6/gdb/mips-linux-nat.c | 2 +- | ||
67 | + 1 file changed, 1 insertion(+), 1 deletion(-) | ||
68 | + | ||
69 | +diff --git a/gdb-7.6/gdb/mips-linux-nat.c b/gdb-7.6/gdb/mips-linux-nat.c | ||
70 | +index 61e83c6..d517e37 100644 | ||
71 | +--- a/gdb-7.6/gdb/mips-linux-nat.c | ||
72 | ++++ b/gdb-7.6/gdb/mips-linux-nat.c | ||
73 | +@@ -154,7 +154,7 @@ mips64_linux_register_addr (struct gdbarch *gdbarch, int regno, int store) | ||
74 | + /* Fetch the thread-local storage pointer for libthread_db. */ | ||
75 | + | ||
76 | + ps_err_e | ||
77 | +-ps_get_thread_area (const struct ps_prochandle *ph, | ||
78 | ++ps_get_thread_area (struct ps_prochandle *ph, | ||
79 | + lwpid_t lwpid, int idx, void **base) | ||
80 | + { | ||
81 | + if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0) | ||
82 | +-- | ||
83 | +2.11.0 | ||
84 | + | ||
85 | -- | ||
86 | 2.11.0 | ||
87 | |||
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.9.bb b/meta-oe/recipes-kernel/crash/crash_7.2.0.bb index d40937e93..9bea48e0d 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.1.9.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.2.0.bb | |||
@@ -24,10 +24,9 @@ SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;download | |||
24 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ | 24 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ |
25 | file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ | 25 | file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ |
26 | file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ | 26 | file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ |
27 | file://0004-crash-fix-build-failure-with-mips.patch \ | ||
28 | " | 27 | " |
29 | SRC_URI[md5sum] = "f3b44a151dbe7046462b9caaa9847ca6" | 28 | SRC_URI[md5sum] = "48899de3118e04cfa40a2364f5618193" |
30 | SRC_URI[sha256sum] = "c48e1269443a6a8e8337e328b21b03e4e50248f607eed83fbb27eb0d833d6aa4" | 29 | SRC_URI[sha256sum] = "5d076e1fefb41aa178ad3e1cef6511670efc47de5cb04d4af9bdd4e8f2f18cbc" |
31 | 30 | ||
32 | SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" | 31 | SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" |
33 | SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" | 32 | SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" |