diff options
author | dengke.du@windriver.com <dengke.du@windriver.com> | 2017-04-12 01:42:26 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-18 14:21:41 +0200 |
commit | fc6963cefd3404d2d8793b9054f63fe14fd4a354 (patch) | |
tree | 3a53edaffc3635fd9b59ed8f40920a9af38ef568 /meta-oe/recipes-kernel/crash | |
parent | 8aa550093cdf6dd9ac9cee3097a224aa7050fbcb (diff) | |
download | meta-openembedded-fc6963cefd3404d2d8793b9054f63fe14fd4a354.tar.gz |
crash: 7.1.5 -> 7.1.8
1. Upgrade crash to fix build failure with glibc 2.25.
2. Add the "id" to HOSTTOOLS in meta-oe/layer.conf
Signed-off-by: Dengke Du <dengke.du@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/crash')
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch | 112 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch | 13 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0003-crash-detect-the-sysroot-s-glibc-header-file.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.1.8.bb (renamed from meta-oe/recipes-kernel/crash/crash_7.1.5.bb) | 11 |
5 files changed, 194 insertions, 11 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch new file mode 100644 index 0000000000..9434815d8f --- /dev/null +++ b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch | |||
@@ -0,0 +1,112 @@ | |||
1 | From b8c8fbe0a2481e97fc57dd596346827a692a5768 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dave Anderson <anderson@redhat.com> | ||
3 | Date: Tue, 28 Mar 2017 15:44:40 -0400 | ||
4 | Subject: [PATCH 1/3] Fix for a compilation error if glibc-2.25 or later has | ||
5 | been installed on the host build machine. Without the patch, the build fails | ||
6 | with the error message "amd64-linux-nat.c:496:1: error: conflicting types for | ||
7 | 'ps_get_thread_area'". (anderson@redhat.com) | ||
8 | |||
9 | Upstream-Status: Backport | ||
10 | |||
11 | Signed-off-by: Dengke Du <dengke.du@windriver.com> | ||
12 | --- | ||
13 | Makefile | 6 +++++ | ||
14 | configure.c | 2 +- | ||
15 | gdb-7.6-proc_service.h.patch | 55 ++++++++++++++++++++++++++++++++++++++++++++ | ||
16 | 3 files changed, 62 insertions(+), 1 deletion(-) | ||
17 | create mode 100644 gdb-7.6-proc_service.h.patch | ||
18 | |||
19 | diff --git a/Makefile b/Makefile | ||
20 | index 202ef8b..b6b7e80 100644 | ||
21 | --- a/Makefile | ||
22 | +++ b/Makefile | ||
23 | @@ -264,6 +264,12 @@ gdb_patch: | ||
24 | if [ "${ARCH}" = "x86_64" ] && [ "${TARGET}" = "PPC64" ] && [ -f ${GDB}-ppc64le-support.patch ]; then \ | ||
25 | patch -d ${GDB} -p1 -F0 < ${GDB}-ppc64le-support.patch ; \ | ||
26 | fi | ||
27 | + if [ -f /usr/include/proc_service.h ]; then \ | ||
28 | + grep 'extern ps_err_e ps_get_thread_area (struct' /usr/include/proc_service.h; \ | ||
29 | + if [ $$? -eq 0 ]; then \ | ||
30 | + patch -p0 < ${GDB}-proc_service.h.patch; \ | ||
31 | + fi; \ | ||
32 | + fi | ||
33 | |||
34 | library: make_build_data ${OBJECT_FILES} | ||
35 | ar -rs ${PROGRAM}lib.a ${OBJECT_FILES} | ||
36 | diff --git a/configure.c b/configure.c | ||
37 | index d63cdd7..776defe 100644 | ||
38 | --- a/configure.c | ||
39 | +++ b/configure.c | ||
40 | @@ -240,7 +240,7 @@ struct supported_gdb_version { | ||
41 | "7.6", | ||
42 | "GDB_FILES=${GDB_7.6_FILES}", | ||
43 | "GDB_OFILES=${GDB_7.6_OFILES}", | ||
44 | - "GDB_PATCH_FILES=gdb-7.6.patch gdb-7.6-ppc64le-support.patch", | ||
45 | + "GDB_PATCH_FILES=gdb-7.6.patch gdb-7.6-ppc64le-support.patch gdb-7.6-proc_service.h.patch", | ||
46 | "GDB_FLAGS=-DGDB_7_6", | ||
47 | "GPLv3" | ||
48 | }, | ||
49 | diff --git a/gdb-7.6-proc_service.h.patch b/gdb-7.6-proc_service.h.patch | ||
50 | new file mode 100644 | ||
51 | index 0000000..49d18bb | ||
52 | --- /dev/null | ||
53 | +++ b/gdb-7.6-proc_service.h.patch | ||
54 | @@ -0,0 +1,55 @@ | ||
55 | +--- gdb-7.6/gdb/gdb_proc_service.h.orig | ||
56 | ++++ gdb-7.6/gdb/gdb_proc_service.h | ||
57 | +@@ -115,7 +115,7 @@ extern pid_t ps_getpid (struct ps_procha | ||
58 | + /* Fetch the special per-thread address associated with the given LWP. | ||
59 | + This call is only used on a few platforms (most use a normal register). | ||
60 | + The meaning of the `int' parameter is machine-dependent. */ | ||
61 | +-extern ps_err_e ps_get_thread_area (const struct ps_prochandle *, | ||
62 | ++extern ps_err_e ps_get_thread_area (struct ps_prochandle *, | ||
63 | + lwpid_t, int, psaddr_t *); | ||
64 | + | ||
65 | + | ||
66 | +--- gdb-7.6/gdb/amd64-linux-nat.c.orig | ||
67 | ++++ gdb-7.6/gdb/amd64-linux-nat.c | ||
68 | +@@ -493,7 +493,7 @@ amd64_linux_new_fork (struct lwp_info *p | ||
69 | + a request for a thread's local storage address. */ | ||
70 | + | ||
71 | + ps_err_e | ||
72 | +-ps_get_thread_area (const struct ps_prochandle *ph, | ||
73 | ++ps_get_thread_area (struct ps_prochandle *ph, | ||
74 | + lwpid_t lwpid, int idx, void **base) | ||
75 | + { | ||
76 | + if (gdbarch_bfd_arch_info (target_gdbarch ())->bits_per_word == 32) | ||
77 | +--- gdb-7.6/gdb/aarch64-linux-nat.c.orig | ||
78 | ++++ gdb-7.6/gdb/aarch64-linux-nat.c | ||
79 | +@@ -750,7 +750,7 @@ aarch64_linux_new_fork (struct lwp_info | ||
80 | + storage (or its descriptor). */ | ||
81 | + | ||
82 | + ps_err_e | ||
83 | +-ps_get_thread_area (const struct ps_prochandle *ph, | ||
84 | ++ps_get_thread_area (struct ps_prochandle *ph, | ||
85 | + lwpid_t lwpid, int idx, void **base) | ||
86 | + { | ||
87 | + struct iovec iovec; | ||
88 | +--- gdb-7.6/gdb/arm-linux-nat.c.orig | ||
89 | ++++ gdb-7.6/gdb/arm-linux-nat.c | ||
90 | +@@ -613,7 +613,7 @@ supply_fpregset (struct regcache *regcac | ||
91 | + /* Fetch the thread-local storage pointer for libthread_db. */ | ||
92 | + | ||
93 | + ps_err_e | ||
94 | +-ps_get_thread_area (const struct ps_prochandle *ph, | ||
95 | ++ps_get_thread_area (struct ps_prochandle *ph, | ||
96 | + lwpid_t lwpid, int idx, void **base) | ||
97 | + { | ||
98 | + if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0) | ||
99 | +--- gdb-7.6/gdb/i386-linux-nat.c.orig | ||
100 | ++++ gdb-7.6/gdb/i386-linux-nat.c | ||
101 | +@@ -849,7 +849,7 @@ i386_linux_new_fork (struct lwp_info *pa | ||
102 | + storage (or its descriptor). */ | ||
103 | + | ||
104 | + ps_err_e | ||
105 | +-ps_get_thread_area (const struct ps_prochandle *ph, | ||
106 | ++ps_get_thread_area (struct ps_prochandle *ph, | ||
107 | + lwpid_t lwpid, int idx, void **base) | ||
108 | + { | ||
109 | + /* NOTE: cagney/2003-08-26: The definition of this buffer is found | ||
110 | -- | ||
111 | 2.8.1 | ||
112 | |||
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch b/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch index 39732a9eda..26a34e5c16 100644 --- a/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch +++ b/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch | |||
@@ -1,14 +1,15 @@ | |||
1 | From cbaaa42933bb27b1bcff4c7d71d54c913201ee88 Mon Sep 17 00:00:00 2001 | 1 | From 73269df4d8196abe81112acaa2613155b308a8b8 Mon Sep 17 00:00:00 2001 |
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | 2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> |
3 | Date: Fri, 9 Jan 2015 11:51:18 +0900 | 3 | Date: Fri, 9 Jan 2015 11:51:18 +0900 |
4 | Subject: [PATCH] cross_add_configure_option | 4 | Subject: [PATCH 1/9] cross_add_configure_option |
5 | 5 | ||
6 | %% original patch: 0001-cross_add_configure_option.patch | ||
6 | --- | 7 | --- |
7 | Makefile | 4 ++-- | 8 | Makefile | 4 ++-- |
8 | 1 file changed, 2 insertions(+), 2 deletions(-) | 9 | 1 file changed, 2 insertions(+), 2 deletions(-) |
9 | 10 | ||
10 | diff --git a/Makefile b/Makefile | 11 | diff --git a/Makefile b/Makefile |
11 | index 9c44633..39bebd0 100644 | 12 | index a2baec1..f1972c8 100644 |
12 | --- a/Makefile | 13 | --- a/Makefile |
13 | +++ b/Makefile | 14 | +++ b/Makefile |
14 | @@ -232,7 +232,7 @@ gdb_merge: force | 15 | @@ -232,7 +232,7 @@ gdb_merge: force |
@@ -20,15 +21,15 @@ index 9c44633..39bebd0 100644 | |||
20 | --with-bugurl="" --with-expat=no --with-python=no --disable-sim; \ | 21 | --with-bugurl="" --with-expat=no --with-python=no --disable-sim; \ |
21 | make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \ | 22 | make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \ |
22 | else make --no-print-directory rebuild; fi | 23 | else make --no-print-directory rebuild; fi |
23 | @@ -277,7 +277,7 @@ force: | 24 | @@ -283,7 +283,7 @@ force: |
24 | 25 | ||
25 | make_configure: force | 26 | make_configure: force |
26 | @rm -f configure | 27 | @rm -f configure |
27 | - @${CC} ${CONF_FLAGS} -o configure configure.c ${WARNING_ERROR} ${WARNING_OPTIONS} | 28 | - @${CC} ${CONF_FLAGS} -o configure configure.c ${WARNING_ERROR} ${WARNING_OPTIONS} |
28 | + @cc ${CONF_FLAGS} -o configure configure.c ${WARNING_ERROR} ${WARNING_OPTIONS} | 29 | + @${BUILD_CC} ${CONF_FLAGS} -o configure configure.c ${WARNING_ERROR} ${WARNING_OPTIONS} |
29 | 30 | ||
30 | clean: make_configure | 31 | clean: make_configure |
31 | @./configure ${CONF_TARGET_FLAG} -q -b | 32 | @./configure ${CONF_TARGET_FLAG} -q -b |
32 | -- | 33 | -- |
33 | 1.8.4.2 | 34 | 2.8.1 |
34 | 35 | ||
diff --git a/meta-oe/recipes-kernel/crash/crash/0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch b/meta-oe/recipes-kernel/crash/crash/0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch new file mode 100644 index 0000000000..8355fe44ea --- /dev/null +++ b/meta-oe/recipes-kernel/crash/crash/0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 52fc1a7c17768fd52c3577d21dad84e8babb94b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dengke Du <dengke.du@windriver.com> | ||
3 | Date: Thu, 6 Apr 2017 23:01:14 -0400 | ||
4 | Subject: [PATCH 2/3] crash: fix build error unknown type name 'gdb_fpregset_t' | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Dengke Du <dengke.du@windriver.com> | ||
9 | --- | ||
10 | gdb-7.6/gdb/gdb_proc_service.h | 3 +-- | ||
11 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/gdb-7.6/gdb/gdb_proc_service.h b/gdb-7.6/gdb/gdb_proc_service.h | ||
14 | index 8bc6088..99c6496 100644 | ||
15 | --- a/gdb-7.6/gdb/gdb_proc_service.h | ||
16 | +++ b/gdb-7.6/gdb/gdb_proc_service.h | ||
17 | @@ -20,6 +20,7 @@ | ||
18 | #define GDB_PROC_SERVICE_H | ||
19 | |||
20 | #include <sys/types.h> | ||
21 | +#include "gregset.h" | ||
22 | |||
23 | #ifdef HAVE_PROC_SERVICE_H | ||
24 | #include <proc_service.h> | ||
25 | @@ -53,8 +54,6 @@ | ||
26 | #include <sys/procfs.h> | ||
27 | #endif | ||
28 | |||
29 | -#include "gregset.h" | ||
30 | - | ||
31 | /* Functions in this interface return one of these status codes. */ | ||
32 | typedef enum | ||
33 | { | ||
34 | -- | ||
35 | 2.8.1 | ||
36 | |||
diff --git a/meta-oe/recipes-kernel/crash/crash/0003-crash-detect-the-sysroot-s-glibc-header-file.patch b/meta-oe/recipes-kernel/crash/crash/0003-crash-detect-the-sysroot-s-glibc-header-file.patch new file mode 100644 index 0000000000..1f4bd01da4 --- /dev/null +++ b/meta-oe/recipes-kernel/crash/crash/0003-crash-detect-the-sysroot-s-glibc-header-file.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From c7950ef5228adc52a500b4fc67d7e48c3c09c1df Mon Sep 17 00:00:00 2001 | ||
2 | From: Dengke Du <dengke.du@windriver.com> | ||
3 | Date: Thu, 6 Apr 2017 23:02:44 -0400 | ||
4 | Subject: [PATCH 3/3] crash: detect the sysroot's glibc header file | ||
5 | |||
6 | This is cross compile, so let the Makefile detect the sysroot's glibc | ||
7 | header file, not the host's glibc header file. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Dengke Du <dengke.du@windriver.com> | ||
12 | --- | ||
13 | Makefile | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index b6b7e80..94f21a5 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -264,8 +264,8 @@ gdb_patch: | ||
21 | if [ "${ARCH}" = "x86_64" ] && [ "${TARGET}" = "PPC64" ] && [ -f ${GDB}-ppc64le-support.patch ]; then \ | ||
22 | patch -d ${GDB} -p1 -F0 < ${GDB}-ppc64le-support.patch ; \ | ||
23 | fi | ||
24 | - if [ -f /usr/include/proc_service.h ]; then \ | ||
25 | - grep 'extern ps_err_e ps_get_thread_area (struct' /usr/include/proc_service.h; \ | ||
26 | + if [ -f ${RECIPE_SYSROOT}/usr/include/proc_service.h ]; then \ | ||
27 | + grep 'extern ps_err_e ps_get_thread_area (struct' ${RECIPE_SYSROOT}/usr/include/proc_service.h; \ | ||
28 | if [ $$? -eq 0 ]; then \ | ||
29 | patch -p0 < ${GDB}-proc_service.h.patch; \ | ||
30 | fi; \ | ||
31 | -- | ||
32 | 2.8.1 | ||
33 | |||
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb b/meta-oe/recipes-kernel/crash/crash_7.1.8.bb index fbd89c316d..012ef1a9a7 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.1.5.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.1.8.bb | |||
@@ -22,10 +22,13 @@ SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;download | |||
22 | file://donnot-extract-gdb-during-do-compile.patch \ | 22 | file://donnot-extract-gdb-during-do-compile.patch \ |
23 | file://gdb_build_jobs_and_not_write_crash_target.patch \ | 23 | file://gdb_build_jobs_and_not_write_crash_target.patch \ |
24 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ | 24 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ |
25 | file://0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch \ | ||
26 | file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ | ||
27 | file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ | ||
25 | " | 28 | " |
26 | 29 | ||
27 | SRC_URI[md5sum] = "7bd06eaec6827d4fac636b2b592d3056" | 30 | SRC_URI[md5sum] = "31787074f267a3536eebff008a0652ec" |
28 | SRC_URI[sha256sum] = "c3954412c8557614a0d50092c007aa96b4e3e6e97453dfbb60241ab680caf7b2" | 31 | SRC_URI[sha256sum] = "9965dee9199d7e39764fbee7f21c7c45b1f7b6d17c8e92ad62f468f062876478" |
29 | 32 | ||
30 | SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" | 33 | SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" |
31 | SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" | 34 | SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" |
@@ -80,7 +83,7 @@ do_compile_prepend() { | |||
80 | } | 83 | } |
81 | 84 | ||
82 | do_compile() { | 85 | do_compile() { |
83 | oe_runmake ${EXTRA_OEMAKE} | 86 | oe_runmake ${EXTRA_OEMAKE} RECIPE_SYSROOT=${RECIPE_SYSROOT} |
84 | } | 87 | } |
85 | 88 | ||
86 | do_install_prepend () { | 89 | do_install_prepend () { |
@@ -111,5 +114,3 @@ RDEPENDS_${PN}_class-cross = "" | |||
111 | # Causes gcc to get stuck and eat all available memory in qemuarm builds | 114 | # Causes gcc to get stuck and eat all available memory in qemuarm builds |
112 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - | 115 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - |
113 | ARM_INSTRUCTION_SET = "arm" | 116 | ARM_INSTRUCTION_SET = "arm" |
114 | |||
115 | PNBLACKLIST[crash] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130678/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||