diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-08-17 00:25:56 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-17 12:26:41 -0700 |
commit | c699d2088e4149dc3043542652b6370c51735b6d (patch) | |
tree | 8682b2cfba4928b0002bdc2e6b64d164cf808914 /meta-oe/recipes-kernel/crash | |
parent | 545f6d08919894295b0ecdf581d8a225f3f741de (diff) | |
download | meta-openembedded-c699d2088e4149dc3043542652b6370c51735b6d.tar.gz |
crash: Fix arm64 build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/crash')
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch | 54 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.2.8.bb | 1 |
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch new file mode 100644 index 000000000..c94644438 --- /dev/null +++ b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 0dddb4e1158705345b7f4f71635d42c89e1b0c8f Mon Sep 17 00:00:00 2001 | ||
2 | From: Dave Anderson <anderson@redhat.com> | ||
3 | Date: Fri, 31 Jan 2020 17:11:46 -0500 | ||
4 | Subject: [PATCH] Fix for an ARM64 gcc-10 compilation error. Without the | ||
5 | patch, the build of the embedded gdb module fails with an error message that | ||
6 | indicates "multiple definition of 'tdesc_aarch64'". (anderson@redhat.com) | ||
7 | |||
8 | Upstream-Status: Backport [https://github.com/crash-utility/crash/commit/e770735200c02ac2414c394ea6ec5f7f033efe64] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | gdb-7.6.patch | 30 ++++++++++++++++++++++++++++++ | ||
12 | 1 file changed, 30 insertions(+) | ||
13 | |||
14 | diff --git a/gdb-7.6.patch b/gdb-7.6.patch | ||
15 | index f6c311d..f64b55f 100644 | ||
16 | --- a/gdb-7.6.patch | ||
17 | +++ b/gdb-7.6.patch | ||
18 | @@ -2471,3 +2471,33 @@ diff -up gdb-7.6/opcodes/configure.orig gdb-7.6/opcodes/configure | ||
19 | #else | ||
20 | # error "!__i386__ && !__x86_64__" | ||
21 | #endif | ||
22 | +--- gdb-7.6/gdb/features/aarch64.c.orig | ||
23 | ++++ gdb-7.6/gdb/features/aarch64.c | ||
24 | +@@ -5,7 +5,6 @@ | ||
25 | + #include "osabi.h" | ||
26 | + #include "target-descriptions.h" | ||
27 | + | ||
28 | +-struct target_desc *tdesc_aarch64; | ||
29 | + static void | ||
30 | + initialize_tdesc_aarch64 (void) | ||
31 | + { | ||
32 | +--- gdb-7.6/gdb/aarch64-linux-nat.c.orig | ||
33 | ++++ gdb-7.6/gdb/aarch64-linux-nat.c | ||
34 | +@@ -37,6 +37,7 @@ | ||
35 | + | ||
36 | + #include "gregset.h" | ||
37 | + | ||
38 | ++extern struct target_desc *tdesc_aarch64; | ||
39 | + #include "features/aarch64.c" | ||
40 | + | ||
41 | + /* Defines ps_err_e, struct ps_prochandle. */ | ||
42 | +--- gdb-7.6/gdb/aarch64-tdep.c.orig | ||
43 | ++++ gdb-7.6/gdb/aarch64-tdep.c | ||
44 | +@@ -52,6 +52,7 @@ | ||
45 | + #include "gdb_assert.h" | ||
46 | + #include "vec.h" | ||
47 | + | ||
48 | ++struct target_desc *tdesc_aarch64; | ||
49 | + #include "features/aarch64.c" | ||
50 | + #include "features/aarch64-without-fpu.c" | ||
51 | + | ||
52 | -- | ||
53 | 2.28.0 | ||
54 | |||
diff --git a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb index 834c92cc4..6e2533635 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb | |||
@@ -25,6 +25,7 @@ SRC_URI = "git://github.com/crash-utility/${BPN}.git \ | |||
25 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ | 25 | file://remove-unrecognized-gcc-option-m32-for-mips.patch \ |
26 | file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ | 26 | file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ |
27 | file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ | 27 | file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ |
28 | file://0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch \ | ||
28 | " | 29 | " |
29 | SRCREV = "24f4801f8c8871a2e3e660fe9fa8fdd86bb29876" | 30 | SRCREV = "24f4801f8c8871a2e3e660fe9fa8fdd86bb29876" |
30 | 31 | ||