summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-29 21:26:22 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit233d3b20c5892f34ce4949fcf9bb5d9bcde11d56 (patch)
tree6ada12679eb29e1f0cbb336a07b0f27ab9f062be /meta-oe/recipes-graphics
parent502ec72e60ecdd1bbcaeedefc228cdb9753f0f79 (diff)
downloadmeta-openembedded-233d3b20c5892f34ce4949fcf9bb5d9bcde11d56.tar.gz
fontforge: Upgrade to 20190801 release
License-Update: Dropped plugins [1] and gnulib [2] - Add a fix for musl build to include sys/select.h - gnulib dependency is not needed anymore - Disable libuninameslist, recipe is missing in OE [1] https://github.com/fontforge/fontforge/commit/ed62345e3ad7484cd0bf714f5ef9c7012dad157c#diff-9879d6db96fd29134fc802214163b95a [2] https://github.com/fontforge/fontforge/commit/51c045a09804c20725527878c753df6ba96dafa8#diff-9879d6db96fd29134fc802214163b95a Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch29
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb62
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb46
3 files changed, 75 insertions, 62 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch b/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch
new file mode 100644
index 000000000..54ff7b76d
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge/0001-include-sys-select-on-non-glibc-platforms.patch
@@ -0,0 +1,29 @@
1From 798f2816130838f3618212291de6ab0ea814c868 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 29 Sep 2019 20:39:02 -0700
4Subject: [PATCH] include sys/select on non-glibc platforms
5
6musl needs sys/select.h for defining fd_set
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 gdraw/gdraw.c | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/gdraw/gdraw.c b/gdraw/gdraw.c
15index 24591b778..217c63140 100644
16--- a/gdraw/gdraw.c
17+++ b/gdraw/gdraw.c
18@@ -32,7 +32,7 @@
19 #include "gkeysym.h"
20 #include "ustring.h"
21
22-#if __Mac || __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__
23+#if __Mac || __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__ || !defined(__GLIBC__)
24 # include <sys/select.h>
25 #endif
26
27--
282.23.0
29
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb
deleted file mode 100644
index ee3bc58bc..000000000
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20190413.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1SUMMARY = "A font editor"
2HOMEPAGE = "http://fontforge.github.io/en-US/"
3LICENSE = "BSD-3-Clause & GPLv3"
4LIC_FILES_CHKSUM = " \
5 file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
6 file://LICENSE;md5=5f9637af5c51f2e8d06385ef38eb48f1 \
7"
8
9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gnulib gettext-native"
10DEPENDS_append_class-target = " libxi"
11
12inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
13
14REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
15
16SRC_URI = "git://github.com/${BPN}/${BPN}.git"
17# tag 20190413
18SRCREV = "7f6f1d021fdfea7789972f9534ba3241616d8dfc"
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF_append_class-native = " with_x=no"
22
23do_configure_prepend() {
24 # uthash sources are expected in uthash/src
25 currdir=`pwd`
26 cd ${S}
27
28 mkdir -p uthash/src
29 cp ${STAGING_INCDIR}/ut*.h uthash/src
30
31 # avoid bootstrap cloning gnulib on every configure
32 cat >.gitmodules <<EOF
33[submodule "gnulib"]
34 path = gnulib
35 url = git://git.sv.gnu.org/gnulib
36EOF
37 cp -rf ${STAGING_DATADIR}/gnulib ${S}
38
39 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
40 # | bootstrap: running: libtoolize --quiet
41 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
42 # | ...
43 ./bootstrap --force
44
45 cd $currdir
46}
47
48PACKAGES =+ "${PN}-python"
49
50RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
51
52FILES_${PN} += " \
53 ${datadir}/appdata \
54 ${datadir}/metainfo \
55 ${datadir}/mime \
56"
57
58FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
59RDEPENDS_${PN}-python = "python"
60
61# for e.g kde's oxygen-fonts
62BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
new file mode 100644
index 000000000..25c2ce81f
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -0,0 +1,46 @@
1SUMMARY = "A font editor"
2HOMEPAGE = "http://fontforge.github.io/en-US/"
3LICENSE = "BSD-3-Clause & GPLv3"
4LIC_FILES_CHKSUM = " \
5 file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
6 file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
7"
8
9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native"
10DEPENDS_append_class-target = " libxi"
11
12inherit autotools pkgconfig pythonnative distro_features_check gettext gtk-icon-cache mime
13
14REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
15
16# tag 20190801
17SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
18SRC_URI = "git://github.com/${BPN}/${BPN}.git \
19 file://0001-include-sys-select-on-non-glibc-platforms.patch \
20"
21S = "${WORKDIR}/git"
22
23EXTRA_OECONF += "--without-libuninameslist"
24EXTRA_OECONF_append_class-native = " with_x=no"
25
26#do_configure_prepend() {
27# uthash sources are expected in uthash/src
28# mkdir -p ${S}/uthash/src
29# cp ${STAGING_INCDIR}/ut*.h ${S}/uthash/src
30#}
31
32PACKAGES =+ "${PN}-python"
33
34RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
35
36FILES_${PN} += " \
37 ${datadir}/appdata \
38 ${datadir}/metainfo \
39 ${datadir}/mime \
40"
41
42FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
43RDEPENDS_${PN}-python = "python"
44
45# for e.g kde's oxygen-fonts
46BBCLASSEXTEND = "native"