summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-04 17:45:56 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-06 08:59:14 -0700
commit5f69cfea691d3770012ba97c808567fe6e99cd4f (patch)
tree1d0fdbc6215d7c757e6e40e9921aa70b3d3ff86f /meta-oe/recipes-graphics
parent21580d65af95a854cccc7d0bf5c31201c9c30ea9 (diff)
downloadmeta-openembedded-5f69cfea691d3770012ba97c808567fe6e99cd4f.tar.gz
lv-drivers: Add recipe for lvgl lib
Wayland driver is supported. Change-Id: If734c0f1037a1feeb08a2a67fa76e3142ae35af0 Forwarded: https://github.com/openembedded/meta-openembedded/pull/447 Origin: https://git.ostc-eu.org/OSTC/planning/core-os/-/issues/233 Relate-to: https://github.com/lvgl/lvgl/issues/2534 Signed-off-by: Philippe Coval <philippe.coval@huawei.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
new file mode 100644
index 000000000..a7478d4d5
--- /dev/null
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -0,0 +1,45 @@
1# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
4# TODO: Pin upstream release (current v7.11.0-80-g419a757)
5src_org = "lvgl"
6SRC_URI = "gitsm://github.com/${src_org}/lv_drivers;destsuffix=${S};protocol=https;nobranch=1"
7SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
11
12HOMEPAGE = "https://docs.lvgl.io/latest/en/html/porting/index.html"
13SUMMARY = "LVGL's Display and Touch pad drivers"
14DESCRIPTION = "Collection of drivers: SDL, framebuffer, wayland and more..."
15
16DEPENDS += "libxkbcommon"
17DEPENDS += "lvgl"
18DEPENDS += "wayland"
19
20REQUIRED_DISTRO_FEATURES = "wayland"
21
22inherit cmake
23inherit features_check
24
25S = "${WORKDIR}/${PN}-${PV}"
26
27EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
28
29TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
30TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
31
32
33do_configure:append() {
34 [ -r "${S}/lv_drv_conf.h" ] \
35 || sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
36 -e "s|# define USE_WAYLAND 0|# define USE_WAYLAND 1|g" \
37 < "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h"
38}
39
40
41FILES:${PN}-dev = "\
42 ${includedir}/lvgl/lv_drivers/ \
43 "
44
45FILES:${PN}-staticdev = "${libdir}/"