summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-09-07 23:08:27 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 10:24:44 +0200
commitd957e045c04e026e87d6325735c3e07029d32423 (patch)
tree6534a24d6979885b4b6f85ee52bf28e9a69c59be /meta-oe/recipes-graphics
parentd07327e6589de9f13fb91daa716728ac2306e3cd (diff)
downloadmeta-openembedded-d957e045c04e026e87d6325735c3e07029d32423.tar.gz
xserver-xorg: drop 1.10.2 and use xserver-xf86-lite-1.11.0 from oe-core instead
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xorg-xserver-common.inc126
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch61
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch14
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch39
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch102
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch33
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb33
7 files changed, 0 insertions, 408 deletions
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xorg-xserver-common.inc b/meta-oe/recipes-graphics/xorg-xserver/xorg-xserver-common.inc
deleted file mode 100644
index 0b4a8548c..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xorg-xserver-common.inc
+++ /dev/null
@@ -1,126 +0,0 @@
1HOMEPAGE = "http://www.x.org"
2SECTION = "x11/base"
3LICENSE = "MIT-X"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3dd2bbe3563837f80ed8926b06c1c353"
5
6INC_PR = "r21"
7
8# xf86-*-* packages depend on an X server built with the xfree86 DDX
9# so we have a virtual to represent that:
10PROVIDES = "virtual/xserver-xf86"
11
12# Other packages tend to just care that there is *an* X server:
13PROVIDES += "virtual/xserver"
14
15# Config manager for xserver, options are: hal, udev, empty (for configuration in xorg.conf)
16DISTRO_XORG_CONFIG_MANAGER ?= "udev"
17
18# default none, enabled by DISTRO_XORG_CONFIG_MANAGER setting
19CONFIG_MANAGER_OPTION += "${@['--disable-config-hal','--enable-config-hal',''][bb.data.getVar('DISTRO_XORG_CONFIG_MANAGER',d) in ['hal']]}"
20CONFIG_MANAGER_OPTION += "${@['--disable-config-udev','--enable-config-udev',''][bb.data.getVar('DISTRO_XORG_CONFIG_MANAGER',d) in ['udev']]}"
21
22DEPENDS = "fontconfig freetype flex-native liblbxutil kbproto \
23xf86driproto drm glproto randrproto renderproto fixesproto damageproto \
24xcmiscproto xextproto xproto xf86miscproto xf86vidmodeproto xf86bigfontproto \
25scrnsaverproto bigreqsproto resourceproto fontsproto inputproto \
26xf86dgaproto videoproto compositeproto trapproto recordproto dmxproto \
27resourceproto xineramaproto xtrans evieext libxkbfile libxfont libxau \
28libfontenc libxdmcp libxxf86vm libxaw libxmu libxt libxpm libxext libx11 \
29libxkbui libxxf86misc libxi libdmx libxtst libxres virtual/libgl libxcalibrate \
30libxv ${DISTRO_XORG_CONFIG_MANAGER}"
31
32RRECOMMENDS_${PN} = "libpciaccess"
33
34XORG_PN = "xorg-server"
35SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
36
37S = "${WORKDIR}/${XORG_PN}-${PV}"
38
39inherit autotools pkgconfig glx-use-tls
40
41EXTRA_OECONF += " --enable-xcalibrate \
42 --enable-kdrive \
43 --enable-xephyr \
44 --disable-xfbdev \
45 --disable-xnest \
46 --disable-kdrive-vesa \
47 --with-default-font-path="${datadir}/fonts/X11/misc" \
48 ac_cv_file__usr_share_sgml_X11_defs_ent=no"
49
50# CONFIG_MANAGER_OPTION is used only in recipes which support those options
51
52EXTRA_OECONF_append_arm = " ac_cv_header_linux_apm_bios_h=no "
53
54PACKAGES =+ "xserver-security-policy"
55FILES_xserver-security-policy += "${libdir}/xserver/SecurityPolicy"
56RRECOMMENDS_${PN} += "xserver-security-policy xkeyboard-config rgb xserver-xf86-config"
57
58PACKAGES =+ "${PN}-sdl ${PN}-fbdev ${PN}-xprint ${PN}-xvfb ${PN}-utils ${PN}-xephyr"
59
60RDEPENDS_${PN}-xvfb += "xkeyboard-config"
61
62FILES_${PN}-fbdev = "${bindir}/Xfbdev"
63FILES_${PN}-sdl = "${bindir}/Xsdl"
64FILES_${PN}-xprint = "${libdir}/X11/xserver/*/print"
65FILES_${PN}-xvfb = "${bindir}/Xvfb"
66FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
67FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/modules/*.so ${libdir}/xorg/modules/*.so /etc/X11 ${libdir}/xorg/protocol.txt ${datadir}/X11/xorg.conf.d"
68FILES_${PN}-doc += "${libdir}/X11/doc ${datadir}/X11/xkb/compiled/README.compiled"
69FILES_${PN}-xephyr = "${bindir}/Xephyr"
70
71FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
72 ${libdir}/xorg/modules/*/.debug \
73 ${libdir}/xorg/modules/*/*/.debug \
74 "
75
76# Split out some modules and extensions from the main package
77# These aren't needed for basic operations and only take up space:
78# 32.0k libdri.so
79# 336.0k libglx.so
80# 1360k libint10.so
81# 180.0k libwfb.so
82# 320.0k libxaa.so
83# 124.0k libxf1bpp.so
84# 84.0k libxf4bpp.so
85# librecord.so
86# libextmod.so
87# libdbe.so
88
89PACKAGES =+ "${PN}-extension-dri \
90 ${PN}-extension-dri2 \
91 ${PN}-extension-glx \
92 ${PN}-extension-record \
93 ${PN}-extension-extmod \
94 ${PN}-extension-dbe \
95 ${PN}-module-libint10 \
96 ${PN}-module-libafb \
97 ${PN}-module-libwfb \
98 ${PN}-module-libmfb \
99 ${PN}-module-libcfb \
100 ${PN}-module-xaa \
101 ${PN}-module-libxf1bpp \
102 ${PN}-module-libxf4bpp"
103
104
105FILES_${PN}-extension-dri = "${libdir}/xorg/modules/extensions/libdri.so"
106FILES_${PN}-extension-dri2 = "${libdir}/xorg/modules/extensions/libdri2.so"
107FILES_${PN}-extension-glx = "${libdir}/xorg/modules/extensions/libglx.so"
108FILES_${PN}-extension-record = "${libdir}/xorg/modules/extensions/librecord.so"
109FILES_${PN}-extension-extmod = "${libdir}/xorg/modules/extensions/libextmod.so"
110FILES_${PN}-extension-dbe = "${libdir}/xorg/modules/extensions/libdbe.so"
111FILES_${PN}-module-libint10 = "${libdir}/xorg/modules/libint10.so"
112FILES_${PN}-module-libafb = "${libdir}/xorg/modules/libafb.so"
113FILES_${PN}-module-libwfb = "${libdir}/xorg/modules/libwfb.so"
114FILES_${PN}-module-libmfb = "${libdir}/xorg/modules/libmfb.so"
115FILES_${PN}-module-libcfb = "${libdir}/xorg/modules/libcfb.so"
116FILES_${PN}-module-xaa = "${libdir}/xorg/modules/libxaa.so"
117FILES_${PN}-module-libxf1bpp = "${libdir}/xorg/modules/libxf1bpp.so"
118FILES_${PN}-module-libxf4bpp = "${libdir}/xorg/modules/libxf4bpp.so"
119
120PACKAGES =+ "${PN}-multimedia-modules"
121
122FILES_${PN}-multimedia-modules = "${libdir}/xorg/modules/multimedia/*drv*"
123
124do_install_append () {
125 ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
126}
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
deleted file mode 100644
index 2c4078a00..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From 50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd Mon Sep 17 00:00:00 2001
2From: Aaron Plattner <aplattner@nvidia.com>
3Date: Tue, 24 May 2011 23:02:42 +0000
4Subject: randr: check rotated virtual size limits correctly
5
6Commit d1107918d4626268803b54033a07405122278e7f introduced checks to
7the RandR path that cause RRSetScreenConfig requests to fail if the
8size is too large. Unfortunately, when RandR 1.1 rotation is enabled
9it compares the rotated screen dimensions to the unrotated limits,
10which causes 90- and 270-degree rotation to fail unless your screen
11happens to be square:
12
13 X Error of failed request: BadValue (integer parameter out of range for operation)
14 Major opcode of failed request: 153 (RANDR)
15 Minor opcode of failed request: 2 (RRSetScreenConfig)
16 Value in failed request: 0x780
17 Serial number of failed request: 14
18 Current serial number in output stream: 14
19
20Fix this by moving the check above the code that swaps the dimensions
21based on the rotation.
22
23Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
24Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
25Tested-by: Robert Hooker <robert.hooker@canonical.com>
26Tested-by: Kent Baxley <kent.baxley@canonical.com>
27Signed-off-by: Keith Packard <keithp@keithp.com>
28(cherry picked from commit b6c7b9b2f39e970cedb6bc1e073f901e28cb0fa3)
29---
30diff --git a/randr/rrscreen.c b/randr/rrscreen.c
31index 1bc1a9e..da6d48d 100644
32--- a/randr/rrscreen.c
33+++ b/randr/rrscreen.c
34@@ -910,12 +910,6 @@ ProcRRSetScreenConfig (ClientPtr client)
35 */
36 width = mode->mode.width;
37 height = mode->mode.height;
38- if (rotation & (RR_Rotate_90|RR_Rotate_270))
39- {
40- width = mode->mode.height;
41- height = mode->mode.width;
42- }
43-
44 if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) {
45 client->errorValue = width;
46 free(pData);
47@@ -927,6 +921,12 @@ ProcRRSetScreenConfig (ClientPtr client)
48 return BadValue;
49 }
50
51+ if (rotation & (RR_Rotate_90|RR_Rotate_270))
52+ {
53+ width = mode->mode.height;
54+ height = mode->mode.width;
55+ }
56+
57 if (width != pScreen->width || height != pScreen->height)
58 {
59 int c;
60--
61cgit v0.8.3-6-g21f6
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
deleted file mode 100644
index a947582f1..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1diff --git a/fb/fbcopy.c b/fb/fbcopy.c
2index 07eb663..ba394b7 100644
3--- a/fb/fbcopy.c
4+++ b/fb/fbcopy.c
5@@ -91,8 +91,7 @@ fbCopyNtoN (DrawablePtr pSrcDrawable,
6 while (nbox--)
7 {
8 #ifndef FB_ACCESS_WRAPPER /* pixman_blt() doesn't support accessors yet */
9- if (pm == FB_ALLONES && alu == GXcopy && !reverse &&
10- !upsidedown)
11+ if (pm == FB_ALLONES && alu == GXcopy)
12 {
13 if (!pixman_blt ((uint32_t *)src, (uint32_t *)dst, srcStride, dstStride, srcBpp, dstBpp,
14 (pbox->x1 + dx + srcXoff),
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
deleted file mode 100644
index d3661cbea..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1Ugly hack that prevents server termination with xf86-video-fbdev-0.4.1
2(and probably other) while returning from chvt or resume on some
3hardware (e. g. zaurus).
4
5Correct fix would require debugging of fbdev mode during LeaveVT and
6EnterVT.
7
8This patch may cause staying in incorrect or corrupted display mode
9after EnterVT, but on man affected devices it does not cause any visible
10problems.
11
12Hacked code is never called on properly written drivers.
13
14Devices affected and testers involved for future patch removal:
15Sharp Zaurus (spitz/akita): Stanislav Brabec <utx@penguin.cz>
16
17See also:
18https://bugzilla.redhat.com/show_bug.cgi?id=238451
19
20The bug (first line indicates that your device is affected):
21
22(EE) FBDEV(0): FBIOPUT_VSCREENINFO succeeded but modified mode
23
24Fatal server error:
25EnterVT failed for screen 0
26
27Index: xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
28===================================================================
29--- xorg-server-1.7.3.orig/hw/xfree86/fbdevhw/fbdevhw.c
30+++ xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
31@@ -571,7 +571,7 @@ fbdevHWSetMode(ScrnInfoPtr pScrn, Displa
32 #if DEBUG
33 print_fbdev_mode("returned", &set_var);
34 #endif
35- return FALSE;
36+ /* return FALSE; UGLY HACK to allow return from chvt */
37 }
38
39 if (!check)
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
deleted file mode 100644
index 632a64ce5..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
+++ /dev/null
@@ -1,102 +0,0 @@
1diff -ur xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c git/xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c
2--- xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c 2011-04-28 09:25:00.000000000 +0200
3+++ git/xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c 2011-05-19 00:31:01.178439874 +0200
4@@ -99,6 +99,8 @@
5 return; \
6 }
7
8+#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
9+
10 EventListPtr xf86Events = NULL;
11
12 static int
13@@ -1408,4 +1410,73 @@
14 EnableDevice(dev, TRUE);
15 }
16
17+/* Taken from evdev-properties.h. */
18+#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
19+#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
20+
21+/* This is a hack until we get device -> CRTC association. */
22+void
23+xf86InputRotationNotify(Rotation rotation)
24+{
25+ DeviceIntPtr dev;
26+ //LocalDevicePtr local;
27+ int ret;
28+ int swap_axes = 0;
29+ CARD8 invert[2] = { 0, 0 };
30+ static Atom prop_swap = 0, prop_invert = 0;
31+ static int atom_generation = -1;
32+
33+ if (atom_generation != serverGeneration) {
34+ prop_swap = 0;
35+ prop_invert = 0;
36+ }
37+
38+ switch (rotation & RR_Rotate_All) {
39+ case RR_Rotate_0:
40+ swap_axes = 1;
41+ invert[0] = 0;
42+ invert[1] = 0;
43+ break;
44+ case RR_Rotate_90:
45+ swap_axes = 0;
46+ invert[0] = 0;
47+ invert[1] = 1;
48+ break;
49+ case RR_Rotate_180:
50+ swap_axes = 1;
51+ invert[0] = 1;
52+ invert[1] = 1;
53+ break;
54+ case RR_Rotate_270:
55+ swap_axes = 0;
56+ invert[0] = 1;
57+ invert[1] = 0;
58+ break;
59+ }
60+
61+ if (!prop_swap)
62+ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
63+ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
64+ if (!prop_invert)
65+ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
66+ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
67+
68+ for (dev = inputInfo.devices; dev; dev = dev->next) {
69+ //local = dev->public.devicePrivate;
70+ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
71+ PropModeReplace, 1, &swap_axes, FALSE);
72+ if (ret != Success) {
73+ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
74+ continue;
75+ }
76+ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
77+ PropModeReplace, 2, invert, FALSE);
78+ if (ret != Success) {
79+ xf86Msg(X_ERROR, "Changing invert property failed!\n");
80+ continue;
81+ }
82+ }
83+}
84+
85+
86 /* end of xf86Xinput.c */
87diff -ur xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c git/xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c
88--- xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c 2011-04-28 09:25:00.000000000 +0200
89+++ git/xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c 2011-05-19 00:23:16.244383998 +0200
90@@ -389,6 +389,12 @@
91 if (didLock)
92 crtc->funcs->unlock (crtc);
93
94+ /*
95+ * Rotate Touchscreen
96+ */
97+ xf86InputRotationNotify(crtc->rotation);
98+
99+
100 return ret;
101 }
102
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch
deleted file mode 100644
index 3967c4c73..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.2/replace-pkgconfig-sdkdir-poking.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1configury forces pkg-config to poke for sdkdir variable which
2pkg-config happily returns but does not prepend sysroot to it
3since thats only done for includes and libs. This then gets -I
4prepended and added to CFLAGS. Guess what gcc cross gripes
5about including host includes in cross builds but does not bail
6out the build but it does not escape the wrath of our oe's
7QA checks and rightly so. We replace use of sdkdir with
8--cflags-only-I which returns the include paths correctly
9pointing inside sysroot and not at the host includes and plus
10includedir if you look inside the .pc file is assigned sdkdir
11anyway so we do not lose anything
12
13This m4 macro is included in other packages e.g. xf86-video-fbdev
14which dont build on hosts which have installation of
15xorg-xserver-dev because it gets this include poisoning
16
17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18
19Upstream-status: Pending
20
21Index: xorg-server-1.10.1/xorg-server.m4
22===================================================================
23--- xorg-server-1.10.1.orig/xorg-server.m4
24+++ xorg-server-1.10.1/xorg-server.m4
25@@ -31,7 +31,7 @@ dnl
26 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
27 AC_REQUIRE([PKG_PROG_PKG_CONFIG])
28 SAVE_CFLAGS="$CFLAGS"
29- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
30+ CFLAGS="$CFLAGS `$PKG_CONFIG --cflags-only-I xorg-server`"
31 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
32 #include "xorg-server.h"
33 #if !defined $1
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb
deleted file mode 100644
index 1d8836486..000000000
--- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1# Assign it here, since the hal->udev transition happens post 1.7 in angstrom
2DISTRO_XORG_CONFIG_MANAGER_angstrom = "udev"
3
4require xorg-xserver-common.inc
5LIC_FILES_CHKSUM = "file://COPYING;md5=74df27b6254cc88d2799b5f4f5949c00"
6
7DESCRIPTION = "the X.Org X server"
8DEPENDS += "mesa-dri pixman libpciaccess openssl dri2proto glproto font-util-native"
9PE = "2"
10PR = "${INC_PR}.1"
11
12SRC_URI += " \
13 file://50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch \
14 file://randr-support.patch \
15 file://hack-fbdev-ignore-return-mode.patch \
16 file://hack-assume-pixman-supports-overlapped-blt.patch \
17 file://replace-pkgconfig-sdkdir-poking.patch \
18 "
19SRC_URI[md5sum] = "c9ba50bd44ea70da51f13100336a5484"
20SRC_URI[sha256sum] = "65264f6640568b9db8d738aec1ddd036c3ae21b7ba05b98d006759d11a72792c"
21
22do_install_prepend() {
23 mkdir -p ${D}/${libdir}/X11/fonts
24}
25
26# The NVidia driver requires Xinerama support in the X server. Ion uses it.
27PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
28XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
29
30EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
31EXTRA_OECONF += " --enable-dri2 --disable-unit-tests --disable-docs --disable-devel-docs"
32
33export LDFLAGS += " -ldl "