summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-01 18:30:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:30:26 +0100
commit0c31f55bcfd6630d894dd2dda6ca483bea5de4ab (patch)
tree362ae6300bfa295709e24a4879639fb4c0fb5116 /meta-oe/recipes-graphics
parentb4524eb786472e69e28212a58a329a5e44e40547 (diff)
downloadmeta-openembedded-0c31f55bcfd6630d894dd2dda6ca483bea5de4ab.tar.gz
Make use of the new bb.utils.filter() function
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.10.bb14
-rw-r--r--meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb2
2 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
index 6e786f28c..e0f8128ed 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
@@ -34,25 +34,25 @@ do_compile() {
34 34
35 # Be sure to respect preferences (force to "no") 35 # Be sure to respect preferences (force to "no")
36 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} 36 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
37 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then 37 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
38 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile 38 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
39 fi 39 fi
40 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then 40 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
41 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile 41 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
42 fi 42 fi
43 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then 43 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then
44 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile 44 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
45 fi 45 fi
46 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then 46 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then
47 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile 47 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
48 fi 48 fi
49 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then 49 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then
50 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile 50 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
51 fi 51 fi
52 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then 52 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
53 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile 53 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
54 fi 54 fi
55 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'lirc', 'lirc', '', d)}" ]; then 55 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
56 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile 56 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
57 fi 57 fi
58 58
diff --git a/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
index de8038a2d..b4b16416b 100644
--- a/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
+++ b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "f6f4876a4dabe6a37c270c20bb9e141e38fb50e0bba200e1b9d0470e5e
16 16
17inherit allarch fontcache 17inherit allarch fontcache
18 18
19PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 19PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
20PACKAGECONFIG[x11] = "" 20PACKAGECONFIG[x11] = ""
21 21
22# Don't use font cache mecanism for console packages 22# Don't use font cache mecanism for console packages