summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-02 13:05:53 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:35 -0700
commitc26bc83d3ab5f21d47ebbd1b316032b877cae66c (patch)
tree8463930e37f352ae06deb6c2b601445f379dc799 /meta-oe/recipes-graphics
parent0a482225b882812f787eceac0b24ebaf8d374291 (diff)
downloadmeta-openembedded-c26bc83d3ab5f21d47ebbd1b316032b877cae66c.tar.gz
gphoto2: Upgrade to 2.5.28
License-Update: Copyright symbol added - Copyright 1991, 1999 Free Software Foundation, Inc. + Copyright © 1991, 1999 Free Software Foundation, Inc. Also upgrade libgphoto2 to 2.5.30 Fix build with musl while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/gphoto2/gphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch13
-rw-r--r--meta-oe/recipes-graphics/gphoto2/gphoto2/0001-gphoto2-Use-pthread_t-abstract-type-for-thead-IDs.patch39
-rw-r--r--meta-oe/recipes-graphics/gphoto2/gphoto2/0002-Look-for-popt-with-GP_CHECK_LIBRARY-function.patch32
-rw-r--r--meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.28.bb (renamed from meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.27.bb)6
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch31
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.30.bb (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.27.bb)8
6 files changed, 60 insertions, 69 deletions
diff --git a/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch b/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
index 7800fdd57..eaef8180e 100644
--- a/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
+++ b/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
@@ -9,18 +9,13 @@ This is done twice together with oe autotools.bbclass.
9 configure.ac | 1 - 9 configure.ac | 1 -
10 1 file changed, 1 deletion(-) 10 1 file changed, 1 deletion(-)
11 11
12diff --git a/configure.ac b/configure.ac
13index bb5b795..93fbaf2 100644
14--- a/configure.ac 12--- a/configure.ac
15+++ b/configure.ac 13+++ b/configure.ac
16@@ -64,7 +64,6 @@ GP_GETTEXT_HACK([],[Lutz Müller and others],[${MAIL_GPHOTO_TRANSLATION}]) 14@@ -46,7 +46,6 @@ dnl i18n support
15 dnl ---------------------------------------------------------------------------
16 GP_GETTEXT_HACK([],[Lutz Müller and others],[${MAIL_GPHOTO_TRANSLATION}])
17 ALL_LINGUAS="az cs da de en_GB es eu fi fr hu id is it ja nl pa pl pt_BR ro ru rw sk sr sv uk vi zh_CN zh_TW" 17 ALL_LINGUAS="az cs da de en_GB es eu fi fr hu id is it ja nl pa pl pt_BR ro ru rw sk sr sv uk vi zh_CN zh_TW"
18-AM_PO_SUBDIRS()
18 AM_GNU_GETTEXT_VERSION([0.14.1]) 19 AM_GNU_GETTEXT_VERSION([0.14.1])
19 AM_GNU_GETTEXT([external]) 20 AM_GNU_GETTEXT([external])
20-AM_PO_SUBDIRS()
21 AM_ICONV() 21 AM_ICONV()
22 GP_GETTEXT_FLAGS()
23
24--
251.9.1
26
diff --git a/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-gphoto2-Use-pthread_t-abstract-type-for-thead-IDs.patch b/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-gphoto2-Use-pthread_t-abstract-type-for-thead-IDs.patch
new file mode 100644
index 000000000..a27c02cef
--- /dev/null
+++ b/meta-oe/recipes-graphics/gphoto2/gphoto2/0001-gphoto2-Use-pthread_t-abstract-type-for-thead-IDs.patch
@@ -0,0 +1,39 @@
1From 23c67e93e51f700d0aeecfc08277e39f51201fc3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Sep 2022 12:59:46 -0700
4Subject: [PATCH] gphoto2: Use pthread_t abstract type for thead IDs
5
6This is not a plain old datatype in every libc, e.g. with musl this
7would fail in type conversion
8
9Upstream-Status: Submitted [https://github.com/gphoto/gphoto2/pull/535]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 gphoto2/main.c | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/gphoto2/main.c b/gphoto2/main.c
16index 2bf5964..9a6b05d 100644
17--- a/gphoto2/main.c
18+++ b/gphoto2/main.c
19@@ -1198,7 +1198,7 @@ thread_func (void *data)
20 pthread_cleanup_pop (1);
21 }
22
23-static unsigned int
24+static pthread_t
25 start_timeout_func (Camera *camera, unsigned int timeout,
26 CameraTimeoutFunc func, void __unused__ *data)
27 {
28@@ -1219,7 +1219,7 @@ start_timeout_func (Camera *camera, unsigned int timeout,
29 }
30
31 static void
32-stop_timeout_func (Camera __unused__ *camera, unsigned int id,
33+stop_timeout_func (Camera __unused__ *camera, pthread_t id,
34 void __unused__ *data)
35 {
36 pthread_t tid = id;
37--
382.37.3
39
diff --git a/meta-oe/recipes-graphics/gphoto2/gphoto2/0002-Look-for-popt-with-GP_CHECK_LIBRARY-function.patch b/meta-oe/recipes-graphics/gphoto2/gphoto2/0002-Look-for-popt-with-GP_CHECK_LIBRARY-function.patch
deleted file mode 100644
index e6c7dd667..000000000
--- a/meta-oe/recipes-graphics/gphoto2/gphoto2/0002-Look-for-popt-with-GP_CHECK_LIBRARY-function.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 884d4c9bbd2dc147d614a5fabc25dbea7a71cd48 Mon Sep 17 00:00:00 2001
2From: Andreas Baak <andreas.baak@gmail.com>
3Date: Sun, 12 Jul 2015 02:13:58 -0700
4Subject: [PATCH] Look for popt with GP_CHECK_LIBRARY function
5
6The previously used proprietary function GP_CHECK_POPT
7defined in /.m4m/gp-check-opt.m4 is not ready for cross
8compilation since it looks for the library and headers
9in the host system. Yocto reports the following error:
10"QA Issue: gphoto2: The compile log indicates that host
11include and/or library paths were used."
12Using the GP_CHECK_LIBRARY function fixes this problem
13---
14 configure.ac | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/configure.ac b/configure.ac
18index 93fbaf2..6d661f0 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -285,7 +285,7 @@ GP_CONFIG_MSG([Text preview support],[$aa_msg])
22 dnl ---------------------------------------------------------------------------
23 dnl popt.h: Simplifies handling of command-line options enormously.
24 dnl ---------------------------------------------------------------------------
25-GP_CHECK_POPT([mandatory])
26+GP_CHECK_LIBRARY([POPT], [popt], [], [popt.h], [], [], [mandatory])
27
28
29 dnl ---------------------------------------------------------------------------
30--
311.9.1
32
diff --git a/meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.27.bb b/meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.28.bb
index 84ff67723..fe3394047 100644
--- a/meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.27.bb
+++ b/meta-oe/recipes-graphics/gphoto2/gphoto2_2.5.28.bb
@@ -8,11 +8,9 @@ RDEPENDS:gphoto2 = "libgphoto2"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/gphoto2-${PV}.tar.bz2;name=gphoto2 \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/gphoto2-${PV}.tar.bz2;name=gphoto2 \
10 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ 10 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \
11 file://0002-Look-for-popt-with-GP_CHECK_LIBRARY-function.patch \ 11 file://0001-gphoto2-Use-pthread_t-abstract-type-for-thead-IDs.patch \
12" 12"
13 13SRC_URI[gphoto2.sha256sum] = "2a648dcdf12da19e208255df4ebed3e7d2a02f905be4165f2443c984cf887375"
14SRC_URI[gphoto2.md5sum] = "92d39b383c0e0354b4d3af1af7b8b416"
15SRC_URI[gphoto2.sha256sum] = "30054e93a1bb59f501aabd5018713177ea04ce0cb28935319bd6ca80061e8d38"
16 14
17inherit autotools pkgconfig gettext 15inherit autotools pkgconfig gettext
18 16
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
index 8093676ad..f93650f86 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
@@ -19,30 +19,23 @@ Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
19 libgphoto2_port/configure.ac | 1 - 19 libgphoto2_port/configure.ac | 1 -
20 2 files changed, 0 insertions(+), 2 deletions(-) 20 2 files changed, 0 insertions(+), 2 deletions(-)
21 21
22diff --git a/configure.ac b/configure.ac
23index 2f8e1b8..2e90acf 100644
24--- a/configure.ac 22--- a/configure.ac
25+++ b/configure.ac 23+++ b/configure.ac
26@@ -209,7 +209,6 @@ ALL_LINGUAS="cs da de es eu fr hu it ja nl pl ru sv uk vi zh_CN" 24@@ -282,7 +282,6 @@ dnl ------------------------------------
27 GP_GETTEXT_HACK([${PACKAGE}-${LIBGPHOTO2_CURRENT_MIN}],[The gPhoto Team],[${MAIL_GPHOTO_TRANSLATION}]) 25 GP_GETTEXT_SETUP([GETTEXT_PACKAGE_LIBGPHOTO2],
28 AM_GNU_GETTEXT_VERSION([0.14.1]) 26 [${PACKAGE}-${LIBGPHOTO2_CURRENT_MIN}],
29 AM_GNU_GETTEXT([external]) 27 [po])
30-AM_PO_SUBDIRS() 28-AM_PO_SUBDIRS()
29 AM_GNU_GETTEXT_VERSION([0.19.1])
30 AM_GNU_GETTEXT([external])
31 AM_ICONV() 31 AM_ICONV()
32 GP_GETTEXT_FLAGS()
33
34diff --git a/libgphoto2_port/configure.ac b/libgphoto2_port/configure.ac
35index 0b66d58..df47357 100644
36--- a/libgphoto2_port/configure.ac 32--- a/libgphoto2_port/configure.ac
37+++ b/libgphoto2_port/configure.ac 33+++ b/libgphoto2_port/configure.ac
38@@ -124,7 +124,6 @@ GP_GETTEXT_HACK([${PACKAGE}-${LIBGPHOTO2_PORT_CURRENT_MIN}],[Lutz Mueller and ot 34@@ -122,7 +122,6 @@ dnl ------------------------------------
39 ALL_LINGUAS="cs da de es eu fi fr it ja nl pl pt_BR ru sk sr sv uk vi zh_CN zh_TW" 35 GP_GETTEXT_SETUP([GETTEXT_PACKAGE_LIBGPHOTO2_PORT],
40 AM_GNU_GETTEXT_VERSION([0.14.1]) 36 [${PACKAGE}-${LIBGPHOTO2_PORT_CURRENT_MIN}],
41 AM_GNU_GETTEXT([external]) 37 [po])
42-AM_PO_SUBDIRS() 38-AM_PO_SUBDIRS()
39 AM_GNU_GETTEXT_VERSION([0.19.1])
40 AM_GNU_GETTEXT([external])
43 AM_ICONV() 41 AM_ICONV()
44 GP_GETTEXT_FLAGS()
45
46--
471.7.4.4
48
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.27.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.30.bb
index 41600be2e..0f2800a95 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.27.bb
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.30.bb
@@ -1,7 +1,7 @@
1SUMMARY = "libgphoto2 allows you to access digital cameras" 1SUMMARY = "libgphoto2 allows you to access digital cameras"
2SECTION = "libs" 2SECTION = "libs"
3LICENSE = "LGPL-2.1-only" 3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1" 4LIC_FILES_CHKSUM = "file://COPYING;md5=477378d78dfeeaa93826ee4ec7c643fb"
5 5
6DEPENDS = "libtool jpeg virtual/libusb0 libexif zlib libxml2" 6DEPENDS = "libtool jpeg virtual/libusb0 libexif zlib libxml2"
7 7
@@ -13,9 +13,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2
13 file://40-libgphoto2.rules \ 13 file://40-libgphoto2.rules \
14 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ 14 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \
15" 15"
16 16SRC_URI[libgphoto2.sha256sum] = "ee61a1dac6ad5cf711d114e06b90a6d431961a6e7ec59f4b757a7cd77b1c0fb4"
17SRC_URI[libgphoto2.md5sum] = "83a2f96dade72e95dffb8e5fa9628d7e"
18SRC_URI[libgphoto2.sha256sum] = "f8b85478c44948a0b0b52c4d4dfda2de1d7bcb7b262c76bd1ae306d9c63240d7"
19 17
20inherit autotools pkgconfig gettext lib_package 18inherit autotools pkgconfig gettext lib_package
21 19
@@ -57,4 +55,4 @@ FILES:libgphotoport = "${libdir}/libgphoto2_port.so.*"
57FILES:${PN} += "${nonarch_base_libdir}/udev/*" 55FILES:${PN} += "${nonarch_base_libdir}/udev/*"
58FILES:${PN}-dbg += "${libdir}/*/*/.debug" 56FILES:${PN}-dbg += "${libdir}/*/*/.debug"
59FILES:${PN}-dev += "${libdir}/*/*/*.la" 57FILES:${PN}-dev += "${libdir}/*/*/*.la"
60FILES:${PN}-doc += "${datadir}/libgphoto2_port/0.12.0/vcamera/README.txt" 58FILES:${PN}-doc += "${datadir}/libgphoto2_port/0.12.?/vcamera/README.txt"