diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-05-29 18:27:43 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-31 07:48:02 -0700 |
commit | b41e80c15e7161bef2723bbe898ea7b961bea170 (patch) | |
tree | 0c9c2af29d5c92418278c9777d42f038e2709f26 /meta-oe/recipes-graphics | |
parent | 5aac941441b1e72558dac40ebb40bc8958a78c29 (diff) | |
download | meta-openembedded-b41e80c15e7161bef2723bbe898ea7b961bea170.tar.gz |
gtkwave: set REQUIRED_DISTRO_FEATURES only to wayland
* after the migration to gtk3 in:
https://git.openembedded.org/meta-openembedded/commit/?id=8221db74e300619d002e2b385d12a5fe13e8999a
this was now failing with:
| In file included from ../../gtkwave-gtk3-3.3.109/src/debug.h:17,
| from ../../gtkwave-gtk3-3.3.109/src/vlist.h:18,
| from ../../gtkwave-gtk3-3.3.109/src/analyzer.h:18,
| from ../../gtkwave-gtk3-3.3.109/src/symbol.h:20,
| from ../../gtkwave-gtk3-3.3.109/src/vcd.h:32,
| from ../../gtkwave-gtk3-3.3.109/src/ae2.h:16,
| from ../../gtkwave-gtk3-3.3.109/src/globals.h:27,
| from ../../gtkwave-gtk3-3.3.109/src/timeentry.c:11:
| ../../gtkwave-gtk3-3.3.109/src/gtk23compat.h:12:10: fatal error: gdk/gdkwayland.h: No such file or directory
| 12 | #include <gdk/gdkwayland.h>
| | ^~~~~~~~~~~~~~~~~~
for distributions without wayland in DISTRO_FEATURES.
* because https://github.com/gtkwave/gtkwave/blob/f9d82a82aa3ddc30ca47984278371f62c9a3bd81/gtkwave3-gtk3/src/gtk23compat.h#L10
explicitly includes gdk/gdkwayland.h for gtk-3.22.26 and newer (oe-core currently has 3.24.29)
* restrict REQUIRED_DISTRO_FEATURES to wayland _and_ x11
(instead of either of them through ANY_OF_DISTRO_FEATURES and GTK3DISTROFEATURES)
because wayland is needed for gtk3 to provide this gdkwayland.h
and x11 is needed by tk dependency
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.109.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.109.bb b/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.109.bb index 2b572f7e2..e1cb3d4a5 100644 --- a/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.109.bb +++ b/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.109.bb | |||
@@ -23,9 +23,13 @@ DEPENDS = " \ | |||
23 | 23 | ||
24 | inherit pkgconfig autotools gettext texinfo mime mime-xdg | 24 | inherit pkgconfig autotools gettext texinfo mime mime-xdg |
25 | 25 | ||
26 | # depends on gtk+3 which has this restriction | ||
27 | inherit features_check | 26 | inherit features_check |
28 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | 27 | # depends on gtk+3 which has this restriction |
28 | # ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | ||
29 | # but https://github.com/gtkwave/gtkwave/blob/f9d82a82aa3ddc30ca47984278371f62c9a3bd81/gtkwave3-gtk3/src/gtk23compat.h#L10 | ||
30 | # explicitly includes gdk/gdkwayland.h for gtk-3.22.26 and newer (oe-core currently has 3.24.29) | ||
31 | # and it needs x11 as well for tk dependency (so it happends to be both GTK3DISTROFEATURES instead of either of them) | ||
32 | REQUIRED_DISTRO_FEATURES = "wayland x11" | ||
29 | 33 | ||
30 | EXTRA_OECONF = " \ | 34 | EXTRA_OECONF = " \ |
31 | --enable-gtk3 \ | 35 | --enable-gtk3 \ |