diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-07-02 23:50:37 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-07-02 23:57:16 -0700 |
commit | 9363162b5147e2ecc21796047aefc7a10e0d999a (patch) | |
tree | c1e4b350038670bc96d6d8b816dd53ac7952dbe5 /meta-oe/recipes-graphics | |
parent | 6da3cec9b3b98068f28467971fdde9f26805a652 (diff) | |
download | meta-openembedded-9363162b5147e2ecc21796047aefc7a10e0d999a.tar.gz |
renderdoc: Fix build with clang fortify and glibc 2.40
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/renderdoc/renderdoc/0001-jpeg-compressor-Reorder-stdio.h-include-location.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/renderdoc/renderdoc_1.33.bb | 1 |
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc/0001-jpeg-compressor-Reorder-stdio.h-include-location.patch b/meta-oe/recipes-graphics/renderdoc/renderdoc/0001-jpeg-compressor-Reorder-stdio.h-include-location.patch new file mode 100644 index 000000000..1c714f84d --- /dev/null +++ b/meta-oe/recipes-graphics/renderdoc/renderdoc/0001-jpeg-compressor-Reorder-stdio.h-include-location.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 4eb26927eebebfc4df8789ba69f60f3c28b8ba33 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 2 Jul 2024 23:36:23 -0700 | ||
4 | Subject: [PATCH] jpeg-compressor: Reorder stdio.h include location | ||
5 | |||
6 | Current, location ends up with compile errors with clang and glibc 2.40 | ||
7 | fortified headers | ||
8 | |||
9 | | /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/renderdoc/1.33/recipe-sysroot/usr/include/bits/stdio2.h:128:13: error: use of undeclared identifier '__builtin___vfprintf_chk'; did you mean '__builtin___sprintf_chk'? | ||
10 | | 128 | int __r = __builtin___vfprintf_chk (__stream, __USE_FORTIFY_LEVEL - 1, | ||
11 | | | ^ | ||
12 | | /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/renderdoc/1.33/recipe-sysroot/usr/include/bits/stdio2.h:128:39: error: cannot initialize a parameter of type 'char *' with an lvalue of type 'FILE *const __restrict' (aka 'jpge::_IO_FILE *const __restrict') | ||
13 | | 128 | int __r = __builtin___vfprintf_chk (__stream, __USE_FORTIFY_LEVEL - 1, | ||
14 | | | ^~~~~~~~ | ||
15 | |||
16 | This re-ordering ensures that fortified function prototypes are used correctly. | ||
17 | |||
18 | Upstream-Status: Submitted [https://github.com/baldurk/renderdoc/pull/3369] | ||
19 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
20 | --- | ||
21 | renderdoc/3rdparty/jpeg-compressor/jpge.cpp | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/renderdoc/3rdparty/jpeg-compressor/jpge.cpp b/renderdoc/3rdparty/jpeg-compressor/jpge.cpp | ||
25 | index 74d9d1006..d58e41664 100644 | ||
26 | --- a/renderdoc/3rdparty/jpeg-compressor/jpge.cpp | ||
27 | +++ b/renderdoc/3rdparty/jpeg-compressor/jpge.cpp | ||
28 | @@ -10,6 +10,7 @@ | ||
29 | |||
30 | #include "jpge.h" | ||
31 | |||
32 | +#include <stdio.h> | ||
33 | #include <stdlib.h> | ||
34 | #include <string.h> | ||
35 | |||
36 | @@ -897,7 +898,6 @@ bool jpeg_encoder::process_scanline(const void* pScanline) | ||
37 | } | ||
38 | |||
39 | // Higher level wrappers/examples (optional). | ||
40 | -#include <stdio.h> | ||
41 | |||
42 | class cfile_stream : public output_stream | ||
43 | { | ||
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.33.bb b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.33.bb index e6b59cfae..833845b5a 100644 --- a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.33.bb +++ b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.33.bb | |||
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5536c2b72eeed14bafaf4d2a6c032b87" | |||
7 | SRCREV = "cae289323847ce0a84a0deca4958183567eee17e" | 7 | SRCREV = "cae289323847ce0a84a0deca4958183567eee17e" |
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | git://github.com/baldurk/${BPN}.git;protocol=https;branch=v1.x \ | 9 | git://github.com/baldurk/${BPN}.git;protocol=https;branch=v1.x \ |
10 | file://0001-jpeg-compressor-Reorder-stdio.h-include-location.patch \ | ||
10 | " | 11 | " |
11 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
12 | 13 | ||