summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2016-05-08 15:08:12 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-12 11:53:30 -0400
commit00ec8bc10df539ecedc3beb2dde28a8e4665cad8 (patch)
tree1a863d84a5bab853a9179d494ada1468e865a2f9 /meta-oe/recipes-graphics
parent273d79740b69deb63672705848613de64acfeaf2 (diff)
downloadmeta-openembedded-00ec8bc10df539ecedc3beb2dde28a8e4665cad8.tar.gz
autotools-bootstrap: make bootstrap package specific.
The theory behind this bbclass was reasonable, with the primary goal being to avoid multiple downloads of gnulib, but it neglected the fact that packages would be shipping a specific version of the ./bootstrap which will support some flags but maybe not all the latest ones from the latest gnulib/build-aux/bootstrap file. I attempted to simply update the two pkgs to use the latest copy of bootstrap from gnulib but this of course triggers the descent into autoconf hell that we all know and love. Rather than futzing with the packages configure.ac and deviating from what the pkg maintainers intended and tested, we can just let the packages have independent calls to ./bootstrap with whatever flags are needed. The goal of this commit is to move the prepend out to the packages and then delete the class without any real functional change ; i.e. a purely mechanical change. Then we can adjust each package to ensure it will still build with a modern host, in an independent fashion, while keeping the main advantage of not fetching gnulib two extra times for netcf and fontforge. Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
index b50202d0a..53899f13c 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = " \
9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash" 9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash"
10DEPENDS_append_class-target = " libxi" 10DEPENDS_append_class-target = " libxi"
11 11
12inherit autotools-bootstrap pkgconfig pythonnative distro_features_check 12inherit autotools pkgconfig pythonnative distro_features_check
13 13
14REQUIRED_DISTRO_FEATURES_append_class-target = " x11" 14REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
15 15
@@ -24,8 +24,24 @@ do_configure_prepend() {
24 # uthash sources are expected in uthash/src 24 # uthash sources are expected in uthash/src
25 currdir=`pwd` 25 currdir=`pwd`
26 cd ${S} 26 cd ${S}
27
27 mkdir -p uthash/src 28 mkdir -p uthash/src
28 cp ${STAGING_INCDIR}/ut*.h uthash/src 29 cp ${STAGING_INCDIR}/ut*.h uthash/src
30
31 # avoid bootstrap cloning gnulib on every configure
32 cat >.gitmodules <<EOF
33[submodule "gnulib"]
34 path = gnulib
35 url = git://git.sv.gnu.org/gnulib
36EOF
37 cp -rf ${STAGING_DATADIR}/gnulib ${S}
38
39 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
40 # | bootstrap: running: libtoolize --quiet
41 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
42 # | ...
43 ./bootstrap --force
44
29 cd $currdir 45 cd $currdir
30} 46}
31 47