diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-27 19:08:11 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:26 +0200 |
commit | 15bb5e03a0bae987cd56cecfb6a79e68812ded98 (patch) | |
tree | 05f2efbaca57169c284e77a864f4421b8e598e20 /meta-oe/recipes-graphics | |
parent | 2bd65aacdfa2634f20dfbc7cacf6e418f8cc2ae7 (diff) | |
download | meta-openembedded-15bb5e03a0bae987cd56cecfb6a79e68812ded98.tar.gz |
gtkperf: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
3 files changed, 80 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/gtkperf/gtkperf/0001-Include-stdlib.h-for-exit-API.patch b/meta-oe/recipes-graphics/gtkperf/gtkperf/0001-Include-stdlib.h-for-exit-API.patch new file mode 100644 index 000000000..d529ddd23 --- /dev/null +++ b/meta-oe/recipes-graphics/gtkperf/gtkperf/0001-Include-stdlib.h-for-exit-API.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From f8ac48abded02353918b02db38629988bd111c46 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 27 Jun 2017 08:19:44 -0700 | ||
4 | Subject: [PATCH 1/2] Include stdlib.h for exit() API | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Fixes | ||
10 | main.c:81: warning: incompatible implicit declaration of built-in function ‘exit’ | ||
11 | |||
12 | Patch from Debian | ||
13 | http://sources.debian.net/src/gtkperf/0.40%2Bds-2/debian/patches/01-include_stdlib.patch/ | ||
14 | |||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | src/main.c | 1 + | ||
18 | 1 file changed, 1 insertion(+) | ||
19 | |||
20 | diff --git a/src/main.c b/src/main.c | ||
21 | index 888eb36..c226799 100644 | ||
22 | --- a/src/main.c | ||
23 | +++ b/src/main.c | ||
24 | @@ -11,6 +11,7 @@ | ||
25 | #endif | ||
26 | |||
27 | #include <getopt.h> | ||
28 | +#include <stdlib.h> | ||
29 | |||
30 | #include "interface.h" | ||
31 | #include "support.h" | ||
32 | -- | ||
33 | 2.13.2 | ||
34 | |||
diff --git a/meta-oe/recipes-graphics/gtkperf/gtkperf/0002-timing.c-Fix-format-security-errors.patch b/meta-oe/recipes-graphics/gtkperf/gtkperf/0002-timing.c-Fix-format-security-errors.patch new file mode 100644 index 000000000..0548040af --- /dev/null +++ b/meta-oe/recipes-graphics/gtkperf/gtkperf/0002-timing.c-Fix-format-security-errors.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 47974b8473c5b928f6742caee466f5c2d4d2e9eb Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 27 Jun 2017 08:22:26 -0700 | ||
4 | Subject: [PATCH 2/2] timing.c: Fix format-security errors | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/timing.c | 6 +++--- | ||
9 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
10 | |||
11 | diff --git a/src/timing.c b/src/timing.c | ||
12 | index 0b8f0eb..c0668c9 100644 | ||
13 | --- a/src/timing.c | ||
14 | +++ b/src/timing.c | ||
15 | @@ -97,7 +97,7 @@ add_test_info_time (AppData * appdata) | ||
16 | gtk_text_buffer_insert (appdata->textview_info_buffer, &iter, | ||
17 | timestring, -1); | ||
18 | |||
19 | - g_printf (timestring); | ||
20 | + g_printf ("%s", timestring); | ||
21 | |||
22 | } | ||
23 | |||
24 | @@ -129,7 +129,7 @@ add_test_info_end (AppData * appdata) | ||
25 | gtk_statusbar_push (GTK_STATUSBAR (appdata->statusbar_main), 0, | ||
26 | " Test Finished"); | ||
27 | |||
28 | - g_printf (timestring); | ||
29 | + g_printf ("%s", timestring); | ||
30 | |||
31 | } | ||
32 | |||
33 | @@ -154,5 +154,5 @@ add_test_info_start (AppData * appdata) | ||
34 | gtk_statusbar_push (GTK_STATUSBAR (appdata->statusbar_main), 0, | ||
35 | " Running tests..."); | ||
36 | |||
37 | - g_printf (timestring); | ||
38 | + g_printf ("%s", timestring); | ||
39 | } | ||
40 | -- | ||
41 | 2.13.2 | ||
42 | |||
diff --git a/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb b/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb index e404a7a51..2db91904f 100644 --- a/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb +++ b/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb | |||
@@ -4,7 +4,10 @@ LICENSE = "LGPLv2.1" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
5 | 5 | ||
6 | SRC_URI = "http://prdownloads.sourceforge.net/${BPN}/${BPN}_${PV}.tar.gz \ | 6 | SRC_URI = "http://prdownloads.sourceforge.net/${BPN}/${BPN}_${PV}.tar.gz \ |
7 | file://Makevars" | 7 | file://Makevars \ |
8 | file://0001-Include-stdlib.h-for-exit-API.patch \ | ||
9 | file://0002-timing.c-Fix-format-security-errors.patch \ | ||
10 | " | ||
8 | 11 | ||
9 | SRC_URI[md5sum] = "4331dde4bb83865e15482885fcb0cc53" | 12 | SRC_URI[md5sum] = "4331dde4bb83865e15482885fcb0cc53" |
10 | SRC_URI[sha256sum] = "9704344e732038eecbd007dd996a56293a6b027b5b76f3f036273a3fae1ab27b" | 13 | SRC_URI[sha256sum] = "9704344e732038eecbd007dd996a56293a6b027b5b76f3f036273a3fae1ab27b" |