summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-14 12:34:01 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-12-04 11:25:35 +0100
commitde7c5162f83bc4e9eb6ecb9d8e8717049bb8df00 (patch)
treea8645a192f9f383a2bbe96061684ade00c6334d3 /meta-oe/recipes-graphics
parent80498a8cc8a96f269a97f36d71b1f8065cd5ece8 (diff)
downloadmeta-openembedded-de7c5162f83bc4e9eb6ecb9d8e8717049bb8df00.tar.gz
devilspie2: move to meta-gnome (libwnck is there)
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb30
-rw-r--r--meta-oe/recipes-graphics/devilspie/files/default.lua46
-rw-r--r--meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop5
3 files changed, 0 insertions, 81 deletions
diff --git a/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb b/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb
deleted file mode 100644
index 05311fd54..000000000
--- a/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "Devilspie2 is a window matching utility, allowing the user to perform scripted actions on windows as they are created"
2HOMEPAGE = "http://www.gusnan.se/devilspie2"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=00aefaa50aad75c21367df66102d542c \
5 file://GPL3.txt;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = "gtk+ glib-2.0 libwnck lua5.1 virtual/libx11"
8
9SRC_URI = " \
10 http://www.gusnan.se/devilspie2/download/devilspie2_${PV}-src.tar.gz \
11 file://default.lua \
12 file://devilspie2.desktop \
13"
14SRC_URI[md5sum] = "90b354662659e2922bd051fdde3b0971"
15SRC_URI[sha256sum] = "9c94fa13ed8c0bf6914fdda513e21a4bd527821b97a53d8004168a8d465a646a"
16
17inherit pkgconfig
18
19do_compile() {
20 export GTK2=1
21 oe_runmake CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS=" -ldl -lm ${LDFLAGS}"
22}
23
24do_install() {
25 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" install
26 install -d ${D}/${sysconfdir}/devilspie2
27 install -m 644 ${WORKDIR}/default.lua ${D}/${sysconfdir}/devilspie2
28 install -d ${D}/${sysconfdir}/xdg/autostart
29 install -m 644 ${WORKDIR}/devilspie2.desktop ${D}/${sysconfdir}/xdg/autostart
30}
diff --git a/meta-oe/recipes-graphics/devilspie/files/default.lua b/meta-oe/recipes-graphics/devilspie/files/default.lua
deleted file mode 100644
index 22a17fe98..000000000
--- a/meta-oe/recipes-graphics/devilspie/files/default.lua
+++ /dev/null
@@ -1,46 +0,0 @@
1-- Copyright (c) 2012 Andreas Müller <schnitzeltony@googlemail.com>
2--
3-- this is an example
4-- * undecorating all windows opened maximized
5-- * maximizing and undecorating all appplication's windows in apps_list
6-- for further information see
7-- http://www.gusnan.se/devilspie2/manual.php
8
9wnd_type = get_window_type()
10
11if(wnd_type == "WINDOW_TYPE_NORMAL") then
12
13 -- add only applications you want maximized+undecorated and
14 -- which don't keep maximized state
15 apps_list =
16 {
17 "Terminal",
18 "ristretto",
19 "xarchiver",
20 }
21
22 app_name = get_application_name()
23
24 -- to have some informational output, start devilspie2 with --debug
25 -- option and uncomment the following lines:
26
27 --debug_print ("Window Name: " .. get_window_name())
28 --debug_print ("Application name: " .. app_name)
29 --debug_print ("window-type: " .. wnd_type)
30
31 -- undecorate all windows starting maximized
32 if (get_window_is_maximized()) then
33 undecorate_window()
34
35 -- maximize/undecorate all windows in apps_list
36 -- (unfortunately for some also their settings)
37 else
38 for line, str in ipairs(apps_list) do
39 if (string.find(app_name, str)) then
40 maximize()
41 undecorate_window()
42 break
43 end
44 end
45 end
46end
diff --git a/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop b/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop
deleted file mode 100644
index e34e881cd..000000000
--- a/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop
+++ /dev/null
@@ -1,5 +0,0 @@
1[Desktop Entry]
2Type=Application
3Name=Devilspie2
4Exec=devilspie2 -f /etc/devilspie2
5