summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-02-28 17:51:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-11 14:58:50 +0100
commitf426f5d7b5393c40eb9b5bbc465e5be219ccdb80 (patch)
treec59fdb73a90396848af342ca1f42cba6b326274f /meta-oe/recipes-graphics
parent50f7a7c96604e74b12bea7f9269dfa9064f358f1 (diff)
downloadmeta-openembedded-f426f5d7b5393c40eb9b5bbc465e5be219ccdb80.tar.gz
fim: add new recipe for version 0.4-rc1
FIM (Fbi IMproved) is a framebuffer (customizable and scriptable) image viewer. It is based on Fbi image viewer. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fim/fim_0.4-rc1.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fim/fim_0.4-rc1.bb b/meta-oe/recipes-graphics/fim/fim_0.4-rc1.bb
new file mode 100644
index 000000000..01aa87c85
--- /dev/null
+++ b/meta-oe/recipes-graphics/fim/fim_0.4-rc1.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Framebuffer (scriptable) image viewer"
2DESCRIPTION = "FIM (Fbi IMproved) aims to be a highly customizable and scriptable \
3 image viewer targeted at users who are comfortable with software \
4 like the Vim text editor or the Mutt mail user agent."
5SECTION = "utils"
6HOMEPAGE = "http://www.autistici.org/dezperado/fim/"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fa01bff138cc98a62b8840a157951c88"
10
11# flex with provide /usr/include/FlexLexer.h
12DEPENDS = "flex-native bison-native flex"
13
14SRC_URI = "http://download.savannah.nongnu.org/releases/fbi-improved/${BPN}-${PV}.tar.gz"
15SRC_URI[md5sum] = "d7362dde5541c2b6439c35c6e2bd5046"
16SRC_URI[sha256sum] = "3f6bf2de2952b9adcbeb3db12c2a979e999a81dd1e314a03bc58e24f1ea9f686"
17
18PARALLEL_MAKE = ""
19
20inherit autotools
21
22# Don't use provided regex.c
23EXTRA_OECONF = "fim_cv_regex=no fim_cv_regex_broken=no \
24 --enable-framebuffer \
25 --disable-djvu \
26 --disable-ps \
27 --disable-xcftopnm \
28 --disable-convert \
29 --disable-inkscape \
30 --disable-xfig \
31 --disable-dia \
32 --disable-aa \
33 --disable-sdl \
34 --enable-read-dirs \
35 --enable-recursive-dirs \
36 --enable-custom-status-bar \
37"
38
39# Note: imlib2 is located in meta-efl layer.
40PACKAGECONFIG ??= "jpeg rl"
41PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
42PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
43PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
44PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
45PACKAGECONFIG[pdf] = "--enable-poppler,--disable-poppler,poppler"
46PACKAGECONFIG[magick] = "--enable-graphicsmagick,--disable-graphicsmagick,imagemagick"
47PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
48PACKAGECONFIG[rl] = "--enable-readline,--disable-readline,readline"