diff options
author | Ross Burton <ross.burton@intel.com> | 2013-02-13 15:13:49 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-16 05:55:00 +0100 |
commit | e83429283bda966d5d2a98333cde2c262564d9aa (patch) | |
tree | 42503b14af16411ce161fe64a8dcf10b048abb28 /meta-oe/recipes-graphics | |
parent | 770b14191143fd89fa18daa4048af1f618debdee (diff) | |
download | meta-openembedded-e83429283bda966d5d2a98333cde2c262564d9aa.tar.gz |
waffle: new package, a GL deferred resolution library.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/waffle/files/cflags.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb | 34 |
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/waffle/files/cflags.patch b/meta-oe/recipes-graphics/waffle/files/cflags.patch new file mode 100644 index 000000000..381975674 --- /dev/null +++ b/meta-oe/recipes-graphics/waffle/files/cflags.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Upstream-Status: Backport | ||
2 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
3 | |||
4 | From 2abec1cb3c17fa5ec8d945d79acd74a39c38293a Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@intel.com> | ||
6 | Date: Wed, 12 Dec 2012 12:57:18 +0000 | ||
7 | Subject: cmake: respect existing CMAKE_C_FLAGS | ||
8 | |||
9 | When cross-compiling it's not unusual to need specific arguments passed to gcc | ||
10 | such as --sysroot. Ensure that these are passed on from the toolchain file by | ||
11 | appending to CMAKE_C_FLAGS instead of overwriting it. | ||
12 | |||
13 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
14 | |||
15 | Index: waffle-1.2.2/CMakeLists.txt | ||
16 | =================================================================== | ||
17 | --- waffle-1.2.2.orig/CMakeLists.txt 2012-11-28 00:43:40.000000000 +0000 | ||
18 | +++ waffle-1.2.2/CMakeLists.txt 2013-02-13 11:34:02.476188233 +0000 | ||
19 | @@ -212,7 +212,7 @@ | ||
20 | # ------------------------------------------------------------------------------ | ||
21 | |||
22 | # FIXME: Only enable c99 if compiler supports it. | ||
23 | -set(CMAKE_C_FLAGS "--std=c99 -Wall -Werror=implicit-function-declaration") | ||
24 | +set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --std=c99 -Wall -Werror=implicit-function-declaration") | ||
25 | if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux") | ||
26 | # On MacOS, the SSE2 headers trigger this error. | ||
27 | set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror=missing-prototypes") | ||
diff --git a/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb b/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb new file mode 100644 index 000000000..4f80191fd --- /dev/null +++ b/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "cross-platform C library to defer selection of GL API and of window system" | ||
2 | LICENSE = "BSD-2-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \ | ||
4 | file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf" | ||
5 | |||
6 | SRC_URI = "http://people.freedesktop.org/~chadversary/waffle/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \ | ||
7 | file://cflags.patch" | ||
8 | |||
9 | SRC_URI[md5sum] = "fdd07cea7709422fbf72418ee63a285d" | ||
10 | SRC_URI[sha256sum] = "7e342c859b58d4e051b347ef3d7740ed2f3b6c506b93daec272724afe7dd1311" | ||
11 | |||
12 | inherit cmake | ||
13 | |||
14 | # This should be overridden per-machine to reflect the capabilities of the GL | ||
15 | # stack. | ||
16 | PACKAGECONFIG ??= "glx" | ||
17 | |||
18 | # I say virtual/libgl, actually wants gl.pc | ||
19 | PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,,virtual/libgl libx11" | ||
20 | |||
21 | # I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland | ||
22 | # DISTRO_FEATURE. | ||
23 | PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,,virtual/libgl wayland" | ||
24 | |||
25 | # I say virtual/libgl, actually wants gbm.pc egl.pc | ||
26 | PACKAGECONFIG[gbm] = "-Dwaffle_has_wayland=1,,virtual/libgl udev" | ||
27 | |||
28 | # I say virtual/libgl, actually wants egl.pc | ||
29 | PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,,virtual/libgl libxcb" | ||
30 | |||
31 | # Take the flags added by PACKAGECONFIG and pass them to cmake. | ||
32 | EXTRA_OECMAKE = "${EXTRA_OECONF}" | ||
33 | |||
34 | FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake" | ||