diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-05-19 11:26:24 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-05-25 14:45:21 +0200 |
commit | 5e3dc9510776c5f9ee65799732dd3a824de53a0d (patch) | |
tree | 7f5a57f9724bb1780fc21c1f230f985831131428 /meta-oe/recipes-graphics | |
parent | 90215e2729c99493a51df288a073c53691cc7b8d (diff) | |
download | meta-openembedded-5e3dc9510776c5f9ee65799732dd3a824de53a0d.tar.gz |
xserver-xorg: upgrade to 1.10.1.901 and return randr-support patch
* Thanks to Benjamin Deering for updating patch
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-assume-pixman-supports-overlapped-blt.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-fbdev-ignore-return-mode.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch | 131 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/replace-pkgconfig-sdkdir-poking.patch) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb (renamed from meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.bb) | 7 |
5 files changed, 135 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-assume-pixman-supports-overlapped-blt.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch index a947582f1..a947582f1 100644 --- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-assume-pixman-supports-overlapped-blt.patch +++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-assume-pixman-supports-overlapped-blt.patch | |||
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-fbdev-ignore-return-mode.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch index d3661cbea..d3661cbea 100644 --- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/hack-fbdev-ignore-return-mode.patch +++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/hack-fbdev-ignore-return-mode.patch | |||
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch new file mode 100644 index 000000000..d870f3972 --- /dev/null +++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/randr-support.patch | |||
@@ -0,0 +1,131 @@ | |||
1 | diff -ur xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c git/xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c | ||
2 | --- xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c 2011-04-28 09:25:00.000000000 +0200 | ||
3 | +++ git/xorg-server-1.10.1.901//hw/xfree86/common/xf86Xinput.c 2011-05-19 00:31:01.178439874 +0200 | ||
4 | @@ -99,6 +99,8 @@ | ||
5 | return; \ | ||
6 | } | ||
7 | |||
8 | +#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270) | ||
9 | + | ||
10 | EventListPtr xf86Events = NULL; | ||
11 | |||
12 | static int | ||
13 | @@ -1408,4 +1410,73 @@ | ||
14 | EnableDevice(dev, TRUE); | ||
15 | } | ||
16 | |||
17 | +/* Taken from evdev-properties.h. */ | ||
18 | +#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap" | ||
19 | +#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion" | ||
20 | + | ||
21 | +/* This is a hack until we get device -> CRTC association. */ | ||
22 | +void | ||
23 | +xf86InputRotationNotify(Rotation rotation) | ||
24 | +{ | ||
25 | + DeviceIntPtr dev; | ||
26 | + //LocalDevicePtr local; | ||
27 | + int ret; | ||
28 | + int swap_axes = 0; | ||
29 | + CARD8 invert[2] = { 0, 0 }; | ||
30 | + static Atom prop_swap = 0, prop_invert = 0; | ||
31 | + static int atom_generation = -1; | ||
32 | + | ||
33 | + if (atom_generation != serverGeneration) { | ||
34 | + prop_swap = 0; | ||
35 | + prop_invert = 0; | ||
36 | + } | ||
37 | + | ||
38 | + switch (rotation & RR_Rotate_All) { | ||
39 | + case RR_Rotate_0: | ||
40 | + swap_axes = 1; | ||
41 | + invert[0] = 0; | ||
42 | + invert[1] = 0; | ||
43 | + break; | ||
44 | + case RR_Rotate_90: | ||
45 | + swap_axes = 0; | ||
46 | + invert[0] = 0; | ||
47 | + invert[1] = 1; | ||
48 | + break; | ||
49 | + case RR_Rotate_180: | ||
50 | + swap_axes = 1; | ||
51 | + invert[0] = 0; | ||
52 | + invert[1] = 0; | ||
53 | + break; | ||
54 | + case RR_Rotate_270: | ||
55 | + swap_axes = 0; | ||
56 | + invert[0] = 0; | ||
57 | + invert[1] = 1; | ||
58 | + break; | ||
59 | + } | ||
60 | + | ||
61 | + if (!prop_swap) | ||
62 | + prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES, | ||
63 | + strlen(EVDEV_PROP_SWAP_AXES), TRUE); | ||
64 | + if (!prop_invert) | ||
65 | + prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES, | ||
66 | + strlen(EVDEV_PROP_INVERT_AXES), TRUE); | ||
67 | + | ||
68 | + for (dev = inputInfo.devices; dev; dev = dev->next) { | ||
69 | + //local = dev->public.devicePrivate; | ||
70 | + ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8, | ||
71 | + PropModeReplace, 1, &swap_axes, FALSE); | ||
72 | + if (ret != Success) { | ||
73 | + xf86Msg(X_ERROR, "Changing swap_xy property failed!\n"); | ||
74 | + continue; | ||
75 | + } | ||
76 | + ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8, | ||
77 | + PropModeReplace, 2, invert, FALSE); | ||
78 | + if (ret != Success) { | ||
79 | + xf86Msg(X_ERROR, "Changing invert property failed!\n"); | ||
80 | + continue; | ||
81 | + } | ||
82 | + } | ||
83 | +} | ||
84 | + | ||
85 | + | ||
86 | /* end of xf86Xinput.c */ | ||
87 | diff -ur xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c git/xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c | ||
88 | --- xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c 2011-04-28 09:25:00.000000000 +0200 | ||
89 | +++ git/xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c 2011-05-19 00:23:16.244383998 +0200 | ||
90 | @@ -389,6 +389,12 @@ | ||
91 | if (didLock) | ||
92 | crtc->funcs->unlock (crtc); | ||
93 | |||
94 | + /* | ||
95 | + * Rotate Touchscreen | ||
96 | + */ | ||
97 | + xf86InputRotationNotify(crtc->rotation); | ||
98 | + | ||
99 | + | ||
100 | return ret; | ||
101 | } | ||
102 | |||
103 | diff -ur xorg-server-1.10.1.901//randr/rrscreen.c git/xorg-server-1.10.1.901//randr/rrscreen.c | ||
104 | --- xorg-server-1.10.1.901//randr/rrscreen.c 2011-02-25 04:27:32.000000000 +0100 | ||
105 | +++ git/xorg-server-1.10.1.901//randr/rrscreen.c 2011-05-18 23:19:39.007760004 +0200 | ||
106 | @@ -910,11 +910,6 @@ | ||
107 | */ | ||
108 | width = mode->mode.width; | ||
109 | height = mode->mode.height; | ||
110 | - if (rotation & (RR_Rotate_90|RR_Rotate_270)) | ||
111 | - { | ||
112 | - width = mode->mode.height; | ||
113 | - height = mode->mode.width; | ||
114 | - } | ||
115 | |||
116 | if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) { | ||
117 | client->errorValue = width; | ||
118 | @@ -926,7 +921,12 @@ | ||
119 | free(pData); | ||
120 | return BadValue; | ||
121 | } | ||
122 | - | ||
123 | + if (rotation & (RR_Rotate_90|RR_Rotate_270)) | ||
124 | + { | ||
125 | + width = mode->mode.height; | ||
126 | + height = mode->mode.width; | ||
127 | + } | ||
128 | + | ||
129 | if (width != pScreen->width || height != pScreen->height) | ||
130 | { | ||
131 | int c; | ||
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/replace-pkgconfig-sdkdir-poking.patch b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch index 3967c4c73..3967c4c73 100644 --- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1/replace-pkgconfig-sdkdir-poking.patch +++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-1.10.1.901/replace-pkgconfig-sdkdir-poking.patch | |||
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.bb b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb index c02bd7105..0515a34da 100644 --- a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.bb +++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg_1.10.1.901.bb | |||
@@ -7,15 +7,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=74df27b6254cc88d2799b5f4f5949c00" | |||
7 | DESCRIPTION = "the X.Org X server" | 7 | DESCRIPTION = "the X.Org X server" |
8 | DEPENDS += "mesa-dri pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native" | 8 | DEPENDS += "mesa-dri pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native" |
9 | PE = "2" | 9 | PE = "2" |
10 | PR = "${INC_PR}.1" | 10 | PR = "${INC_PR}.2" |
11 | 11 | ||
12 | SRC_URI += " \ | 12 | SRC_URI += " \ |
13 | file://randr-support.patch \ | ||
13 | file://hack-fbdev-ignore-return-mode.patch \ | 14 | file://hack-fbdev-ignore-return-mode.patch \ |
14 | file://hack-assume-pixman-supports-overlapped-blt.patch \ | 15 | file://hack-assume-pixman-supports-overlapped-blt.patch \ |
15 | file://replace-pkgconfig-sdkdir-poking.patch \ | 16 | file://replace-pkgconfig-sdkdir-poking.patch \ |
16 | " | 17 | " |
17 | SRC_URI[md5sum] = "75f117c74f2ecaf9dd167f6a66ac98de" | 18 | SRC_URI[md5sum] = "64585a28abb18726d950cf1005bbcce4" |
18 | SRC_URI[sha256sum] = "143c7c3d7d4428352e1153dffa34fd64af391f72d30b2a03e911e54e36f00b5d" | 19 | SRC_URI[sha256sum] = "b7d775891e7e7fc3001763cf5727995b81bf07b72e12d9d41db282fe625298e6" |
19 | 20 | ||
20 | do_install_prepend() { | 21 | do_install_prepend() { |
21 | mkdir -p ${D}/${libdir}/X11/fonts | 22 | mkdir -p ${D}/${libdir}/X11/fonts |