summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xorg-driver
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-graphics/xorg-driver
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-driver')
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb10
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb2
3 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
index a604d4651..0397fb2f5 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
@@ -16,6 +16,6 @@ EXTRA_OEMAKE = "'INCLUDE=-I${STAGING_INCDIR}/xorg -I${STAGING_INCDIR}/pixman-1'"
16 16
17#skip xorg-driver-common.inc AC_CHECK_FILE mangling 17#skip xorg-driver-common.inc AC_CHECK_FILE mangling
18do_configure_prepend () { 18do_configure_prepend () {
19 sed 's#gcc#${CC}#g' -i Makefile 19 sed 's#gcc#${CC}#g' -i Makefile
20 return 20 return
21} 21}
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
index d00fb4eda..fab7fab1f 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
@@ -22,13 +22,13 @@ SRC_URI[md5sum] = "b7a4d2f11637ee3fcf432e044b1d017f"
22SRC_URI[sha256sum] = "5f46fdef095a6e44a69e0f0b57c7d665224b26d990d006611236d8332e85b105" 22SRC_URI[sha256sum] = "5f46fdef095a6e44a69e0f0b57c7d665224b26d990d006611236d8332e85b105"
23 23
24do_configure_prepend() { 24do_configure_prepend() {
25 rm -rf ${S}/m4/ || true 25 rm -rf ${S}/m4/ || true
26} 26}
27do_install_append() { 27do_install_append() {
28 install -d ${D}/${datadir}/hal/fdi/policy/20thirdparty 28 install -d ${D}/${datadir}/hal/fdi/policy/20thirdparty
29 install -m 0644 ${WORKDIR}/10-x11-input-tslib.fdi ${D}/${datadir}/hal/fdi/policy/20thirdparty 29 install -m 0644 ${WORKDIR}/10-x11-input-tslib.fdi ${D}/${datadir}/hal/fdi/policy/20thirdparty
30 install -d ${D}/lib/udev/rules.d 30 install -d ${D}/lib/udev/rules.d
31 install -m 0644 ${WORKDIR}/99-xf86-input-tslib.rules ${D}/lib/udev/rules.d/ 31 install -m 0644 ${WORKDIR}/99-xf86-input-tslib.rules ${D}/lib/udev/rules.d/
32} 32}
33 33
34FILES_${PN} += "${datadir}/hal /lib/udev" 34FILES_${PN} += "${datadir}/hal /lib/udev"
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
index f9eb3ce92..c3d83a47d 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://git.openmoko.org/git/xf86-video-glamo.git;protocol=git;branch=m
14 file://0001-fix-build-with-KMS-disabled.patch \ 14 file://0001-fix-build-with-KMS-disabled.patch \
15 file://0003-glamo-driver-adapt-to-xserver-0.13-video-API.patch \ 15 file://0003-glamo-driver-adapt-to-xserver-0.13-video-API.patch \
16 file://0001-glamo-driver-remove-references-to-mibstore.patch \ 16 file://0001-glamo-driver-remove-references-to-mibstore.patch \
17 " 17"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b" 20SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b"