diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:35:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:36:45 +0200 |
commit | cdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch) | |
tree | 42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-oe/recipes-graphics/xorg-driver | |
parent | 2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff) | |
download | meta-openembedded-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz |
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread:
https://patchwork.openembedded.org/patch/137573/
update the messages to warn possible users that the
recipe will be removed before the end of the next development
cycle (before Yocto 2.4 is released).
* updated with:
sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs`
* then noticed couple recipes being blacklisted only based on
DISTRO_FEATURES, so removed those:
meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb
meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb
meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb
meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
meta-oe/recipes-navigation/gypsy/gypsy.inc
meta-oe/recipes-navigation/navit/navit.inc
meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
* if it isn't fixed by this date, it's fair game to be removed
whenever someone gets around to i
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-driver')
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb index 547ec86c1..5f2adec1a 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543" | |||
5 | 5 | ||
6 | DEPENDS += "pixman" | 6 | DEPENDS += "pixman" |
7 | 7 | ||
8 | PNBLACKLIST[xf86-input-mtev] ?= "BROKEN: doesn't build with B!=S (Makefile without ${S} in sed call)" | 8 | PNBLACKLIST[xf86-input-mtev] ?= "BROKEN: doesn't build with B!=S (Makefile without ${S} in sed call) - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
9 | 9 | ||
10 | SRC_URI = "git://gitorious.org/xorg/xf86-input-mtev.git file://fix-it.patch" | 10 | SRC_URI = "git://gitorious.org/xorg/xf86-input-mtev.git file://fix-it.patch" |
11 | SRCREV = "1eb469166ffc095c5801475f057f911f97a6e641" | 11 | SRCREV = "1eb469166ffc095c5801475f057f911f97a6e641" |
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-geode_2.11.16.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-geode_2.11.16.bb index d26759861..e543413ad 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-geode_2.11.16.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-geode_2.11.16.bb | |||
@@ -13,4 +13,4 @@ COMPATIBLE_HOST = "i.86.*-linux" | |||
13 | RDEPENDS_${PN} += "xserver-xorg-module-exa" | 13 | RDEPENDS_${PN} += "xserver-xorg-module-exa" |
14 | 14 | ||
15 | # 2_2.11.16-r21.0/xf86-video-geode-2.11.16/src/gx_driver.c:376:20: error: implicit declaration of function 'xf86MapVidMem' [-Werror=implicit-function-declaration] | 15 | # 2_2.11.16-r21.0/xf86-video-geode-2.11.16/src/gx_driver.c:376:20: error: implicit declaration of function 'xf86MapVidMem' [-Werror=implicit-function-declaration] |
16 | PNBLACKLIST[xf86-video-geode] ?= "BROKEN, fails to build" | 16 | PNBLACKLIST[xf86-video-geode] ?= "BROKEN, fails to build - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb index 97d80c22f..5818d0cc9 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb | |||
@@ -22,4 +22,4 @@ SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b" | |||
22 | 22 | ||
23 | EXTRA_OECONF = " --disable-kms " | 23 | EXTRA_OECONF = " --disable-kms " |
24 | 24 | ||
25 | PNBLACKLIST[xf86-video-glamo] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130629/" | 25 | PNBLACKLIST[xf86-video-glamo] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130629/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.12.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.12.bb index 436c92cc4..444189a89 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.12.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.12.bb | |||
@@ -16,4 +16,4 @@ SRC_URI[md5sum] = "dc79910c7b9e32321cefc7af250c7765" | |||
16 | SRC_URI[sha256sum] = "0ea057ad7fc31caba2d4e46c7e418fe2b3c762b04fb8d382f53383397fd8391e" | 16 | SRC_URI[sha256sum] = "0ea057ad7fc31caba2d4e46c7e418fe2b3c762b04fb8d382f53383397fd8391e" |
17 | 17 | ||
18 | 18 | ||
19 | PNBLACKLIST[xf86-video-nouveau] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130657/" | 19 | PNBLACKLIST[xf86-video-nouveau] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130657/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" |