diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-29 18:28:56 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-29 19:18:27 -0700 |
commit | 5ce7a2a89b9447e14f6cb60a0af9128987478a78 (patch) | |
tree | 3bbfefff83ff00c8a7d1004e03dd54e19ffaabc2 /meta-oe/recipes-graphics/xorg-app | |
parent | 3e1007146c8d01839112043d625a8495b4947b87 (diff) | |
download | meta-openembedded-5ce7a2a89b9447e14f6cb60a0af9128987478a78.tar.gz |
xterm: Add _GNU_SOURCE via CFLAGS
This ensures that definitions of functions e.g. ptsname and wcwidth are
added correctly.
Fixes
| ./main.c:2940:8: error: incompatible integer to pointer conversion initializing 'char *' with an expression of type 'int' [-Wint-conversion]
| char *name = ptsname(*pty);
| ^ ~~~~~~~~~~~~~
| ./util.c:5506:19: error: use of undeclared identifier 'wcwidth'
| my_wcwidth = wcwidth;
| ^
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-app')
-rw-r--r-- | meta-oe/recipes-graphics/xorg-app/xterm_373.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_373.bb b/meta-oe/recipes-graphics/xorg-app/xterm_373.bb index 7e36f475c..bc555cbcd 100644 --- a/meta-oe/recipes-graphics/xorg-app/xterm_373.bb +++ b/meta-oe/recipes-graphics/xorg-app/xterm_373.bb | |||
@@ -27,6 +27,8 @@ EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \ | |||
27 | 27 | ||
28 | B = "${S}" | 28 | B = "${S}" |
29 | 29 | ||
30 | CFLAGS += "-D_GNU_SOURCE" | ||
31 | |||
30 | do_configure() { | 32 | do_configure() { |
31 | gnu-configize --force | 33 | gnu-configize --force |
32 | sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure | 34 | sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure |