diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 14:40:23 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:04 +0200 |
commit | f2b3287cc162169028ad59e9fc5ebde8e03cbb04 (patch) | |
tree | f149602f36a6a9c1bbd7cf3f7bd2c584e202003a /meta-oe/recipes-graphics/xinput-calibrator | |
parent | ca1f7c0399905206be0bc5f36fc0c881b915e4f0 (diff) | |
download | meta-openembedded-f2b3287cc162169028ad59e9fc5ebde8e03cbb04.tar.gz |
xinput-calibrator: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/xinput-calibrator')
-rw-r--r-- | meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service | 11 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb | 15 |
2 files changed, 23 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service new file mode 100644 index 000000000..23018768d --- /dev/null +++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Loads xinput calibration data | ||
3 | ConditionPathExists=/etc/pointercal.xinput | ||
4 | Requires=display-manager.service | ||
5 | After=display-manager.service | ||
6 | |||
7 | [Service] | ||
8 | ExecStart=/usr/bin/xinput_calibrator_once.sh | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb index 97f934380..b01f62dab 100644 --- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb +++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb | |||
@@ -5,12 +5,13 @@ LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f340 | |||
5 | DEPENDS = "virtual/libx11 libxi" | 5 | DEPENDS = "virtual/libx11 libxi" |
6 | 6 | ||
7 | PV = "0.7.5+git${SRCPV}" | 7 | PV = "0.7.5+git${SRCPV}" |
8 | PR = "r1" | 8 | PR = "r5" |
9 | 9 | ||
10 | inherit autotools | 10 | inherit autotools systemd |
11 | 11 | ||
12 | SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111" | 12 | SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111" |
13 | SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git" | 13 | SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git \ |
14 | file://xinput-calibrator.service" | ||
14 | 15 | ||
15 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
16 | 17 | ||
@@ -24,8 +25,16 @@ do_install_append() { | |||
24 | install -d ${D}${sysconfdir}/xdg/autostart | 25 | install -d ${D}${sysconfdir}/xdg/autostart |
25 | sed -i -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' scripts/xinput_calibrator.desktop | 26 | sed -i -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' scripts/xinput_calibrator.desktop |
26 | install -m 0644 scripts/xinput_calibrator.desktop ${D}${sysconfdir}/xdg/autostart | 27 | install -m 0644 scripts/xinput_calibrator.desktop ${D}${sysconfdir}/xdg/autostart |
28 | |||
29 | install -d ${D}${systemd_unitdir}/system | ||
30 | install -m 0644 ${WORKDIR}/xinput-calibrator.service ${D}${systemd_unitdir}/system | ||
27 | } | 31 | } |
28 | 32 | ||
29 | FILES_${PN} += "${sysconfdir}/xdg/autostart" | 33 | FILES_${PN} += "${sysconfdir}/xdg/autostart" |
30 | RDEPENDS_${PN} = "xinput xterm" | 34 | RDEPENDS_${PN} = "xinput xterm" |
31 | RRECOMMENDS_${PN} = "pointercal-xinput" | 35 | RRECOMMENDS_${PN} = "pointercal-xinput" |
36 | |||
37 | RPROVIDES_${PN} += "${PN}-systemd" | ||
38 | RREPLACES_${PN} += "${PN}-systemd" | ||
39 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
40 | SYSTEMD_SERVICE_${PN} = "${PN}.service" | ||