diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-graphics/ttf-fonts | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/ttf-fonts')
6 files changed, 19 insertions, 19 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb index bcc797cc2..72bc2d255 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb | |||
@@ -20,8 +20,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \ | |||
20 | S = "${WORKDIR}/dejavu-fonts-ttf-${PV}/ttf" | 20 | S = "${WORKDIR}/dejavu-fonts-ttf-${PV}/ttf" |
21 | 21 | ||
22 | do_install_append () { | 22 | do_install_append () { |
23 | install -d ${D}${sysconfdir}/fonts/conf.d/ | 23 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
24 | install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ | 24 | install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
25 | } | 25 | } |
26 | 26 | ||
27 | PACKAGES = "\ | 27 | PACKAGES = "\ |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb index a96bc5111..c1180b87c 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/android/platform_frameworks_base.git;protocol=git;br | |||
13 | S = "${WORKDIR}/git/data/fonts" | 13 | S = "${WORKDIR}/git/data/fonts" |
14 | 14 | ||
15 | do_install_prepend() { | 15 | do_install_prepend() { |
16 | rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it | 16 | rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it |
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES = "ttf-droid-sans ttf-droid-sans-mono \ | 19 | PACKAGES = "ttf-droid-sans ttf-droid-sans-mono \ |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb index 8359bd88f..129e1375a 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb | |||
@@ -7,20 +7,20 @@ LIC_FILES_CHKSUM = "file://../OFL.txt;md5=969851e3a70122069a4d9ee61dd5a2ed" | |||
7 | PR = "r0" | 7 | PR = "r0" |
8 | 8 | ||
9 | SRC_URI = "http://levien.com/type/myfonts/Inconsolata.otf \ | 9 | SRC_URI = "http://levien.com/type/myfonts/Inconsolata.otf \ |
10 | file://OFL.txt" | 10 | file://OFL.txt" |
11 | 11 | ||
12 | S = "${WORKDIR}/ttf-inconsolata-${PV}" | 12 | S = "${WORKDIR}/ttf-inconsolata-${PV}" |
13 | 13 | ||
14 | FILES_${PN} = "${datadir}/fonts/truetype/Inconsolata.ttf \ | 14 | FILES_${PN} = "${datadir}/fonts/truetype/Inconsolata.ttf \ |
15 | ${datadir}/doc/ttf-inconsolata/*" | 15 | ${datadir}/doc/ttf-inconsolata/*" |
16 | 16 | ||
17 | do_configure() { | 17 | do_configure() { |
18 | mv ${WORKDIR}/Inconsolata.otf ${S}/Inconsolata.ttf | 18 | mv ${WORKDIR}/Inconsolata.otf ${S}/Inconsolata.ttf |
19 | } | 19 | } |
20 | 20 | ||
21 | do_install_append() { | 21 | do_install_append() { |
22 | install -d ${D}${datadir}/doc/ttf-inconsolata/ | 22 | install -d ${D}${datadir}/doc/ttf-inconsolata/ |
23 | install -m 0644 ${WORKDIR}/OFL.txt ${D}${datadir}/doc/ttf-inconsolata/ | 23 | install -m 0644 ${WORKDIR}/OFL.txt ${D}${datadir}/doc/ttf-inconsolata/ |
24 | } | 24 | } |
25 | 25 | ||
26 | SRC_URI[md5sum] = "0fbe014c1f0fb5e3c71140ff0dc63edf" | 26 | SRC_URI[md5sum] = "0fbe014c1f0fb5e3c71140ff0dc63edf" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb index 52379449d..d2e84c2e2 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb | |||
@@ -18,8 +18,8 @@ python populate_packages_prepend() { | |||
18 | } | 18 | } |
19 | 19 | ||
20 | do_install() { | 20 | do_install() { |
21 | install -d ${D}${datadir}/fonts/ttf-mplus | 21 | install -d ${D}${datadir}/fonts/ttf-mplus |
22 | install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/ | 22 | install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/ |
23 | } | 23 | } |
24 | 24 | ||
25 | SRC_URI[md5sum] = "d1400184b51b3871e8d2fca6c50e18ae" | 25 | SRC_URI[md5sum] = "d1400184b51b3871e8d2fca6c50e18ae" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb index d88373489..0390740de 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb | |||
@@ -23,12 +23,12 @@ FILES_ttf-sazanami-mincho = "${datadir}/fonts/truetype/sazanami-mincho.ttf \ | |||
23 | ${datadir}/doc/ttf-sazanami-mincho/README" | 23 | ${datadir}/doc/ttf-sazanami-mincho/README" |
24 | 24 | ||
25 | do_install_append() { | 25 | do_install_append() { |
26 | # README contains the redistribution license | 26 | # README contains the redistribution license |
27 | install -d ${D}${datadir}/doc/ | 27 | install -d ${D}${datadir}/doc/ |
28 | install -d ${D}${datadir}/doc/ttf-sazanami-gothic | 28 | install -d ${D}${datadir}/doc/ttf-sazanami-gothic |
29 | install -d ${D}${datadir}/doc/ttf-sazanami-mincho | 29 | install -d ${D}${datadir}/doc/ttf-sazanami-mincho |
30 | install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-gothic | 30 | install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-gothic |
31 | install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-mincho | 31 | install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-mincho |
32 | } | 32 | } |
33 | 33 | ||
34 | SRC_URI[md5sum] = "ceef10579a75c92483171f3bd7f77df2" | 34 | SRC_URI[md5sum] = "ceef10579a75c92483171f3bd7f77df2" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb index 6095386db..88fca6c51 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb | |||
@@ -11,9 +11,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz" | |||
11 | S = "${WORKDIR}/wqy-zenhei" | 11 | S = "${WORKDIR}/wqy-zenhei" |
12 | 12 | ||
13 | do_install_append () { | 13 | do_install_append () { |
14 | install -d ${D}${sysconfdir}/fonts/conf.d/ | 14 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
15 | install -m 0644 ${S}/44-wqy-zenhei.conf ${D}${sysconfdir}/fonts/conf.d/ | 15 | install -m 0644 ${S}/44-wqy-zenhei.conf ${D}${sysconfdir}/fonts/conf.d/ |
16 | install -m 0644 ${S}/66-wqy-zenhei-sharp.conf ${D}${sysconfdir}/fonts/conf.d/ | 16 | install -m 0644 ${S}/66-wqy-zenhei-sharp.conf ${D}${sysconfdir}/fonts/conf.d/ |
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES = "${PN}" | 19 | PACKAGES = "${PN}" |