summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
commitc58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch)
tree3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
parenteec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff)
downloadmeta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz
move layer into meta-oe in preparation for future splits
As per TSC decision Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb')
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb135
1 files changed, 135 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
new file mode 100644
index 000000000..698b2edf8
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
@@ -0,0 +1,135 @@
1require ttf.inc
2
3DESCRIPTION = "Gentium fonts - TTF Version"
4HOMEPAGE = "http://scripts.sil.org/gentium"
5LICENSE = "SIL Open Font License"
6LICENSE_URL = "http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=OFL"
7PR = "r3"
8
9SRC_URI = "${DEBIAN_MIRROR}/main/t/ttf-gentium/ttf-gentium_${PV}.orig.tar.gz \
10 file://OFL.gz"
11
12S = "${WORKDIR}/ttf-sil-gentium-${PV}"
13
14do_install_append() {
15
16 install -d ${D}${datadir}/doc/ttf-gentium/
17 install -d ${D}${datadir}/doc/ttf-gentium-alt/
18
19 install -m 0644 ${WORKDIR}/OFL ${D}${datadir}/doc/ttf-gentium/
20 install -m 0644 ${WORKDIR}/OFL ${D}${datadir}/doc/ttf-gentium-alt/
21
22}
23
24PACKAGES = "${PN}-dbg ${PN} ${PN}-alt"
25
26FILES_ttf-gentium-alt = "${datadir}/fonts/truetype/GenAI*.ttf \
27 ${datadir}/fonts/truetype/GenAR*.ttf \
28 ${datadir}/doc/ttf-gentium-alt/*"
29
30FILES_${PN} = "${datadir}/fonts/truetype/GenI*.ttf \
31 ${datadir}/fonts/truetype/GenR*.ttf \
32 ${datadir}/doc/ttf-gentium/*"
33
34#
35# License
36#
37# Gentium is released under the SIL Open Font License - please read it carefully
38# and do not download the fonts unless you agree to the terms of the license:
39#
40# This Font Software is Copyright (c) 2003-2005, SIL International
41# (http://scripts.sil.org/). All Rights Reserved.
42#
43# "Gentium" is a Reserved Font Name for this Font Software. "SIL" is a Reserved
44# Font Name for this Font Software.
45#
46# This Font Software is licensed under the SIL Open Font License, Version 1.0. No
47# modification of the license is permitted, only verbatim copy is allowed. This
48# license is copied below, and is also available with a FAQ
49# at:http://scripts.sil.org/OFL SIL OPEN FONT LICENSE
50#
51# Version 1.0 - 22 November 2005
52#
53# PREAMBLE
54#
55# The goals of the Open Font License (OFL) are to stimulate worldwide development
56# of cooperative font projects, to support the font creation efforts of academic
57# and linguistic communities, and to provide an open framework in which fonts may
58# be shared and improved in partnership with others.
59#
60# The OFL allows the licensed fonts to be used, studied, modified and
61# redistributed freely as long as they are not sold by themselves. The fonts,
62# including any derivative works, can be bundled, embedded, redistributed and
63# sold with any software provided that the font names of derivative works are
64# changed. The fonts and derivatives, however, cannot be released under any other
65# type of license.
66#
67# DEFINITIONS
68#
69# "Font Software" refers to any and all of the following:
70#
71# * font files data files source code build scripts documentation
72#
73# "Reserved Font Name" refers to the Font Software name as seen by users and any
74# other names as specified after the copyright statement.
75#
76# "Standard Version" refers to the collection of Font Software components as
77# distributed by the Copyright Holder.
78#
79# "Modified Version" refers to any derivative font software made by adding to,
80# deleting, or substituting -- in part or in whole -- any of the components of
81# the Standard Version, by changing formats or by porting the Font Software to a
82# new environment.
83#
84# "Author" refers to any designer, engineer, programmer, technical writer or
85# other person who contributed to the Font Software.
86#
87# PERMISSION & CONDITIONS
88#
89# Permission is hereby granted, free of charge, to any person obtaining a copy of
90# the Font Software, to use, study, copy, merge, embed, modify, redistribute, and
91# sell modified and unmodified copies of the Font Software, subject to the
92# following conditions:
93#
94# 1) Neither the Font Software nor any of its individual components, in Standard
95# or Modified Versions, may be sold by itself.
96#
97# 2) Standard or Modified Versions of the Font Software may be bundled,
98# redistributed and sold with any software, provided that each copy contains the
99# above copyright notice and this license. These can be included either as
100# stand-alone text files, human-readable headers or in the appropriate
101# machine-readable metadata fields within text or binary files as long as those
102# fields can be easily viewed by the user.
103#
104# 3) No Modified Version of the Font Software may use the Reserved Font Name(s),
105# in part or in whole, unless explicit written permission is granted by the
106# Copyright Holder. This restriction applies to all references stored in the Font
107# Software, such as the font menu name and other font description fields, which
108# are used to differentiate the font from others.
109#
110# 4) The name(s) of the Copyright Holder or the Author(s) of the Font Software
111# shall not be used to promote, endorse or advertise any Modified Version, except
112# to acknowledge the contribution(s) of the Copyright Holder and the Author(s) or
113# with their explicit written permission.
114#
115# 5) The Font Software, modified or unmodified, in part or in whole, must be
116# distributed using this license, and may not be distributed under any other
117# license.
118#
119# TERMINATION
120#
121# This license becomes null and void if any of the above conditions are not met.
122#
123# DISCLAIMER
124#
125# THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
126# IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY,
127# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF COPYRIGHT, PATENT,
128# TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE LIABLE FOR
129# ANY CLAIM, DAMAGES OR OTHER LIABILITY, INCLUDING ANY GENERAL, SPECIAL,
130# INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN AN ACTION OF
131# CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF THE USE OR INABILITY TO USE
132# THE FONT SOFTWARE OR FROM OTHER DEALINGS IN THE FONT SOFTWARE.
133
134SRC_URI[md5sum] = "4c3e6ae586be277537ebb68f2a45b883"
135SRC_URI[sha256sum] = "4746c04c9a4ad9e0788a38e0a2f81919a630d8070ceabc89f156b6d41d8ceb37"