summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/tslib/tslib_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-20 23:20:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-23 19:21:56 +0200
commit53638b464d84700f26290b50ffb9430d322d5a31 (patch)
tree38988c58ee3751511dd3540e32111cd096598638 /meta-oe/recipes-graphics/tslib/tslib_git.bb
parent5d92a2a27213aa9563b926bc3e2e9dbac54624a3 (diff)
downloadmeta-openembedded-53638b464d84700f26290b50ffb9430d322d5a31.tar.gz
tslib: remove
A newer recipe is now in OE-Core. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/tslib/tslib_git.bb')
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_git.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib_git.bb b/meta-oe/recipes-graphics/tslib/tslib_git.bb
deleted file mode 100644
index b653978d4..000000000
--- a/meta-oe/recipes-graphics/tslib/tslib_git.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "An abstraction layer for touchscreen panel events."
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.berlios.de/"
7
8AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
9SECTION = "base"
10LICENSE = "LGPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
12
13PR = "r1"
14
15DEFAULT_PREFERENCE = "-1"
16
17SRC_URI = "git://github.com/kergoth/tslib.git;protocol=git \
18 file://obsolete_automake_macros.patch \
19 file://ts.conf \
20 file://tslib.sh"
21SRCREV = "e17263ef401ee885a27d649b90b577cfb44500e0"
22S = "${WORKDIR}/git"
23
24PV = "1.0+gitr${SRCPV}"
25
26inherit autotools pkgconfig
27
28EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
29
30do_install_prepend() {
31 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
32}
33
34do_install_append() {
35 install -d ${D}${sysconfdir}/profile.d/
36 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
37}
38
39SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
40
41# People should consider using udev's /dev/input/touchscreen0 symlink
42# instead of detect-stylus
43#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
44RPROVIDES_tslib-conf = "libts-0.0-conf"
45
46PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
47DEBIAN_NOAUTONAME_tslib-conf = "1"
48DEBIAN_NOAUTONAME_tslib-tests = "1"
49DEBIAN_NOAUTONAME_tslib-calibrate = "1"
50
51RDEPENDS_${PN} = "tslib-conf"
52RRECOMMENDS_${PN} = "pointercal"
53
54FILES_${PN}-dbg += "${libdir}/ts/.debug*"
55FILES_${PN}-dev += "${libdir}/ts/*.la"
56FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
57FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
58FILES_tslib-calibrate += "${bindir}/ts_calibrate"
59FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"