summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/terminus-font
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commit21f10c11f39020f9502d741c774a12d1aeb39499 (patch)
treefdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-graphics/terminus-font
parent723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff)
downloadmeta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/terminus-font')
-rw-r--r--meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
index 337cde426..e5bea97d9 100644
--- a/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
+++ b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
@@ -16,11 +16,11 @@ SRC_URI[sha256sum] = "f6f4876a4dabe6a37c270c20bb9e141e38fb50e0bba200e1b9d0470e5e
16 16
17inherit allarch fontcache 17inherit allarch fontcache
18 18
19PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 19PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
20PACKAGECONFIG[x11] = "" 20PACKAGECONFIG[x11] = ""
21 21
22# Don't use font cache mecanism for console packages 22# Don't use font cache mecanism for console packages
23FONT_PACKAGES = "${@base_contains('PACKAGECONFIG', 'x11', '${PN}-pcf', '', d)}" 23FONT_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '${PN}-pcf', '', d)}"
24 24
25# Hand made configure script. Don't need oe_runconf 25# Hand made configure script. Don't need oe_runconf
26do_configure() { 26do_configure() {
@@ -32,11 +32,11 @@ do_configure() {
32} 32}
33 33
34do_compile() { 34do_compile() {
35 oe_runmake DESTDIR=${D} psf txt ${@base_contains('PACKAGECONFIG', 'x11', 'pcf', '', d)} 35 oe_runmake DESTDIR=${D} psf txt ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'pcf', '', d)}
36} 36}
37 37
38do_install() { 38do_install() {
39 oe_runmake DESTDIR=${D} install-psf install-acm ${@base_contains('PACKAGECONFIG', 'x11', 'install-pcf', '', d)} 39 oe_runmake DESTDIR=${D} install-psf install-acm ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'install-pcf', '', d)}
40} 40}
41 41
42PACKAGES += "${PN}-consolefonts ${PN}-consoletrans ${PN}-pcf" 42PACKAGES += "${PN}-consolefonts ${PN}-consoletrans ${PN}-pcf"